Connecting to a Wireless Network using Encryption

Issues related to configuring your network

Connecting to a Wireless Network using Encryption

Postby Driv3r912 » 2009/04/05 00:47:37

Hello everyone, I recently downloaded and installed CentOS 5.3 DVD media. The media check passed. I proceed to install the operating system sucessfully. After installation, all my hardware is recognized, when compared to CentOS 5.2. Anyway, when I attempt to connect to my wireless network that uses either WEP/WPA/WPA2-- I get an error message that I cannot recall (it basically only came up when I entered the key) However, I can connect to my wireless network when it is unencrypted and no open/shared key is needed. Does anyone know how to resolve this. I would like to be able to connect to my wireless network when

FYI: I am using a RealTek RTL8185 Wireless Driver

Also, I use CentOS as a workstation.



Many thanks to all,
Driv3r912,
Nicholas --
Driv3r912
 
Posts: 3
Joined: 2009/04/05 00:43:42

Re: Connecting to a Wireless Network using Encryption

Postby Driv3r912 » 2009/04/05 04:55:00

The exact error message is:

Error for wireless request "Set Encode" (8B2A) :
SET failed on device wlan0 ; Invalid argument.


And then the system attempts to retrieve an IP Address which fails.



Any ideas?
Driv3r912
 
Posts: 3
Joined: 2009/04/05 00:43:42

Connecting to a Wireless Network using Encryption

Postby scottro » 2009/04/05 07:57:27

Are you doing this through command line?

Please give a few more details. (Take a look at the read this first links, they help in deciding what you should post.)
scottro
Forum Moderator
 
Posts: 1713
Joined: 2007/09/03 21:18:09
Location: NYC

Re: Connecting to a Wireless Network using Encryption

Postby Driv3r912 » 2009/04/05 15:39:02

Sorry scottro,

No, I am not attempting to connect to the wireless network through the command line. I am using the Network Configuration Manager (system-config-network). I click on my wireless adapter, and click on the Edit button. A window appears titled "Wireless Device Configuration". I click on the "Wireless Settings" tab. In that tab, I set the Wireless Mode to Managed. Then in the "Network Name (SSID)" area, I select the "specified" radio button and type in my wireless network's SSID.

Here comes the trouble. The next piece of information is authentication. In the drop down box I can select "None, Open system (open), Shared Key (restricted)".

I select either Open system or Shared Key and enter the key in the cooresponding box below it, and then click "OK". We are now taken back to the network configuration screen. I save my changes and close the Network Configuration manager. Then I reopen it, select my wireless adapter and click the "Activate" button. A dialog box opens and states the following:

"Error for wireless request "Set Encode" (8B2A) :
SET failed on device wlan0 ; Invalid argument."

"Obtaining IP Address for wlan0"


At this point, a minute will pass and it will state that it failed.



However, in doing so, if I were to select "None" as my authentication in the Wireless Device Configurations' Wireless Settings Tab, it will connect to my wireless network (when I set the wireless access point to unencrypted).



Hope that in-depth detail helps anyone.




Thanks,
Driv3r912,
Nicholas --
Driv3r912
 
Posts: 3
Joined: 2009/04/05 00:43:42

Re: Connecting to a Wireless Network using Encryption

Postby scottro » 2009/04/05 17:26:48

Ok, let's try doing it from command line.

Take a look at http://home.roadrunner.com/~computertai ... eless.html

There's a simple howto of mine and a link to a more complex howto as well.

To review it briefly. Make sure NetworkMangler--errm Manager, isn't running and won't run on boot.

chkconfig NetworkManager off

Then reboot, because it's a Gnome thing and they're like Windows. Seriously, it seems to do all sorts of other things, and even stopping those things manually doesn't always work, at least for me. I've never investigated it that thoroughly because I turn it off anyway.

Make sure that in /etc/sysconfig/network-scripts/ifcfg-wlan0 it does NOT say NM_CONTROLLED=yes (or anything similar, I might have the syntax wrong.)

Then reboot, be sure to bring the card up with ifconfig wlan0 up.

From there, you can look at the link above and create a simple wpa_supplicant.conf file. Actually, for testing purposes, you can just do something like wpa_passphrase blah blah > wpa.conf (in whatever directory you happen to be.) Then you can check if it's working with wpa_supplicant -Dwext -iwlan0 -cwpa.conf (The -c is the config file, and this way, you can use the test file without worrying about your default wpa_supplicant.conf.
scottro
Forum Moderator
 
Posts: 1713
Joined: 2007/09/03 21:18:09
Location: NYC


Return to CentOS 5 - Networking Support

Who is online

Users browsing this forum: No registered users and 3 guests