[SOLVED] VLAN over bond interface. Can't get Incoming statistics

Issues related to configuring your network

[SOLVED] VLAN over bond interface. Can't get Incoming statistics

Postby ALex_hha » 2012/01/11 15:06:50

It seems that vlan interfaces over bond doesn't work correctly. Specifically traffic statistics

I have the following network config

Code: Select all
# cat /etc/sysconfig/network-scripts/ifcfg-bond1
DEVICE=bond1
ONBOOT=yes
BOOTPROTO=none

# cat /etc/sysconfig/network-scripts/ifcfg-bond1.210
# Intel Corporation 82576 Gigabit Network Connection
DEVICE=bond1.210
BOOTPROTO=none
IPADDR=192.168.210.1
NETMASK=255.255.255.0
ONBOOT=yes
VLAN=yes

# cat /etc/sysconfig/network-scripts/ifcfg-eth2
# Intel Corporation 82576 Gigabit Network Connection
DEVICE=eth2
BOOTPROTO=none
ONBOOT=yes
HWADDR=00:1B:21:63:55:44
MASTER=bond1
SLAVE=yes

# cat /etc/sysconfig/network-scripts/ifcfg-eth3
# Intel Corporation 82576 Gigabit Network Connection
DEVICE=eth3
BOOTPROTO=none
ONBOOT=yes
HWADDR=00:1B:21:63:55:45
MASTER=bond1
SLAVE=yes

# cat /proc/net/bonding/bond1
Ethernet Channel Bonding Driver: v3.4.0-1 (October 7, 2008)

Bonding Mode: load balancing (xor)
Transmit Hash Policy: layer2 (0)
MII Status: up
MII Polling Interval (ms): 80
Up Delay (ms): 0
Down Delay (ms): 0

Slave Interface: eth2
MII Status: up
Speed: 1000 Mbps
Duplex: full
Link Failure Count: 0
Permanent HW addr: 00:1b:21:63:55:44

Slave Interface: eth3
MII Status: up
Speed: 1000 Mbps
Duplex: full
Link Failure Count: 0
Permanent HW addr: 00:1b:21:63:55:45


But when I try to get statistics of the interface I can't see any Incoming data
Code: Select all
# cat /proc/net/dev | grep bond1.210
bond1.210:       0       0    0    0    0     0          0         0 101106032062 446733933    0    0    0     0       0          0


At the same time on eth2/eth3 all shows correctly
Code: Select all
# cat /proc/net/dev | grep eth2
  eth2:2401029223576 2945035953    0    0    0     0          0    262013 1753706319816 2729232623    0    0    0     0       0          0

# cat /proc/net/dev | grep eth3
  eth3:1342749003523 1755079950    0    0    0     0          0    365234 1620089577678 1939377201    0    0    0     0       0          0


I ran into this problem when I try to draw pps statistic (packet per second) via zabbix
ALex_hha
 
Posts: 89
Joined: 2010/04/07 13:02:13

Re: VLAN over bond interface. Can't get Incoming statistics

Postby ALex_hha » 2012/01/12 12:46:28

On CentOS-6.2 all works fine

Code: Select all
# cat /proc/net/dev
Inter-|   Receive                                                |  Transmit
 face |bytes    packets errs drop fifo frame compressed multicast|bytes    packets errs drop fifo colls carrier compressed
    lo:       0       0    0    0    0     0          0         0        0       0    0    0    0     0       0          0
  eth0:   23152     224    0    0    0     0          0         0    21893     171    0    0    0     0       0          0
  eth1:    4308      44    0    0    0     0          0         0    21303     196    0    0    0     0     164          0
 bond0:   27460     268    0    0    0     0          0         0    43196     367    0    0    0     0     164          0
bond0.212:    4136      50    0    0    0     0          0         0     5116      56    0    0    0     0       0          0
ALex_hha
 
Posts: 89
Joined: 2010/04/07 13:02:13

Re: VLAN over bond interface. Can't get Incoming statistics

Postby ALex_hha » 2012/01/14 16:55:23

Аny suggestion?
ALex_hha
 
Posts: 89
Joined: 2010/04/07 13:02:13

Re: VLAN over bond interface. Can't get Incoming statistics

Postby TrevorH » 2012/01/14 17:51:02

Since everything in /proc comes from the kernel or from kernel modules, anything that's missing must be because of a bug in the kernel. You can either report the problem on the upstream bugzilla and hope that they deem it important enough to fix (I have my doubts) or you can use a different kernel. The ELRepo has a kernel-ml repo which is disabled by default and that contains a recompiled mainline kernel that you could try but be aware that it takes you outside the realms of CentOS support.
User avatar
TrevorH
Forum Moderator
 
Posts: 9071
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: VLAN over bond interface. Can't get Incoming statistics

Postby ALex_hha » 2012/01/14 23:33:29

you could try but be aware that it takes you outside the realms of CentOS support.

I am not so brave to test such kernel in the production environment ;) But I will try on the test box

You can either report the problem on the upstream bugzilla and hope that they deem it important enough to fix (I have my doubts)

Can I create report about this problem even if I use CentOS, not RHEL? (I know that CentOS binary compatible with RHEL). If I can, what should I specify in system description - CentOS or RHEL? :)
ALex_hha
 
Posts: 89
Joined: 2010/04/07 13:02:13

[SOLVED] VLAN over bond interface. Can't get Incoming statis

Postby pschaff » 2012/01/15 00:39:50

Upstream Bugzilla has an entry for CentOS under External Bugs. It would be best to first report it for CentOS and let the CentOS developers decide if it needs to go upstream. If it does they may either make the report, or ask you to do so.
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America

Re: VLAN over bond interface. Can't get Incoming statistics

Postby ALex_hha » 2012/01/15 13:33:08

Thanks, but it seems there is no need. See https://www.centos.org/modules/newbb/vi ... 6&forum=40
ALex_hha
 
Posts: 89
Joined: 2010/04/07 13:02:13

Re: VLAN over bond interface. Can't get Incoming statistics

Postby pschaff » 2012/01/15 14:45:15

OK - so does that mean both threads can be marked [SOLVED]?
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America

Re: VLAN over bond interface. Can't get Incoming statistics

Postby ALex_hha » 2012/01/15 19:03:51

I think so, but unfortunately I can't say what exactly cause issue with Incoming statistics

If I can tomorrow I will try to reproduce this issue on the test box with RHEL-5.7. Anyway I will inform you.
ALex_hha
 
Posts: 89
Joined: 2010/04/07 13:02:13

Re: VLAN over bond interface. Can't get Incoming statistics

Postby pschaff » 2012/01/15 23:19:51

Standing by...
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America

Next

Return to CentOS 5 - Networking Support

Who is online

Users browsing this forum: No registered users and 1 guest