slow hard drive on centos 5.2

Installing, Configuring, Troubleshooting server daemons such as Web and Mail

slow hard drive on centos 5.2

Postby counterstrike » 2008/09/05 07:49:55

I have centos 5.2 on two identical machines

both have Gigabyte motherboards with intel P35 shipsets and WD raptor 10k rpm hard drives.

One of them is very slow when copying files and tar -c/-x but the other works much faster.

Also, this on this slower machine, when I start to copy big file with MC, it starts fast, and stops, and then proceeds and stops several times until 100%, but on the other machine, it never stops it just runs to 100% pretty fast :S

What could this be ?

Fresh installations on both? Text mode only
Dedicated root server.
counterstrike
 
Posts: 28
Joined: 2008/08/31 04:11:56

Re: slow hard drive on centos 5.2

Postby gerald_clark » 2008/09/05 13:51:49

Sounds like a DMA not enabled problem.
What does hdparm say?
gerald_clark
 
Posts: 7174
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Re: slow hard drive on centos 5.2

Postby counterstrike » 2008/09/06 06:27:38

Ok, so I have 5 machines, all of them are q6600 cpu, 8 GB ddr2 (667 and 800) ram, and gigabyte MBoards with P35 chipsets supporting sata2
Hard drives on all machines are WD raptor 10000 rpm

Measurments are taken 3 times, and all are the same so I will post only one

machine1 (ddr2 667, centos 5): - slow copying
Code: Select all
sudo hdparm -tT /dev/hda

/dev/hda:
 Timing cached reads:   7092 MB in  2.00 seconds = 3549.96 MB/sec
 Timing buffered disk reads:   12 MB in  3.58 seconds =   3.35 MB/sec
-bash-3.1# sudo hdparm -tT /dev/hda



machine2 (ddr2 667, centos 5):slow copying
Code: Select all
sudo hdparm -tT /dev/hda

/dev/hda:
 Timing cached reads:   8528 MB in  2.00 seconds = 4273.22 MB/sec
 Timing buffered disk reads:   10 MB in  3.67 seconds =   2.73 MB/sec



machine3 (ddr2 800, centos 5.1):fast copying
Code: Select all
 sudo hdparm -tT /dev/sda

/dev/sda:
 Timing cached reads:   7084 MB in  2.00 seconds = 3545.05 MB/sec
 Timing buffered disk reads:  104 MB in  3.05 seconds =  34.09 MB/sec



machine4 (ddr2 800, centos 5.2):slow copying
Code: Select all
 sudo hdparm -tT /dev/hda

/dev/hda:
 Timing cached reads:   13332 MB in  1.99 seconds = 6692.07 MB/sec
 Timing buffered disk reads:   10 MB in  3.46 seconds =   2.89 MB/sec



machine5 (ddr2 800, centos 5.2):fast copying
Code: Select all
 sudo hdparm -tT /dev/sda

/dev/sda:
 Timing cached reads:   10520 MB in  1.99 seconds = 5283.87 MB/sec
 Timing buffered disk reads:  250 MB in  3.01 seconds =  82.97 MB/sec


hmmmm, I have noticed that there is "low buffered disk reads" on machines with hda devices, and those machines are slow,
machines with device sda are ok...

how can I solve that ?

Also:
Code: Select all
sudo hdparm -I /dev/hda | grep SATA
           *    SATA-I signaling speed (1.5Gb/s)

But my motherboards are sata2, and hard drives are sata2, and bios supports sata2 :S
counterstrike
 
Posts: 28
Joined: 2008/08/31 04:11:56

Re: slow hard drive on centos 5.2

Postby counterstrike » 2008/09/06 07:48:34

omg look at this:

Code: Select all
hdparm /dev/hda

/dev/hda:
 multcount    = 16 (on)
 IO_support   =  0 (default 16-bit)
 unmaskirq    =  0 (off)
 using_dma    =  0 (off)
 keepsettings =  0 (off)
 readonly     =  0 (off)
 readahead    = 256 (on)
 geometry     = 16383/255/63, sectors = 145226112, start = 0


and:
Code: Select all
 hdparm -d1 /dev/hda

/dev/hda:
 setting using_dma to 1 (on)
 HDIO_SET_DMA failed: Operation not permitted
 using_dma    =  0 (off)



what now ? :(
counterstrike
 
Posts: 28
Joined: 2008/08/31 04:11:56

Re: slow hard drive on centos 5.2

Postby counterstrike » 2008/09/06 09:53:40

I gound this on the google

Code: Select all
Em Quarta 31 Maio 2006 15:59, Mikkel L. Ellertson escreveu:[color=blue]
> Hdparm can NOT control DMA setting for SATA drives. What I have done
> is to add "hdc=noprobe" to the Grub boot line for the kernel. hdc is
> then treated as a SCSI device, and it uses the BIOS DMA settings.
> Hdparm will still say that DMA is not turned on for the drive, but
> DMA will be used. (It also says that DMA is off for /dev/sda.)


seems like my solution but I do not know how to do this.
Whete is Grub boot line for the kernel and how do I add hdc=noprobe ?
counterstrike
 
Posts: 28
Joined: 2008/08/31 04:11:56


Return to CentOS 5 - Server Support

Who is online

Users browsing this forum: No registered users and 0 guests