configure ifconfig vhosts permanently

General support questions
Posts: 24
Joined: 2012/06/05 13:27:26
Location: Sheffield

configure ifconfig vhosts permanently

Postby derrend » 2012/08/24 19:57:40

Each time my server is reboted apache gets errors because some of the namedvirtualhosts try to bind to ip's that dont exist yet.
eth0:1, 0:2, 0:3 are configured by me manually with 'ifconfig eth0:1' etc but these settings are reset if i have to restart my machine.
If there is a file i can edit on the system i don't know where it is and i cant seem to word my problem properly on google to get a useful answer.

Any help would be great :)

User avatar
Forum Moderator
Posts: 20610
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

configure ifconfig vhosts permanently

Postby TrevorH » 2012/08/24 20:02:54

Create /etc/sysconfig/network-scripts/ifcfg-eth0:0 (etc) files for each one. You can base it off the existing ifcfg-eth0 file and remove the HWADDR= line and amend the rest of the details to match your set up.