Black Screen with VNC

Installing, Configuring, Troubleshooting server daemons such as Web and Mail

Black Screen with VNC

Postby Brianmahler » 2010/02/09 22:49:33

I had VNC working with accounts that were logged in. Then I went thru the procedure for vnc-itsp-config (step 5 of the how-to-centos5 vnc server wiki) so that I could log in remotely to an account that was not already logged in.

All went well until....I tried to log in and all I get is this X11 window with a X cursor and a black screen.

I have restarted the vncserver service but I suspect it is a x11 issue (just a guess).

Any suggestions?
Posts: 7
Joined: 2010/02/05 19:00:17

Re: Black Screen with VNC

Postby chuina » 2010/02/10 00:10:13

a Google search with
Code: Select all
Black Screen with VNC CentOS
gives some useful links.
Posts: 355
Joined: 2009/12/11 10:25:56

Re: Black Screen with VNC

Postby bveale » 2010/02/18 20:36:47

I have found that this line:

#!/bin/sh (-)

from section 2.4 of the VNC Server Wiki page caused the black screen for me, specifically the "(-)" part. Removing it fixed the problem for me.

Hope this helps,

Posts: 4
Joined: 2010/02/04 16:50:51

Re: Black Screen with VNC

Postby bveale » 2010/02/22 15:19:05

If you're looking for a definitive guide to remote login using vnc, in my opinion this is your best resource: ... fedora-11/

I tried the wiki instructions, but it seems to me they aren't meant for using vnc to log in remotely -- more like screen sharing to an already logged-in session.

My 2 cents,

Posts: 4
Joined: 2010/02/04 16:50:51

Re: Black Screen with VNC

Postby pschaff » 2010/02/22 15:53:59

Thanks for the helpful posts. I am pinging the Wiki page maintainers about the "(-)" issue in the script and will have a look at your recommended VNC article as well.
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America

Black Screen with VNC

Postby gerald_clark » 2010/02/22 16:52:47

I don't know where the "(-)" came from. I removed it.
It does not appear in V4.8 or V5.4 CentOS .vnc/xstartup files.

This portion of the instructions are for the modification of the vncserver created xstartup files.
The instructions are very specific about which lines to add and modify, and this line was not one of them.
Posts: 9841
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Return to CentOS 5 - Server Support

Who is online

Users browsing this forum: Yahoo [Bot] and 0 guests