sendmail does not work anymore.

Installing, Configuring, Troubleshooting server daemons such as Web and Mail
BubikolRamios
Posts: 67
Joined: 2009/10/04 09:14:05

sendmail does not work anymore.

Postby BubikolRamios » 2010/04/02 11:15:26

Does not work anymore.

//deinstaled everything
[root@localhost ~]# top -b -n1 | mail -s 'Process snapshot' mymail@mymail.net
/usr/sbin/sendmail: No such file or directory

//reinstaled everything, restart sendmail
[root@localhost ~]# top -b -n1 | mail -s 'Process snapshot' mymail@mymail.net
[root@localhost ~]# /etc/mail/submit.cf: line 544: fileclass: cannot open '/etc/mail/trusted-users': World writable directory
//fixed that with '-o' in /etc/mail/submit.cf, restart sendmail

[root@localhost ~]# top -b -n1 | mail -s 'Process snapshot' mymail@mymail.net
// in mail.log:
Apr 2 12:49:16 localhost sendmail[6252]: o32AnGis006252: to=mymail@mymail.net
, ctladdr=root (0/0), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=49856, relay=[127.0.0.1] [127.0.0.1], dsn=4.0.0, stat=Deferred: Connection refused by [127.0.0.1]

//test
[root@localhost ~]# telnet localhost 25
Trying 127.0.0.1...
telnet: connect to address 127.0.0.1: Connection refused
telnet: Unable to connect to remote host: Connection refused

//commented out #O DaemonPortOptions=Port=smtp,Addr=127.0.0.1, Name=MTA
//in sendmail.cf, restart sendmail

//test
[root@localhost ~]# telnet localhost 25
Trying 127.0.0.1...
telnet: connect to address 127.0.0.1: Connection refused
telnet: Unable to connect to remote host: Connection refused

What to do next ?

chuina
Posts: 355
Joined: 2009/12/11 10:25:56

Re: sendmail does not work anymore.

Postby chuina » 2010/04/02 12:35:00

Please show us the result of:

Code: Select all

rpm -qa sendmail\*
netstat -tulpn | grep sendmail

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

sendmail does not work anymore.

Postby pschaff » 2010/04/02 12:42:29

BubikolRamios wrote:
...
//deinstaled everything
...

What do you mean by "everything"? When did things stop working? What else changed? Did any behavior change when you uninstalled and reinstalled "everything"?

BubikolRamios
Posts: 67
Joined: 2009/10/04 09:14:05

Re: sendmail does not work anymore.

Postby BubikolRamios » 2010/04/02 13:24:06

deinstaled everything means sendmail and one dependent package, which is there by default.

[root@localhost ~]# rpm -qa sendmail
sendmail-8.13.8-2.el5
[root@localhost ~]# netstat -tulpn | grep sendmail
[root@localhost ~]#


hmm looks like it is not running, although look at desktops-s service confuguration says
sendmail (pid 6440) is running...

?

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

Re: sendmail does not work anymore.

Postby pschaff » 2010/04/02 13:27:34

pschaff wrote:
... When did things stop working? What else changed? Did any behavior change when you uninstalled and reinstalled "everything"?


And one more: Did you revert to the default config files? Those are typically not replaced by a re-install.

BubikolRamios
Posts: 67
Joined: 2009/10/04 09:14:05

Re: sendmail does not work anymore.

Postby BubikolRamios » 2010/04/02 13:33:33

Using sendmail very rarely so I dont know when it stopped working. The point is thta I ws expecting that if I uninstall and reinstall sendmail it should work, but does not.

BubikolRamios
Posts: 67
Joined: 2009/10/04 09:14:05

Re: sendmail does not work anymore.

Postby BubikolRamios » 2010/04/02 13:42:02

ok to clear up things:


[root@localhost ~]# yum erase sendmail
Loaded plugins: fastestmirror
Setting up Remove Process
Resolving Dependencies
--> Running transaction check
---> Package sendmail.i386 0:8.13.8-2.el5 set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

======================================================================================================================================================
Package Arch Version Repository Size
======================================================================================================================================================
Removing:
sendmail i386 8.13.8-2.el5 installed 1.3 M

Transaction Summary
======================================================================================================================================================
Install 0 Package(s)
Update 0 Package(s)
Remove 1 Package(s)

Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Erasing : sendmail [1/1]
warning: /etc/mail/submit.cf saved as /etc/mail/submit.cf.rpmsave
warning: /etc/mail/sendmail.cf saved as /etc/mail/sendmail.cf.rpmsave

Removed: sendmail.i386 0:8.13.8-2.el5
Complete!
[root@localhost ~]# yum install sendmail
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: mirror.lihnidos.org
* updates: mirror.lihnidos.org
* addons: mirror.lihnidos.org
* extras: mirror.lihnidos.org
base | 2.1 kB 00:00
updates | 1.9 kB 00:00
addons | 951 B 00:00
extras | 2.1 kB 00:00
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package sendmail.i386 0:8.13.8-2.el5 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

======================================================================================================================================================
Package Arch Version Repository Size
======================================================================================================================================================
Installing:
sendmail i386 8.13.8-2.el5 base 632 k

Transaction Summary
======================================================================================================================================================
Install 1 Package(s)
Update 0 Package(s)
Remove 0 Package(s)

Total download size: 632 k
Is this ok [y/N]: y
Downloading Packages:
sendmail-8.13.8-2.el5.i386.rpm | 632 kB 00:00
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Installing : sendmail [1/1]

Installed: sendmail.i386 0:8.13.8-2.el5
Complete!
[root@localhost ~]# sendmail start
/etc/mail/submit.cf: line 544: fileclass: cannot open '/etc/mail/trusted-users': World writable directory
[root@localhost ~]#

Is this expected ? Does this tell you anything ?

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

Re: sendmail does not work anymore.

Postby pschaff » 2010/04/02 13:48:31

No and no.

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

Re: sendmail does not work anymore.

Postby pschaff » 2010/04/02 13:51:34

BubikolRamios wrote:
Using sendmail very rarely so I dont know when it stopped working. The point is thta I ws expecting that if I uninstall and reinstall sendmail it should work, but does not.

pschaff wrote:
... Did you revert to the default config files? Those are typically not replaced by a re-install.

chuina
Posts: 355
Joined: 2009/12/11 10:25:56

Re: sendmail does not work anymore.

Postby chuina » 2010/04/02 14:15:09

BubikolRamios wrote:
deinstaled everything means sendmail and one dependent package, which is there by default.
[root@localhost ~]# rpm -qa sendmail
sendmail-8.13.8-2.el5
[root@localhost ~]# netstat -tulpn | grep sendmail


Beside the sendmail you also need sendmail-cf and then reconfigure the service described in Deployment Guide's Chapter # 23.
Hint, There is a m4 command in the guide.

Code: Select all

yum install sendmail sendmail-cf sendmail-doc m4


If you use iptables:

Code: Select all

[b]iptables -I INPUT 1 -p tcp -m state --state ESTABLISHED,RELATED -j ACCEPT
iptables -I OUTPUT -p tcp -m state --state ESTABLISHED,RELATED -j ACCEPT
iptables -I INPUT 1 -p tcp --dport 25 -m state --state NEW -j ACCEPT
iptables -I OUPUT -p tcp --dport 25 -m state --state NEW -j ACCEPT[/b]


Return to “CentOS 5 - Server Support”

Who is online

Users browsing this forum: No registered users and 1 guest