ls permission error

Installing, Configuring, Troubleshooting server daemons such as Web and Mail

ls permission error

Postby oliverleach » 2012/01/19 02:53:27

Hi,

I have configured and setup up centos to join AD using autofs to mount remote home directories. One of the servers, server1, has an issue - here is what I think the problem is

When I go to server1, I get a error when trying to run ls in my home directory

ls: .: Permission denied

When I run ls -lha on the home directory of the user, I see the GID of the group instead of the group name "domain users". All other servers show domain users and the group owner of the directory. Here is the output of the directory with the permissions error

drwxrwx--x 3 16777217 16777220

When I run wbinfo --group-info=domain\ users I get this

domain users:x:16777218:

So the problem appears to be that the gid on the home directory does not match the gid of the domain users group on server1

If I run getent group on server1 I get this

domain users:x:16777218:

How can I change this so the GID on server1 for domain users matches the GID of the remote home directory?


Cheers,

Oli
oliverleach
 
Posts: 1
Joined: 2012/01/19 02:41:38

ls permission error

Postby pschaff » 2012/01/19 21:54:20

Welcome to the CentOS fora. Please see the recommended reading for new users linked in my signature.

Perhaps I am missing something, or stating the obvious, but you must set up user accounts on all servers and clients with the same UID/GID, and the user's directory/file ownership must be consistent with those. I don't know the details of how one does that with Active Directory as I don't use it. My guess is that the user was initially created with an incorrect GID, and perhaps UID as well.

For default the CentOS authentication method, for user user1 one would do
Code: Select all
usermod -g 16777218 user1
chgrp -R 16777218 /home/user1
YMMV
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America


Return to CentOS 5 - Server Support

Who is online

Users browsing this forum: No registered users and 1 guest