[SOLVED] Trouble with scsi driver after P2V

Installing, Configuring, Troubleshooting server daemons such as Web and Mail

[SOLVED] Trouble with scsi driver after P2V

Postby Gabrie » 2012/03/20 13:16:39

Hi

For a customer I have P2V-ed an old CentOS server into a virtual machine. I think it is CentOS 5 because the grub loader says kernel 2.6.18.

After booting the VM I can see the VM running through the boot process and when it is trying to load the logical volumes it gives me a kernel panic. (See image: [img]http://farm8.staticflickr.com/7091/6853738092_2eae5e275a.jpg[/img] ).

This used to be a raid5 configuration. My guess is that the VMware LSI SCSI driver is not available in the OS, but how can I insert it?

Gabrie
Gabrie
 
Posts: 2
Joined: 2012/03/20 09:23:15

Re: Trouble with scsi driver after P2V

Postby TrevorH » 2012/03/20 14:44:25

You'll almost certainly need to rebuild the initrd - there's a wiki article on just that if you google for it.
User avatar
TrevorH
Forum Moderator
 
Posts: 9103
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

[SOLVED] Trouble with scsi driver after P2V

Postby pschaff » 2012/03/20 23:32:24

Welcome to the CentOS fora. Please see the recommended reading for new users linked in my signature.

If TipsAndTricks/CreateNewInitrd does not do the trick, then use the rescue mode of the CentOS 5.8 installation media, or a LiveCD/DVD boot of the VM, to provide more information about your system by running "./getinfo.sh disk" and showing us the output file.
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America

Re: Trouble with scsi driver after P2V

Postby Gabrie » 2012/03/23 10:21:07

pschaff wrote:
Welcome to the CentOS fora. Please see the recommended reading for new users linked in my signature.

If TipsAndTricks/CreateNewInitrd does not do the trick, then use the rescue mode of the CentOS 5.8 installation media, or a LiveCD/DVD boot of the VM, to provide more information about your system by running "./getinfo.sh disk" and showing us the output file.



SOLVED !!! Thank you, that was spot on.
Gabrie
 
Posts: 2
Joined: 2012/03/20 09:23:15

Re: [SOLVED] Trouble with scsi driver after P2V

Postby pschaff » 2012/03/23 14:16:01

You are welcome. Thanks for reporting back. Marking this thread [SOLVED] for posterity.
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America


Return to CentOS 5 - Server Support

Who is online

Users browsing this forum: No registered users and 0 guests