Error: unixODBC64-devel conflicts with unixODBC-devel

Installing, Configuring, Troubleshooting server daemons such as Web and Mail

Error: unixODBC64-devel conflicts with unixODBC-devel

Postby aaamin » 2012/11/03 19:29:35

Hi there

I hope some one, familiar with telephony system server, can help me to work around my problem which is very annoying to me.

However whenever I am trying to install unixODBC package to run our rate-engine connectivity with database, I am getting the following error:

Error: unixODBC64-devel conflicts with unixODBC-devel
Error: unixODBC64 conflicts with unixODBC
You could try using --skip-broken
You could try running: package-cleanup --problems
package-cleanup --dupes rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.


I Will appreciate your help.

Thank you.
aaamin
 
Posts: 47
Joined: 2012/04/16 23:24:25

Error: unixODBC64-devel conflicts with unixODBC-devel

Postby TrevorH » 2012/11/03 20:59:47

You need to post more of the output than that. There's probably a whole bunch of stuff further up that identifies which release and architecture it's trying to install and with what release/architecture it conflicts.
User avatar
TrevorH
Forum Moderator
 
Posts: 9098
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Error: unixODBC64-devel conflicts with unixODBC-devel

Postby aaamin » 2012/11/03 22:22:29

Hi TrevorH

I am so glad that you have replied to my post so quickly which is highly appreciated.

if you please help me by telling which COMMANDS do I need to try to get the information that you want to see.

I am looking forward for your next reply.

Thank you.
aaamin
 
Posts: 47
Joined: 2012/04/16 23:24:25

Re: Error: unixODBC64-devel conflicts with unixODBC-devel

Postby TrevorH » 2012/11/03 22:56:37

The snippet of information that you posted looks like the output from a `yum install unixODBC64-devel` command or something similar that pulled in that package. The bit of the output that you posted does not look complete to me, I would have expected a lot more that preceded that and that's the part I want to see.
User avatar
TrevorH
Forum Moderator
 
Posts: 9098
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Error: unixODBC64-devel conflicts with unixODBC-devel

Postby aaamin » 2012/11/04 01:12:35

Hi

Yes trevor you are spot on as usual because you have helped me in the past and I appreciate all the knoledge that you have.

However I am going to post the full script for to have a look at:
---------------------------------------------------------------------

[root@localhost ~]# yum install unixODBC64-devel
Loaded plugins: fastestmirror, security
Loading mirror speeds from cached hostfile
* base: mirror01.th.ifl.net
* epel: mirror.bytemark.co.uk
* extras: mirror01.th.ifl.net
* updates: mirror01.th.ifl.net
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package unixODBC64-devel.i386 0:2.2.14-3.el5 set to be updated
--> Processing Dependency: unixODBC64 = 2.2.14-3.el5 for package: unixODBC64-devel
---> Package unixODBC64-devel.x86_64 0:2.2.14-3.el5 set to be updated
--> Running transaction check
---> Package unixODBC64.x86_64 0:2.2.14-3.el5 set to be updated
--> Processing Conflict: unixODBC64-devel conflicts unixODBC-devel
--> Processing Conflict: unixODBC64-devel conflicts unixODBC-devel
--> Processing Conflict: unixODBC64-devel conflicts unixODBC-devel
--> Processing Conflict: unixODBC64-devel conflicts unixODBC-devel
--> Processing Conflict: unixODBC64 conflicts unixODBC
--> Processing Conflict: unixODBC64 conflicts unixODBC
--> Finished Dependency Resolution
unixODBC64-devel-2.2.14-3.el5.i386 from base has depsolving problems
--> unixODBC64-devel conflicts with unixODBC-devel
unixODBC64-2.2.14-3.el5.x86_64 from base has depsolving problems
--> unixODBC64 conflicts with unixODBC
unixODBC64-devel-2.2.14-3.el5.x86_64 from base has depsolving problems
--> unixODBC64-devel conflicts with unixODBC-devel
Error: unixODBC64-devel conflicts with unixODBC-devel
Error: unixODBC64 conflicts with unixODBC
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.
------------------------------------------------------------------------------------

I hope you give me a pleasing news to tackle this issue if not a bug.

Cheers.
aaamin
 
Posts: 47
Joined: 2012/04/16 23:24:25

Re: Error: unixODBC64-devel conflicts with unixODBC-devel

Postby TrevorH » 2012/11/04 01:39:35

Right, now I understand. You're trying to install unixODBC64-devel but you already have unixODBC (no 64) installed and the two series of packages conflict - they are alternatives to each other and cannot be installed on the same system. If you really want the unixODBC64-* packages installed then you have to remove the ordinary unixODBC-* packages first. If you use `yum remove` to do this then please make sure you do not use the -y switch and then you need to carefully inspect the list of packages that yum says it will remove to make sure it hasn't expanded your selection to include system-critical packages like rpm, yum, glibc etc. Make a note of the other packages that are removed at the same time and reinstall them afterwards though be aware that the 64 version needs mysql-connector-odbc64 and/or postgresql-odbc64 instead of the non64 version that may already be installed.
User avatar
TrevorH
Forum Moderator
 
Posts: 9098
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Error: unixODBC64-devel conflicts with unixODBC-devel

Postby aaamin » 2012/11/04 10:03:47

Hi Trevor

I hope you are well and having a nice weekend.

I have now managed to remove the unixODBC as in below:

<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<,

[root@localhost ~]# yum remove unixODBC
Loaded plugins: fastestmirror, security
Setting up Remove Process
Resolving Dependencies
--> Running transaction check
---> Package unixODBC.i386 0:2.2.11-10.el5 set to be erased
--> Processing Dependency: unixODBC = 2.2.11-10.el5 for package: unixODBC-kde
--> Processing Dependency: unixODBC = 2.2.11-10.el5 for package: unixODBC-devel
--> Processing Dependency: unixODBC = 2.2.11-10.el5 for package: unixODBC-kde
--> Processing Dependency: unixODBC = 2.2.11-10.el5 for package: unixODBC-devel
---> Package unixODBC.x86_64 0:2.2.11-10.el5 set to be erased
--> Running transaction check
---> Package unixODBC-devel.i386 0:2.2.11-10.el5 set to be erased
---> Package unixODBC-devel.x86_64 0:2.2.11-10.el5 set to be erased
---> Package unixODBC-kde.i386 0:2.2.11-10.el5 set to be erased
---> Package unixODBC-kde.x86_64 0:2.2.11-10.el5 set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
Package Arch Version Repository Size
================================================================================
Removing:
unixODBC i386 2.2.11-10.el5 installed 481 k
unixODBC x86_64 2.2.11-10.el5 installed 492 k
Removing for dependencies:
unixODBC-devel i386 2.2.11-10.el5 installed 3.0 M
unixODBC-devel x86_64 2.2.11-10.el5 installed 3.9 M
unixODBC-kde i386 2.2.11-10.el5 installed 2.2 M
unixODBC-kde x86_64 2.2.11-10.el5 installed 2.6 M

Transaction Summary
================================================================================
Remove 6 Package(s)
Reinstall 0 Package(s)
Downgrade 0 Package(s)

Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Erasing : unixODBC-kde 1/6
Erasing : unixODBC 2/6
Erasing : unixODBC-devel 3/6
Erasing : unixODBC-devel 4/6
Erasing : unixODBC-kde 5/6
Erasing : unixODBC 6/6

Removed:
unixODBC.i386 0:2.2.11-10.el5 unixODBC.x86_64 0:2.2.11-10.el5

Dependency Removed:
unixODBC-devel.i386 0:2.2.11-10.el5 unixODBC-devel.x86_64 0:2.2.11-10.el5
unixODBC-kde.i386 0:2.2.11-10.el5 unixODBC-kde.x86_64 0:2.2.11-10.el5

Complete!

<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

and then i installed the unixODBC64 and this is the output:

[root@localhost ~]# yum install unixODBC64
Loaded plugins: fastestmirror, security
Loading mirror speeds from cached hostfile
* base: mirror01.th.ifl.net
* epel: mirror.bytemark.co.uk
* extras: mirror01.th.ifl.net
* updates: mirror01.th.ifl.net
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package unixODBC64.x86_64 0:2.2.14-3.el5 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
Package Arch Version Repository Size
================================================================================
Installing:
unixODBC64 x86_64 2.2.14-3.el5 base 138 k

Transaction Summary
================================================================================
Install 1 Package(s)
Upgrade 0 Package(s)

Total download size: 138 k
Is this ok [y/N]: y
Downloading Packages:
unixODBC64-2.2.14-3.el5.x86_64.rpm | 138 kB 00:00
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Installing : unixODBC64 1/1

Installed:
unixODBC64.x86_64 0:2.2.14-3.el5

Complete!


However I am not sure if I still need to install the mysql-connector-odbc64 and/or postgresql-odbc64
, and if yes could you please kindly tell me how to do or the command for doing so because I am totally new to Linux as a whole.

Thank you
aaamin
 
Posts: 47
Joined: 2012/04/16 23:24:25

Re: Error: unixODBC64-devel conflicts with unixODBC-devel

Postby TrevorH » 2012/11/04 12:52:45

If you didn't have the non-64 mysql/pgsql packages installed before then you probably don't need the alternatives either.
User avatar
TrevorH
Forum Moderator
 
Posts: 9098
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Error: unixODBC64-devel conflicts with unixODBC-devel

Postby aaamin » 2012/11/04 15:03:40

Hi Trevor

I know it might sound daft to ask but how do I know? is there any commands for me to find out? and in case if I have the non-64 mysql/pgsql packages installed, then how do I install the mysql-connector-odbc64 and/or postgresql-odbc64.

Thank you for your help and time.

Regards

Aamin
aaamin
 
Posts: 47
Joined: 2012/04/16 23:24:25

Re: Error: unixODBC64-devel conflicts with unixODBC-devel

Postby TrevorH » 2012/11/04 15:34:44

I'm pretty sure that you didn't have them installed before as, when I ran `yum remove unixODBC-\*` on my system, it offered to remove the mysql connector package too. Yours did not according to the output you posted.
User avatar
TrevorH
Forum Moderator
 
Posts: 9098
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Next

Return to CentOS 5 - Server Support

Who is online

Users browsing this forum: No registered users and 0 guests