[SOLVED] Need IDEA plugin for gpg

Support for security such as Firewalls and securing linux

[SOLVED] Need IDEA plugin for gpg

Postby pauln » 2011/12/29 14:20:32

Hi folks,

Using Centos 5.6. I need to decrypt messages created by PGP 4.0 for MVS.

The messages are encrypted using IDEA for the symmetric cypher. Right now, I'm using gpg on Windows, but it looks like I'm finally going to be permitted to move that process to Linux.

The problem is that the GPG FAQ at http://www.gnupg.org/faq/GnuPG-FAQ.html ... a-and-idea says to get the source for the IDEA plugin is "available from ftp://ftp.gnupg.dk/pub/contrib-dk/." Unfortunately, although ftp.gnupg.dk exists, there is no /pub/contrib-dk directory anymore. I can connect anonymously to the site, and can cd to /pub, but get told that there is no such directory when I try to cd to /pub/contrib-dk. And the site will not allow ls at all.

So, does anyone know if there is a mirror of the gnupg.dk site? Has the IDEA support moved elsewhere? I really don't want to leave this on windows if I can avoid it.

Thanks,
Paul
pauln
 
Posts: 2
Joined: 2011/12/29 13:59:01

Re: Need IDEA plugin for gpg

Postby TrevorH » 2011/12/29 14:54:08

That ftp site appears to be using an extremely broken wu-ftp that responds with "425 Possible PASV port theft cannot open data connection" to almost all ftp requests.

I did manage to download the file from a different site found via google "gpg idea plugin"
User avatar
TrevorH
Forum Moderator
 
Posts: 9146
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Need IDEA plugin for gpg

Postby pauln » 2011/12/29 17:13:32

The problem was that I was not getting the ftp site linked from the gnupg.org page ( ftp.gnupg,dk ) to work. I could not either ls or cd to pub/contrib-dk. :-(

It turns out, however, that their webserver seems to work somewhat better than their ftp server. For the benefit of anyone else looking for the same files, here's the steps that eventually acquired (and proved) a good file:

Code: Select all
wget http://www.gnupg.dk/contrib-dk/idea.c.gz
wget http://www.gnupg.dk/contrib-dk/idea.c.gz.sig
gpg --keyserver pgp.mit.edu --recv-keys 621CC013
gpg --verify idea.c.gz.sig


The key used for the detached sig is expired, but the result at least shows
Code: Select all
# gpg --verify idea.c.gz.sig
gpg: Signature made Tue 01 Apr 2003 10:32:20 AM EST using DSA key ID 621CC013
gpg: Good signature from "Werner Koch <wk@gnupg.org>"
gpg:                 aka "Werner Koch <wk@g10code.com>"
gpg:                 aka "Werner Koch <werner.koch@guug.de>"
gpg: Note: This key has expired!
Primary key fingerprint: ECAF 7590 EB34 43B5 C7CF  3ACB 6C7E E1B8 621C C013


The IDEA code is pretty old by now and even with the patent having expired, it's not the best choice, but I have no choice. The sender is the 800-pound gorilla and I'm a relative gnat. I have to be able to decrypt the files from this provider. They don't particularly have to accommodate me.

Thanks,
Paul
pauln
 
Posts: 2
Joined: 2011/12/29 13:59:01

[SOLVED] Need IDEA plugin for gpg

Postby pschaff » 2012/01/01 02:54:14

Welcome to the CentOS fora. Please see the recommended reading for new users linked in my signature.

Thanks for reporting back. Marking this thread [SOLVED] for posterity.
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America

Re: [SOLVED] Need IDEA plugin for gpg

Postby cnd » 2014/02/03 11:30:20

All well and good, except, that's not his key from back then: 0x57548DCD was:-

http://www.gnupg.org/signature_key.html
cnd
 
Posts: 5
Joined: 2014/01/02 15:23:11


Return to CentOS 5 - Security Support

Who is online

Users browsing this forum: No registered users and 0 guests