[SOLVED] php-dom (php-xml) installation problem with Drupal 7

Support for the other architectures (X86_64, IA-64, and PowerPC)

[SOLVED] php-dom (php-xml) installation problem with Drupal 7

Postby joeebel » 2011/01/06 21:00:39

Please pardon my noobishness (is that a real word?). I'm still a bit new to all this.

I have been unable to load up Drupal 7 on a new server (Centos 5.5 on a Rackspace Cloud Server). The Drupal installation indicates that the php-dom extension is not running. I Googled and Googled and was unable to resolve the issue. Here's the background info:

This is a brand new CentOS 5.5 install, new server (X86_64 arch) with an install of Virtualmin as the first addition. Here is some info from getinfo.sh:


[color=006600]
== BEGIN uname -rmi ==
2.6.35.4-rscloud x86_64 x86_64
== END uname -rmi ==

== BEGIN rpm -qa \*-release\* ==
centos-release-notes-5.5-0
centos-release-5-5.el5.centos
virtualmin-release-1.0-1.rhel.gpl
remi-release-5-7.el5.remi
epel-release-5-4
== END rpm -qa \*-release\* ==

== BEGIN cat /etc/redhat-release ==
CentOS release 5.5 (Final)
== END cat /etc/redhat-release ==

== BEGIN getenforce ==
Disabled
== END getenforce ==

== BEGIN rpm -q yum rpm python ==
yum-3.2.22-26.el5.centos
rpm-4.4.2.3-20.el5_5.1
python-2.4.3-27.el5_5.3
== END rpm -q yum rpm python ==

== BEGIN ls /etc/yum.repos.d ==
CentOS-Base.repo
CentOS-Media.repo
CentOS-Testing.repo
epel.repo
epel-testing.repo
remi.repo
virtualmin.repo
== END ls /etc/yum.repos.d ==

== BEGIN cat /etc/yum.conf ==
[main]
cachedir=/var/cache/yum
keepcache=0
debuglevel=2
logfile=/var/log/yum.log
distroverpkg=redhat-release
tolerant=1
exactarch=1
obsoletes=1
gpgcheck=1
plugins=1

# Note: yum-RHN-plugin doesn't honor this.
metadata_expire=1h

# Default.
# installonly_limit = 3

# PUT YOUR REPOS HERE OR IN separate files named file.repo
# in /etc/yum.repos.d
== END cat /etc/yum.conf ==

== BEGIN yum repolist all ==
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
* addons: mirror.sanctuaryhost.com
* base: mirror.sanctuaryhost.com
* epel: mirrors.servercentral.net
* extras: mirror.cs.vt.edu
* remi: rpms.famillecollet.com
* updates: mirror.clarkson.edu
repo id repo name status
addons CentOS-5 - Addons enabled: 0
base CentOS-5 - Base enabled: 3,434
c5-media CentOS-5 - Media disabled
c5-testing CentOS-5 Testing enabled: 898
centosplus CentOS-5 - Plus disabled
contrib CentOS-5 - Contrib disabled
epel Extra Packages for Enterprise Linux 5 - x8 enabled: 6,056
epel-debuginfo Extra Packages for Enterprise Linux 5 - x8 disabled
epel-source Extra Packages for Enterprise Linux 5 - x8 disabled
epel-testing Extra Packages for Enterprise Linux 5 - Te disabled
epel-testing-debuginfo Extra Packages for Enterprise Linux 5 - Te disabled
epel-testing-source Extra Packages for Enterprise Linux 5 - Te disabled
extras CentOS-5 - Extras enabled: 303
remi Les RPM de remi pour Enterprise Linux 5 - enabled: 535
remi-test Les RPM de remi en test pour Enterprise Li disabled
updates CentOS-5 - Updates enabled: 1,127
virtualmin Red Hat Enterprise 5 - x86_64 - Virtualmin enabled: 330
virtualmin-universal Virtualmin Distribution Neutral enabled: 116
repolist: 12,799
== END yum repolist all ==

== BEGIN egrep 'include|exclude' /etc/yum.repos.d/*.repo ==
/etc/yum.repos.d/CentOS-Testing.repo:includepkgs=php*
== END egrep 'include|exclude' /etc/yum.repos.d/*.repo ==

== BEGIN sed -n -e "/^\[/h; /priority *=/{ G; s/\n/ /; s/ity=/ity = /; p }" /etc/yum.repos.d/*.repo | sort -k3n ==
priority = 1 [addons]
priority = 1 [base]
priority = 1 [extras]
priority = 1 [updates]
priority = 2 [centosplus]
priority = 3 [epel]
priority = 3 [remi]
== END sed -n -e "/^\[/h; /priority *=/{ G; s/\n/ /; s/ity=/ity = /; p }" /etc/yum.repos.d/*.repo | sort -k3n ==

== BEGIN cat /etc/fstab ==
/dev/sda1 / ext3 grpquota,usrquota,noatime,rw 0 1
/dev/sda2 swap swap defaults 0 0
tmpfs /dev/shm tmpfs defaults 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
sysfs /sys sysfs defaults 0 0
proc /proc proc defaults 0 0
== END cat /etc/fstab ==

== BEGIN df -h ==
Filesystem Size Used Avail Use% Mounted on
/dev/sda1 19G 1.3G 17G 7% /
tmpfs 249M 0 249M 0% /dev/shm
== END df -h ==
[/color]

After digging through the Internet Toobz I tried
[color=006600]
[03:02][ilww3:~]$ yum install php-xml
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
* addons: centos.mbni.med.umich.edu
* base: updates.interworx.info
* epel: mirror.vcu.edu
* extras: mirror.steadfast.net
* remi: iut-info.univ-reims.fr
* updates: mirrors.serveraxis.net
Reducing CentOS-5 Testing to included packages only
Finished
611 packages excluded due to repository priority protections
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php-xml.x86_64 0:5.1.6-27.el5_5.3 set to be updated
--> Processing Dependency: php-common = 5.1.6-27.el5_5.3 for package: php-xml
--> Processing Dependency: libexslt.so.0()(64bit) for package: php-xml
--> Processing Dependency: libxslt.so.1()(64bit) for package: php-xml
--> Running transaction check
---> Package libxslt.x86_64 0:1.1.17-2.el5_2.2 set to be updated
---> Package php-xml.x86_64 0:5.1.6-27.el5_5.3 set to be updated
--> Processing Dependency: php-common = 5.1.6-27.el5_5.3 for package: php-xml
--> Finished Dependency Resolution
php-xml-5.1.6-27.el5_5.3.x86_64 from updates has depsolving problems
--> Missing Dependency: php-common = 5.1.6-27.el5_5.3 is needed by package php-xml-5.1.6-27.el5_5.3.x86_64 (updates)

Error: Missing Dependency: php-common = 5.1.6-27.el5_5.3 is needed by package php-xml-5.1.6-27.el5_5.3.x86_64 (updates)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.[/color]


Uh, why is an X86_64 extension needing a non-x86_64 package (php-common = 5.1.6-27.el5_5.3)?


Here's what I already have installed:
[color=006600]
[03:16][ilww3:~]$ yum install php-common.x86_64
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
* addons: centos.mbni.med.umich.edu
* base: updates.interworx.info
* epel: mirrors.servercentral.net
* extras: mirror.steadfast.net
* remi: rpms.famillecollet.com
* updates: mirrors.serveraxis.net
Reducing CentOS-5 Testing to included packages only
Finished
611 packages excluded due to repository priority protections
Setting up Install Process
Package matching php-common-5.1.6-27.el5_5.3.x86_64 already installed. Checking for update.
Nothing to do
[/color]


How do I get php-xml to install so Drupal can see the dom extension to php?

Here are some excerpts (relevant, I hope) from the php -i command:

[color=006600]
phpinfo()
PHP Version => 5.2.10

System => Linux ilww3.net 2.6.35.4-rscloud #8 SMP Mon Sep 20 15:54:33 UTC 2010 x86_64
Build Date => Nov 13 2009 11:36:08
Configure Command => './configure' '--build=x86_64-redhat-linux-gnu' '--host=x86_64-redhat-linux-gnu' '--target=x86_64-redhat-linux-gnu' '--program-prefix=' '--prefix=/usr' '--exec-prefix=/usr' '--bindir=/usr/bin' '--sbindir=/usr/sbin' '--sysconfdir=/etc' '--datadir=/usr/share' '--includedir=/usr/include' '--libdir=/usr/lib64' '--libexecdir=/usr/libexec' '--localstatedir=/var' '--sharedstatedir=/usr/com' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--cache-file=../config.cache' '--with-libdir=lib64' '--with-config-file-path=/etc' '--with-config-file-scan-dir=/etc/php.d' '--disable-debug' '--with-pic' '--disable-rpath' '--without-pear' '--with-bz2' '--with-curl' '--with-exec-dir=/usr/bin' '--with-freetype-dir=/usr' '--with-png-dir=/usr' '--enable-gd-native-ttf' '--without-gdbm' '--with-gettext' '--with-gmp' '--with-iconv' '--with-jpeg-dir=/usr' '--with-openssl' '--with-png' '--with-pspell' '--with-expat-dir=/usr' '--with-pcre-regex=/usr' '--with-zlib' '--with-layout=GNU' '--enable-exif' '--enable-ftp' '--enable-magic-quotes' '--enable-sockets' '--enable-sysvsem' '--enable-sysvshm' '--enable-sysvmsg' '--enable-track-vars' '--enable-trans-sid' '--enable-yp' '--enable-wddx' '--with-kerberos' '--enable-ucd-snmp-hack' '--with-unixODBC=shared,/usr' '--enable-memory-limit' '--enable-shmop' '--enable-calendar' '--enable-dbx' '--enable-dio' '--without-mime-magic' '--without-sqlite' '--with-libxml-dir=/usr' '--with-xml' '--with-system-tzdata' '--enable-force-cgi-redirect' '--enable-pcntl' '--with-imap=shared' '--with-imap-ssl' '--enable-mbstring=shared' '--enable-mbstr-enc-trans' '--enable-mbregex' '--with-ncurses=shared' '--with-gd=shared' '--enable-bcmath=shared' '--enable-dba=shared' '--with-db4=/usr' '--with-xmlrpc=shared' '--with-ldap=shared' '--with-ldap-sasl' '--with-mysql=shared,/usr' '--with-mysqli=shared,/usr/bin/mysql_config' '--enable-dom=shared' '--with-dom-xslt=/usr' '--with-dom-exslt=/usr' '--with-pgsql=shared' '--with-snmp=shared,/usr' '--enable-soap=shared' '--with-xsl=shared,/usr' '--enable-xmlreader=shared' '--enable-xmlwriter=shared' '--enable-fastcgi' '--enable-pdo=shared' '--with-pdo-odbc=shared,unixODBC,/usr' '--with-pdo-mysql=shared,/usr' '--with-pdo-pgsql=shared,/usr' '--with-pdo-sqlite=shared,/usr' '--enable-json=shared' '--enable-zip=shared' '--with-readline' '--enable-dbase=shared'
Server API => Command Line Interface
Virtual Directory Support => disabled
Configuration File (php.ini) Path => /etc
Loaded Configuration File => /etc/php.ini
Scan this dir for additional .ini files => /etc/php.d
additional .ini files parsed => /etc/php.d/dbase.ini,
/etc/php.d/gd.ini,
/etc/php.d/imap.ini,
/etc/php.d/json.ini,
/etc/php.d/mbstring.ini,
/etc/php.d/mcrypt.ini,
/etc/php.d/mysql.ini,
/etc/php.d/mysqli.ini,
/etc/php.d/odbc.ini,
/etc/php.d/pdo.ini,
/etc/php.d/pdo_mysql.ini,
/etc/php.d/pdo_odbc.ini,
/etc/php.d/pdo_pgsql.ini,
/etc/php.d/pdo_sqlite.ini,
/etc/php.d/pgsql.ini,
/etc/php.d/snmp.ini,
/etc/php.d/xmlrpc.ini,
/etc/php.d/zip.ini

PHP API => 20041225
PHP Extension => 20060613
Zend Extension => 220060519
Debug Build => no
Thread Safety => disabled
Zend Memory Manager => enabled
IPv6 Support => enabled
Registered PHP Streams => https, ftps, compress.zlib, compress.bzip2, php, file, data, http, ftp, zip
Registered Stream Socket Transports => tcp, udp, unix, udg, ssl, sslv3, sslv2, tls
Registered Stream Filters => zlib.*, bzip2.*, convert.iconv.*, string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed


This program makes use of the Zend Scripting Language Engine:
Zend Engine v2.2.0, Copyright (c) 1998-2009 Zend Technologies
...

Configuration

PHP Core

Directive => Local Value => Master Value
allow_call_time_pass_reference => Off => Off
allow_url_fopen => On => On
allow_url_include => Off => Off
always_populate_raw_post_data => Off => Off
arg_separator.input => & => &
arg_separator.output => & => &
asp_tags => Off => Off
auto_append_file => no value => no value
auto_globals_jit => On => On
auto_prepend_file => no value => no value
browscap => no value => no value
default_charset => no value => no value
default_mimetype => text/html => text/html
define_syslog_variables => Off => Off
disable_classes => no value => no value
disable_functions => no value => no value
display_errors => Off => Off
display_startup_errors => Off => Off
doc_root => no value => no value
docref_ext => no value => no value
docref_root => no value => no value
enable_dl => On => On
error_append_string => no value => no value
error_log => no value => no value
error_prepend_string => no value => no value
error_reporting => 6143 => 6143
expose_php => On => On
extension_dir => /usr/lib64/php/modules => /usr/lib64/php/modules
file_uploads => On => On
highlight.bg => #FFFFFF => #FFFFFF
highlight.comment => #FF8000 => #FF8000
highlight.default => #0000BB => #0000BB
highlight.html => #000000 => #000000
highlight.keyword => #007700 => #007700
highlight.string => #DD0000 => #DD0000
html_errors => Off => Off
ignore_repeated_errors => Off => Off
ignore_repeated_source => Off => Off
ignore_user_abort => Off => Off
implicit_flush => On => On
include_path => .:/usr/share/pear:/usr/share/php => .:/usr/share/pear:/usr/share/php
log_errors => On => On
log_errors_max_len => 1024 => 1024
magic_quotes_gpc => Off => Off
magic_quotes_runtime => Off => Off
magic_quotes_sybase => Off => Off
mail.force_extra_parameters => no value => no value
max_execution_time => 0 => 0
max_input_nesting_level => 64 => 64
max_input_time => -1 => -1
memory_limit => 32M => 32M
open_basedir => no value => no value
output_buffering => 0 => 0
output_handler => no value => no value
post_max_size => 8M => 8M
precision => 14 => 14
realpath_cache_size => 16K => 16K
realpath_cache_ttl => 120 => 120
register_argc_argv => On => On
register_globals => Off => Off
register_long_arrays => Off => Off
report_memleaks => On => On
report_zend_debug => Off => Off
safe_mode => Off => Off
safe_mode_exec_dir => no value => no value
safe_mode_gid => Off => Off
safe_mode_include_dir => no value => no value
sendmail_from => no value => no value
sendmail_path => /usr/sbin/sendmail -t -i => /usr/sbin/sendmail -t -i
serialize_precision => 100 => 100
short_open_tag => On => On
SMTP => localhost => localhost
smtp_port => 25 => 25
sql.safe_mode => Off => Off
track_errors => Off => Off
unserialize_callback_func => no value => no value
upload_max_filesize => 2M => 2M
upload_tmp_dir => no value => no value
user_dir => no value => no value
variables_order => EGPCS => EGPCS
xmlrpc_error_number => 0 => 0
xmlrpc_errors => Off => Off
y2k_compliance => On => On
zend.ze1_compatibility_mode => Off => Off
...

libxml

libXML support => active
libXML Version => 2.6.26
libXML streams => enabled
...

xml

XML Support => active
XML Namespace Support => active
libxml2 Version => 2.6.26

xmlrpc

core library version => xmlrpc-epi v. 0.51
php extension version => 0.51
author => Dan Libby
homepage => http://xmlrpc-epi.sourceforge.net
open sourced by => Epinions.com[/color]

Thanks in advance for any advice!

Joe
[Moderator edit: Changed incorrect code tags to pre tags to preserve formatting, since html tags were in use; except for the last section - that resulted in a ridiculously ling line.]
joeebel
 
Posts: 8
Joined: 2009/10/23 00:36:57

[SOLVED] php-dom (php-xml) installation problem with Drupal

Postby pschaff » 2011/01/06 21:22:18

You are not running a CentOS kernel, and thus not really CentOS, so all advice from here should be taken with a large grain of salt.

First thing to try is "yum clean all".

If that fails to help it may be a multi-arch problem. Please show the results of
Code: Select all
rpm -qa --qf "%{name}-%{version}-%{release}.%{arch}\n" php\*

I get
Code: Select all
php-common-5.1.6-27.el5_5.3.x86_64
php-ldap-5.1.6-27.el5_5.3.x86_64
php-cli-5.1.6-27.el5_5.3.x86_64
php-5.1.6-27.el5_5.3.x86_64
php-mysql-5.1.6-27.el5_5.3.x86_64
php-pdo-5.1.6-27.el5_5.3.x86_64
php-gd-5.1.6-27.el5_5.3.x86_64

Edit: Some of the issues may be due to the Remi repo and yum-priorities. If you want to use updated Remi packages the lower priority (3) will prevent yum from replacing the core packages with them. This is the down-side of the priorities plugin. One way to go would be to exclude the packages you want updated in the standard repo configs. Similar considerations apply to the updated package versions in CentOSplus.

You may also want to read
FAQ #22. I installed the x86_64 version, so why do I have i386 packages, and can I get rid of them?
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America

Re: php-dom (php-xml) installation problem with Drupal 7

Postby joeebel » 2011/01/06 21:33:42

Thanks for the quick reply!!

Here are the results of your suggestions.

[font=Courier][color=006600]
[21:26][ilww3:/home/joeebel]$ rpm -qa --qf "%{name}-%{version}-%{release}.%{arch}\n" php\*
php-common-5.2.10-1.el5.centos.x86_64
php-cli-5.2.10-1.el5.centos.x86_64
php-odbc-5.2.10-1.el5.centos.x86_64
php-pgsql-5.2.10-1.el5.centos.x86_64
php-imap-5.2.10-1.el5.centos.x86_64
php-gd-5.2.10-1.el5.centos.x86_64
php-devel-5.2.10-1.el5.centos.x86_64
phpMyAdmin-3.3.9-1.el5.remi.noarch
php-pdo-5.2.10-1.el5.centos.x86_64
php-5.2.10-1.el5.centos.x86_64
php-mysql-5.2.10-1.el5.centos.x86_64
php-snmp-5.2.10-1.el5.centos.x86_64
php-xmlrpc-5.2.10-1.el5.centos.x86_64
php-mbstring-5.2.10-1.el5.centos.x86_64
php-pear-1.8.1-2.el5.centos.noarch
php-mcrypt-5.2.9-2.el5.centos.3.x86_64
[21:26][ilww3:/home/joeebel]$ yum clean all
Loaded plugins: fastestmirror, priorities
Cleaning up Everything
Cleaning up list of fastest mirrors
[21:27][ilww3:/home/joeebel]$ yum install php-xml.x86_64
Loaded plugins: fastestmirror, priorities
Determining fastest mirrors
* addons: mirror.steadfast.net
* base: centos.mbni.med.umich.edu
* epel: mirror.steadfast.net
* extras: mirror.batblue.com
* remi: rpms.famillecollet.com
* updates: mirror.unl.edu
addons | 951 B 00:00
addons/primary | 204 B 00:00
base | 2.1 kB 00:00
base/primary_db | 2.1 MB 00:04
c5-testing | 1.9 kB 00:00
c5-testing/primary_db | 615 kB 00:00
epel | 3.7 kB 00:00
epel/primary_db | 3.5 MB 00:00
extras | 2.1 kB 00:00
extras/primary_db | 246 kB 00:00
remi | 2.6 kB 00:00
remi/primary_db | 243 kB 00:00
updates | 1.9 kB 00:00
updates/primary_db | 1.1 MB 00:00
virtualmin | 951 B 00:00
virtualmin/primary | 84 kB 00:00
virtualmin 330/330
virtualmin-universal | 951 B 00:00
virtualmin-universal/primary | 15 kB 00:00
virtualmin-universal 116/116
Reducing CentOS-5 Testing to included packages only
Finished
611 packages excluded due to repository priority protections
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php-xml.x86_64 0:5.1.6-27.el5_5.3 set to be updated
--> Processing Dependency: php-common = 5.1.6-27.el5_5.3 for package: php-xml
--> Processing Dependency: libexslt.so.0()(64bit) for package: php-xml
--> Processing Dependency: libxslt.so.1()(64bit) for package: php-xml
--> Running transaction check
---> Package libxslt.x86_64 0:1.1.17-2.el5_2.2 set to be updated
---> Package php-xml.x86_64 0:5.1.6-27.el5_5.3 set to be updated
--> Processing Dependency: php-common = 5.1.6-27.el5_5.3 for package: php-xml
--> Finished Dependency Resolution
php-xml-5.1.6-27.el5_5.3.x86_64 from updates has depsolving problems
--> Missing Dependency: php-common = 5.1.6-27.el5_5.3 is needed by package php-xml-5.1.6-27.el5_5.3.x86_64 (updates)
Error: Missing Dependency: php-common = 5.1.6-27.el5_5.3 is needed by package php-xml-5.1.6-27.el5_5.3.x86_64 (updates)

You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.[/color]
[/font]

Still confused...
joeebel
 
Posts: 8
Joined: 2009/10/23 00:36:57

Re: php-dom (php-xml) installation problem with Drupal 7

Postby pschaff » 2011/01/06 21:36:23

I believe yum-priorities is killing you. Please re-read my previous post, including the more recent edit.
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America

Re: php-dom (php-xml) installation problem with Drupal 7

Postby joeebel » 2011/01/06 21:37:43

Oops! So sorry! I missed that part of your post. DOH!
joeebel
 
Posts: 8
Joined: 2009/10/23 00:36:57

Re: php-dom (php-xml) installation problem with Drupal 7

Postby pschaff » 2011/01/06 21:48:26

Not your fault - I was editing while you were reading.
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America

Re: php-dom (php-xml) installation problem with Drupal 7

Postby joeebel » 2011/01/06 22:47:53

Do I need to install the non x86_64 version of php-common? Do you think that dependency is real? How do I determine what is the right thing to do? Would I exclude php-common in yum.conf? Do I need to disable some repos? this is a bit confusing...

Sorry for the hassle. I'm new to this corner of the CentOS world...
joeebel
 
Posts: 8
Joined: 2009/10/23 00:36:57

[SOLVED] Re: php-dom (php-xml) installation problem with Drupal 7

Postby joeebel » 2011/01/07 04:05:35

I finally found a resolution to the problem!

After speaking with an uber-geek friend, I installed the Virtualmin-bleed.repo and set its priority to 1. I then used Virtualmin's package updates function (which uses yum) and upgraded to php-5.2.14. Then I was able to install php-xml without the dependency problem and Drupal 7 is now happy!

Thanks for your help with this! I really appreciate it!!
joeebel
 
Posts: 8
Joined: 2009/10/23 00:36:57

Re: [SOLVED] php-dom (php-xml) installation problem with Drupal 7

Postby pschaff » 2011/01/07 15:09:17

You are welcome. Hope that works out for you, but I'd be a bit suspicious of anything with "bleed" in the repo name.
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America


Return to CentOS 5 - X86_64,s390(x) and PowerPC Support

Who is online

Users browsing this forum: No registered users and 0 guests