There are unfinished transactions remaining

General support questions

There are unfinished transactions remaining

Postby JoyceBabu » 2012/11/21 05:15:46

When running
Code: Select all
yum update package
I am getting the following warning

There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.


When running yum-complete-transaction, I am getting the following error

--> Running transaction check
---> Package yum.noarch 0:3.2.29-22.el6.centos will be erased
--> Processing Dependency: yum >= 3.0 for package: yum-plugin-priorities-1.1.30-14.el6.noarch
--> Processing Dependency: yum >= 3.0 for package: yum-plugin-fastestmirror-1.1.30-14.el6.noarch
--> Processing Dependency: yum >= 2.2 for package: atomic-release-1.0-14.el6.art.noarch
--> Processing Dependency: yum >= 3.2.29 for package: yum-utils-1.1.30-14.el6.noarch
--> Running transaction check
---> Package atomic-release.noarch 0:1.0-14.el6.art will be erased
---> Package yum-plugin-fastestmirror.noarch 0:1.1.30-14.el6 will be erased
---> Package yum-plugin-priorities.noarch 0:1.1.30-14.el6 will be erased
---> Package yum-utils.noarch 0:1.1.30-14.el6 will be erased
--> Finished Dependency Resolution
Error: Trying to remove "yum", which is protected
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest


Is this something to be worried about?
JoyceBabu
 
Posts: 1
Joined: 2012/11/21 05:09:30

There are unfinished transactions remaining

Postby pjwelsh » 2012/11/21 15:02:13

Does "rpm -q yum yum-plugin-priorities" produce 2 results for each package? You could remove the explicit *older* package manually and see how much further you get. Sounds as if a yum update of some kind got killed/died/power-cycled in the middle of an operation.
pjwelsh
 
Posts: 2555
Joined: 2007/01/07 02:18:02
Location: Central IL USA


Return to CentOS 6 - General Support

Who is online

Users browsing this forum: No registered users and 13 guests