Broken Kernel, missing .ko data, make not possible

General support questions

Broken Kernel, missing .ko data, make not possible

Postby nomara » 2013/01/25 09:33:54

Hello,
i need help.
You need to now: I have CentOs 6.2
1. i have no network connection because .ko file is missing in kernel file system
2. i can't use USB sticks because Linux cant detect vfat or ext2-ext4

Why is that?
I tried to istall the ath9k driver to get WLAN to work. I found a couple of How To's and forum topics and followd them.
Using make in /usr/src/kernels/2.../ did not work...
I got the following output:
...
make[1]: *** Keine Regel, um >>missing-syscalls<< zu erstellen. Schluss.


Means: No Rule, to make missing-syscalls. End.

So i tried to install the Kernel anew. Did not work it always said Kernel is already installed. So i thought about taking a new installation file but then i noticed i cant use USB, so i tried FTP over a Lan-Connection, and i found eth0 not usable ... i cant start it

So i tried formatting the usb key to the ext2 filesystem... Linux coudlnt detect that eather.
I want to solve it without reinstalling CentOS because i have some Data that i really need.

Does anyone have an idea how i can eather
- get USB working
- get eth0 working or
- get the kernel installed without usb, eth0 :-?

I appreciate your help.
Nomara

EDIT: Cant i just remove the installed kernel and install it new? Or would that kinda break everything?
nomara
 
Posts: 5
Joined: 2013/01/25 09:03:45

Broken Kernel, missing .ko data, make not possible

Postby TrevorH » 2013/01/25 11:18:05

I am pretty sure that ELRepo has a driver for the ath9k chips.

You'd need to post the output from the last few lines of `dmesg` after inserting the USB stick in order to gain any clue as to what's going on with that but I can say that CentOS definitely supports all of vfat and ext[2-4] out of the box so the problem is not with supported file systems.
User avatar
TrevorH
Forum Moderator
 
Posts: 9132
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

WLAN does not show

Postby nomara » 2013/01/30 10:15:12

Hi,
solved a couple of problems by installing centos again.
Wlan still not working.

I have compactPCI from MEN and a WLAN/3G Module from Option (GTM671W)

lspci semms to know the MEN Module and
lsusb detects Option
lsusb
Bus 002 device 002: ID 0af0:8900 Option


lsmod
...
ath9k ... 0
mac88211 ... 1 ath9k
...


I have no connection to internet. I need to get WLAN work.

nmclie nm
status-not connectet
wlan-active
...


Any idias to how it will work?
nomara
 
Posts: 5
Joined: 2013/01/25 09:03:45


Return to CentOS 6 - General Support

Who is online

Users browsing this forum: No registered users and 7 guests