YUM not working on RHEL4

Issues related to software problems
cozcol
Posts: 2
Joined: 2009/03/10 21:21:25
Contact:

YUM not working on RHEL4

Postby cozcol » 2009/03/11 02:11:53

Hi all,

I am trying to innstall and setup YUM on RHEL4, up2date will not work on this server as it is no longer registered with RHN.

I have installed YUM package yum-2.4.3-4.el4.centos

but am getting thefollowing error, maybe due to release problems or syntax incorrect in /etc/redhat-release.

[]# yum update
Repository base is listed more than once in the configuration
Repository extras is listed more than once in the configuration
Repository addons is listed more than once in the configuration
Setting up Update Process
Setting up repositories
http://dag.linux.iastate.edu/dag/redhat ... repomd.xml: [Errno 4] IOError: HTTP Error 404: Not Found
Trying other mirror.
Cannot open/read repomd.xml file for repository: dag
failure: repodata/repomd.xml from dag: [Errno 256] No more mirrors to try.
Error: failure: repodata/repomd.xml from dag: [Errno 256] No more mirrors to try.
[]#

Can anyone help me with theis please.

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

YUM not working on RHEL4

Postby pschaff » 2009/03/11 02:21:03

I'm repeating myself from another thread; however, these might be helpful:

http://wiki.centos.org/HowTos/PackageMa ... /YumOnRHEL

and possibly

http://wiki.centos.org/HowTos/MigrationGuide

Addresses RHEL5, but the concepts are the same,


Return to “CentOS 4 - Software Support”

Who is online

Users browsing this forum: No registered users and 0 guests