old pentium 233 with 127MB RAM run OpenBSD but can not run CentOS

Issues related to hardware problems

old pentium 233 with 127MB RAM run OpenBSD but can not run CentOS

Postby mfaridi » 2010/06/06 15:17:34

I have old pentium 233 with 127MB of RAM and install on it OpenBSD 4.6 with Fluxbox and it work for me good and I run Snort and Apache and squid and nagios on it and all of them work good and I do not have problem , so I want test CentOS and I go download CentOS 5.5 DVD and start install it on this hardware , but when I type
Code: Select all
linux text
and I want install it with Text mode ,system reboot , after search Google , I understand CentOS 5.5 does not support i586 Hardware

So I download CentOS 4.6 and reboot system with it , but when I want install CentOS with text mode , it reboot again , So in installation page , I press
Code: Select all
F4
and choose another option for install , for example
Code: Select all
i586 text
, but system reboot again and I can not install CentOS
I check other Option . but system reboot and I can not install it .
this is my dmesg in OpenBSD

Code: Select all
OpenBSD 4.6 (GENERIC) #58: Thu Jul  9 21:24:42 MDT 2009
deraadt@i386.openbsd.org:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: Intel Pentium/MMX ("GenuineIntel" 586-class) 234 MHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,MCE,CX8,MMX
real mem  = 133787648 (127MB)
avail mem = 120565760 (114MB)
mainbus0 at root
bios0 at mainbus0: AT/286+ BIOS, date 12/09/97, BIOS32 rev. 0 @ 0xfb6e0
apm0 at bios0: Power Management spec V1.2 (slowidle)
apm0: AC on, battery charge unknown
pcibios0 at bios0: rev 2.1 @ 0xf0000/0xbba8
pcibios0: PCI BIOS has 6 Interrupt Routing table entries
pcibios0: PCI Exclusive IRQs: 9 10 11
pcibios0: PCI Interrupt Router at 000:07:0 ("Intel 82371AB PIIX4 ISA" rev 0x00)
pcibios0: PCI bus #0 is the last bus
bios0: ROM list: 0xc0000/0x8000 cpu0 at mainbus0: (uniprocessor)
cpu0: F00F bug workaround installed pci0 at mainbus0
bus 0: configuration mode 1 (bios)
pchb0 at pci0 dev 0 function 0 "Intel 82439TX System" rev 0x01
piixpcib0 at pci0 dev 7 function 0 "Intel 82371AB PIIX4 ISA" rev 0x01
pciide0 at pci0 dev 7 function 1 "Intel 82371AB IDE" rev 0x01: DMA,
channel 0 wired to compatibility, channel 1 wired to compatibility
wd0 at pciide0 channel 0 drive 1: <QUANTUM FIREBALLlct20 30>
wd0: 8-sector PIO, LBA, 28629MB, 58633344 sectors wd0(pciide0:0:1): using PIO mode 4, Ultra-DMA mode 2
atapiscsi0 at pciide0 channel 1 drive 0 scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <ASUS, CD-S400/A, 1.9K> ATAPI 5/cdrom removable
cd0(pciide0:1:0): using PIO mode 4, Ultra-DMA mode 2
uhci0 at pci0 dev 7 function 2 "Intel 82371AB USB" rev 0x01: irq 11
piixpm0 at pci0 dev 7 function 3 "Intel 82371AB Power" rev 0x01: SMI
iic0 at piixpm0 spdmem0 at iic0
addr 0x50: 128MB SDRAM non-parity PC133CL3 ne3 at pci0
dev 8 function 0 "Compex Compexe" rev 0x0a: irq 10, address 00:80:48:c3:d5:74
vga1 at pci0 dev 9 function 0 "S3 ViRGE DX/GX" rev 0x01
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
ne4 at pci0 dev 10 function 0 "Compex Compexe" rev 0x0a: irq 9, address 00:80:48:ca:1c:2c
isa0 at piixpcib0
isadma0 at isa0
com0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
com1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pmsi0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pmsi0 mux 0 sb0 at isa0 port 0x220/24 irq 5
drq 1: dsp v4.12
midi0 at sb0: <SB MIDI UART>
audio0 at sb0
opl0 at sb0: model OPL3
midi1 at opl0: <SB Yamaha OPL3>
pcppi0 at isa0 port 0x61
midi2 at pcppi0: <PC speaker>
spkr0 at pcppi0 lpt0 at isa0 port 0x378/4 irq 7
npx0 at isa0 port 0xf0/16:
reported by CPUID; using exception 16 fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
usb0 at uhci0: USB revision 1.0
uhub0 at usb0 "Intel UHCI root hub" rev 1.00/1.00 addr 1
biomask e945
netmask ef45
ttymask ffdf
softraid0 at root root on wd0a
swap on wd0b
dump on wd0b
$

I want run only apache and snort on this hardware
How I can solve this problem ?

[Moderator edited to insert the missing newline characters.]
mfaridi
 
Posts: 1
Joined: 2010/06/06 14:58:27

old pentium 233 with 127MB RAM run OpenBSD but can not run C

Postby toracat » 2010/06/07 03:07:46

You can get the i586 version of CentOS 4 from http://i586.centos.org/centos/4/isos/i386/ . More details are here:

http://centosnow.blogspot.com/2009/09/i ... os-48.html
User avatar
toracat
Forum Moderator
 
Posts: 7034
Joined: 2006/09/03 16:37:24
Location: California, US


Return to CentOS 4 - Hardware Support

Who is online

Users browsing this forum: No registered users and 0 guests