compiling and RPM for php-pecl-ci8

General support questions
digrouz
Posts: 18
Joined: 2008/10/15 11:16:02
Location: Mouscron - Belgium
Contact:

compiling and RPM for php-pecl-ci8

Postby digrouz » 2013/05/02 09:41:47

Hello,

I'm trying to build a rpm for php-pecl-ci8.

I was able to make it successfully but when I'm trying to install it I get dependency problems:

Resolving Dependencies
--> Running transaction check
---> Package php-pecl-oci8.x86_64 0:1.4.9-1.el6 will be installed
--> Processing Dependency: libclntsh.so.11.1()(64bit) for package: php-pecl-oci8-1.4.9-1.el6.x86_64
--> Finished Dependency Resolution
Error: Package: php-pecl-oci8-1.4.9-1.el6.x86_64 (/php-pecl-oci8-1.4.9-1.el6.x86_64)
Requires: libclntsh.so.11.1()(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest


This library libclntsh.so.11.1 is provided by oracle-instantclient11.2-basic-11.2.0.3.0-1.x86_64 which is already installed on the system.

How can I fix this?

You can look at my spec file here: http://pastebin.com/Ph6D3Fyu

digrouz
Posts: 18
Joined: 2008/10/15 11:16:02
Location: Mouscron - Belgium
Contact:

Re: compiling and RPM for php-pecl-ci8

Postby digrouz » 2013/05/03 07:02:42

Hello,

I found my problem, It was not from my spec file. In fact the rpms for instantclient-basic distributed by oracle are not correctly made to support the "provides" argument of rpm, I had to rebuild them.


Return to “CentOS 6 - General Support”

Who is online

Users browsing this forum: No registered users and 5 guests