Install hangs at VMware Tools install

General support questions
Sirk
Posts: 2
Joined: 2013/07/12 13:25:26

Install hangs at VMware Tools install

Post by Sirk » 2013/07/12 13:32:05

Using VMWare player to create a 6.4 Minimal VM. Installer goes through package check and then starts running through all it's checks, it then hits a point where player automatically installs Tools. At that point it fails, and the installer hangs. Here's the text.


Installing VMware Tools, please wait...
mount: special device /dev/hda does not exist
mount: block device /dev/sr0 is write-protected, mounting read only
/etc/rc5.d/S99local: line 25: eject: command not found
/etc/rc5.d/S99local: line 25: eject: command not found

simon_matthews
Posts: 315
Joined: 2012/09/15 21:06:54

Re: Install hangs at VMware Tools install

Post by simon_matthews » 2013/07/12 15:12:57

Why are you using VMWare and not KVM?

In any case, this looks like a problem with VMWare, not CentOS.

Sirk
Posts: 2
Joined: 2013/07/12 13:25:26

Re: Install hangs at VMware Tools install

Post by Sirk » 2013/07/12 15:19:50

I'm a newb

tigalch
QA Team
Posts: 522
Joined: 2012/06/23 17:28:41
Location: Austria

Re: Install hangs at VMware Tools install

Post by tigalch » 2013/07/12 18:52:27

Upon first installation of CentOS on VMware-products I always initiate the VMware-Tools installer by hand. Have you tried that (with disabling the automatic installer before starting the VM)?

simon_matthews
Posts: 315
Joined: 2012/09/15 21:06:54

Re: Install hangs at VMware Tools install

Post by simon_matthews » 2013/07/13 03:52:00

[quote]
Sirk wrote:
I'm a newb[/quote]

Unless you have a strong reason to use VMWare, then I strongly advise that you use KVM. KVM is fully integrated into CentOS 6, while VMWare requires additional packages, re-compilation of modules every time the kernel is updated, etc., etc..

So, I will ask again: why are you not using KVM?

User avatar
vonskippy
Posts: 839
Joined: 2006/12/30 03:00:04
Location: Western Slope Colorado

Re: Install hangs at VMware Tools install

Post by vonskippy » 2013/07/13 04:16:28

[quote]
simon_matthews wrote:
Unless you have a strong reason to use VMWare, then I strongly advise that you use KVM.[/quote]
The OP states he's trying to install CentOS into a VM created by VMWare Player.

Since KVM does NOT run on top of Windows, I'm guessing KVM is NOT an option for the OP.

VMWare's VM Player is the bait-n-switch utility trying to get you to buy their VMWare Workstation product. In my opinion it's flaky at best.

Use VirtualBox on top of Windows. It's free, it doesn't have any nag screens or gotcha's since there is no paid bigger brother, and it's way easier to get the VirtualBox tools to install.

YMMV

simon_matthews
Posts: 315
Joined: 2012/09/15 21:06:54

Re: Install hangs at VMware Tools install

Post by simon_matthews » 2013/07/13 14:55:33

[quote]
vonskippy wrote:
[quote]
simon_matthews wrote:
Unless you have a strong reason to use VMWare, then I strongly advise that you use KVM.[/quote]
The OP states he's trying to install CentOS into a VM created by VMWare Player.

Since KVM does NOT run on top of Windows, I'm guessing KVM is NOT an option for the OP.
[/quote]

Yes, I should have thought of that!

geoholix
Posts: 1
Joined: 2014/01/21 10:05:19

Re: Install hangs at VMware Tools install

Post by geoholix » 2014/01/21 10:25:08

Hi Sirk,

don't install centos directly when you create new vm on vmware.
here is step how to fix your problem.
1. create new vm on vmware an choose install operating system later.
2. make sure to mounting your installer (physical disc or iso file).
a. right click on your new vm, select settings
b. pointing to CD/DVD (IDE). select your installer on there (physical disc or iso file)
3. run it your vm, the installation will proceed using gui mode and the error messages doesn't appear

/amri

TiTex
Posts: 36
Joined: 2014/01/21 10:36:33
Location: Cluj-Napoca, Romania

Re: Install hangs at VMware Tools install

Post by TiTex » 2014/01/21 11:19:58

i had the same issue ... geoholix's way is working as expected , i don't know why but if you will try to install directly when you create the VM ... vmware it's trying to assume some stuff and it's not the way most people would like it to behave, anyways this was a long time and since i switched to virtualbox for virtualization on windows workstation , give it a try Sirk if the instructions provided by geoholix won't help

User avatar
TechJaxson
Posts: 1
Joined: 2014/08/29 17:58:52

Re: Install hangs at VMware Tools install

Post by TechJaxson » 2014/09/07 16:40:28

geoholix wrote:Hi Sirk,

don't install centos directly when you create new vm on vmware.
here is step how to fix your problem.
1. create new vm on vmware an choose install operating system later.
2. make sure to mounting your installer (physical disc or iso file).
a. right click on your new vm, select settings
b. pointing to CD/DVD (IDE). select your installer on there (physical disc or iso file)
3. run it your vm, the installation will proceed using gui mode and the error messages doesn't appear

/amri
Thank you. Creating the VM with not choosing an OS, did the trick.
- Created & booted
- Shutdown & attached ISO
- Booted and installed fine.

Post Reply