another postfix issue: error 553

Issues related to applications and software problems
Post Reply
FirebirdTN
Posts: 23
Joined: 2014/02/08 14:53:34

another postfix issue: error 553

Post by FirebirdTN » 2014/04/23 22:45:32

I set up one box to forward root mail to my external email address in postfix. I had a minor issue ( post is here: viewtopic.php?f=14&t=45858 ) that was easily solved.

I just set up a second box, but we are running out of email accounts on our godaddy server, so my webmaster set me up an email account on nexcess. I used the exact same procedures for setting up postfix as I did with godaddy. However when I try to send mail I receive the following error:

...said: 553 sorry, that domain isn't in my list of allowed rcpthosts (#5.7.1) (in reply to RCPT TO command))

Its not quite a big deal, I worked around the issue by using the same account on the first box to authenticate to (that way we didn't have to create a new account for the purposes of authentication), but configured postfix to make it appear as if the email originated from another account.

If this is confusing, basically all I am trying to do is get rool mail forwarded from different (but almost identically configured boxes) to my email account, but making sure that each email is easily identifiable from which box it came from. In other words, box a sends me an email from "boxa@mydomain.com", box b sends me an email from "boxb@mydomain.com", etc.

Like I said, I've worked around it so no big deal, but I am wondering how I would have worked around this error in case I am forced in the future to use this providers email server.

Thanks!

-Alan

FirebirdTN
Posts: 23
Joined: 2014/02/08 14:53:34

Re: another postfix issue: error 553

Post by FirebirdTN » 2014/04/24 00:15:50

I REALLY hate email...Okay, I think I know what was happening here. Just a guess, but I found out nexcess does not support NON-encrypted email setups.

When I set postfix up on box #1, I made sure to use a port that although required authentication, did NOT require encryption.

Looks like if I want to use Nexcess for email with postfix, I have to learn how to set up SSL/TLS. Way to much for simple notification text emails. I will save this for another day.

It would be nice if someone would clarify if that is indeed the issue, as I am new to linux, but its a logical guess based on the google research I have done.

-Alan

User avatar
TrevorH
Forum Moderator
Posts: 23473
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: another postfix issue: error 553

Post by TrevorH » 2014/04/24 00:33:41

Where are you getting the error message about "that domain isn't in my list of allowed rcpthosts"? What the fix is depends on which machine is generating that error message.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

FirebirdTN
Posts: 23
Joined: 2014/02/08 14:53:34

Re: another postfix issue: error 553

Post by FirebirdTN » 2014/04/24 01:02:35

TrevorH wrote:Where are you getting the error message about "that domain isn't in my list of allowed rcpthosts"? What the fix is depends on which machine is generating that error message.
whoops. can't believe I left that tidbit out. That was what was in the postfix mail log.

-Alan

Whoever
Posts: 1024
Joined: 2013/09/06 03:12:10

Re: another postfix issue: error 553

Post by Whoever » 2014/04/24 04:28:09

FirebirdTN wrote:
TrevorH wrote:Where are you getting the error message about "that domain isn't in my list of allowed rcpthosts"? What the fix is depends on which machine is generating that error message.
whoops. can't believe I left that tidbit out. That was what was in the postfix mail log.

-Alan
You *still* have not provided sufficient information. It's not clear if that message applies to emails that your box is receiving or to emails that your box is sending. Why don't you post the complete line (and the lines before it for context) from your maillog?

User avatar
TrevorH
Forum Moderator
Posts: 23473
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: another postfix issue: error 553

Post by TrevorH » 2014/04/24 07:21:24

The important part is: is this error coming from the mail server that you control or from a different one further up the chain?
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

FirebirdTN
Posts: 23
Joined: 2014/02/08 14:53:34

Re: another postfix issue: error 553

Post by FirebirdTN » 2014/04/24 10:30:33

Sorry guys, too late. As I mentioned above, I worked around it by using our original email provider's server, and cleared out the log. Guess I will never know.

FWIW, this box isn't set up to receive email. I'm not setting up full fledged email servers. Its only used to send, for the sole purpose of forwarding root mail, and that error came from our provider's smtp server.

Maybe next time...

-Alan

Post Reply