how to install amarok 1.4

Issues related to applications and software problems

how to install amarok 1.4

Postby ket_nn » 2011/07/23 09:38:52

amarok 1.4 is one of the best players designed for linux.
For CentOS 5 the corresponding rpm can be installed from the Epel repository.
It is no longer available in CentOS 6 or am I wrong ? If there is a straightforward workaround to have it for CentOS 6 ?

Thanks
ket_nn
 
Posts: 20
Joined: 2011/07/21 09:19:12
Location: FRANCE

how to install amarok 1.4

Postby pschaff » 2011/07/23 14:54:11

Closest I can find is exaile from RPMforge repo.
Code: Select all
Name        : exaile
Arch        : x86_64
Version     : 0.2.14
Release     : 2.el6.rf
Size        : 1.0 M
Repo        : rpmforge
Summary     : Music player
URL         : http://www.exaile.org/
License     : GPL
Description : Exaile is a media player aiming to be similar to KDE's AmaroK, but for GTK+.
            : It incorporates many of the cool things from AmaroK (and other media players)
            : like automatic fetching of album art, handling of large libraries, lyrics
            : fetching, artist/album information via the wikipedia, last.fm support, optional
            : iPod support (assuming you have python-gpod installed).
            :
            : In addition, Exaile also includes a built in shoutcast directory browser,
            : tabbed playlists (so you can have more than one playlist open at a time),
            : blacklisting of tracks (so they don't get scanned into your library),
            : downloading of guitar tablature from fretplay.com, and submitting played tracks
            : on your iPod to last.fm
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America

Re: how to install amarok 1.4

Postby ket_nn » 2011/07/24 07:38:20

# yum install exaile.x86_64
Loaded plugins: fastestmirror, priorities, refresh-packagekit
Loading mirror speeds from cached hostfile
* base: ftp.ciril.fr
* centosplus: ftp.ciril.fr
* elrepo: elrepo.imt-systems.com
* elrepo-extras: elrepo.imt-systems.com
* elrepo-kernel: elrepo.imt-systems.com
* extras: ftp.ciril.fr
* rpmforge: apt.sw.be
* rpmforge-extras: apt.sw.be
* updates: ftp.ciril.fr
adobe-linux-i386 | 951 B 00:00
base | 3.7 kB 00:00
centosplus | 3.5 kB 00:00
elrepo | 1.9 kB 00:00
elrepo-extras | 1.9 kB 00:00
elrepo-kernel | 951 B 00:00
extras | 951 B 00:00
google-chrome | 951 B 00:00
rpmforge | 975 B 00:00
rpmforge-extras | 975 B 00:00
updates | 3.5 kB 00:00
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package exaile.x86_64 0:0.2.14-2.el6.rf set to be updated
--> Processing Dependency: python-mutagen >= 1.8 for package: exaile-0.2.14-2.el6.rf.x86_64
--> Processing Dependency: python-sqlite2 for package: exaile-0.2.14-2.el6.rf.x86_64
--> Processing Dependency: python-sexy for package: exaile-0.2.14-2.el6.rf.x86_64
--> Processing Dependency: python-cddb for package: exaile-0.2.14-2.el6.rf.x86_64
--> Processing Dependency: gnome-python2-gtkmozembed for package: exaile-0.2.14-2.el6.rf.x86_64
--> Running transaction check
---> Package exaile.x86_64 0:0.2.14-2.el6.rf set to be updated
--> Processing Dependency: python-sqlite2 for package: exaile-0.2.14-2.el6.rf.x86_64
--> Processing Dependency: python-cddb for package: exaile-0.2.14-2.el6.rf.x86_64
--> Processing Dependency: gnome-python2-gtkmozembed for package: exaile-0.2.14-2.el6.rf.x86_64
---> Package python-mutagen.noarch 0:1.16-2.1.el6 set to be updated
---> Package python-sexy.x86_64 0:0.1.9-9.1.el6 set to be updated
--> Processing Dependency: libsexy >= 0.1.10 for package: python-sexy-0.1.9-9.1.el6.x86_64
--> Processing Dependency: libsexy.so.2()(64bit) for package: python-sexy-0.1.9-9.1.el6.x86_64
--> Running transaction check
---> Package exaile.x86_64 0:0.2.14-2.el6.rf set to be updated
--> Processing Dependency: python-sqlite2 for package: exaile-0.2.14-2.el6.rf.x86_64
--> Processing Dependency: python-cddb for package: exaile-0.2.14-2.el6.rf.x86_64
--> Processing Dependency: gnome-python2-gtkmozembed for package: exaile-0.2.14-2.el6.rf.x86_64
---> Package libsexy.x86_64 0:0.1.11-13.el6 set to be updated
--> Finished Dependency Resolution
Error: Package: exaile-0.2.14-2.el6.rf.x86_64 (rpmforge)
Requires: python-cddb
Error: Package: exaile-0.2.14-2.el6.rf.x86_64 (rpmforge)
Requires: gnome-python2-gtkmozembed
Error: Package: exaile-0.2.14-2.el6.rf.x86_64 (rpmforge)
Requires: python-sqlite2
You could try using --skip-broken to work around the problem
ket_nn
 
Posts: 20
Joined: 2011/07/21 09:19:12
Location: FRANCE

Re: how to install amarok 1.4

Postby pschaff » 2011/07/24 09:57:03

Please report the problem on the Repoforge (formerly RPMforge) mailing list.
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America

Re: how to install amarok 1.4

Postby chrismax » 2011/08/10 22:39:38

I have the exact same problem.
But don't we have the original amarok somewhere ? I managed to install digikam and k3b, but i can not find amarok in any of the repo....
chrismax
 
Posts: 14
Joined: 2011/08/09 20:41:02

Re: how to install amarok 1.4

Postby pschaff » 2011/08/11 11:31:09

As there is no Amarok packaged for EL6, about all one could do is file a request at a 3rd party repo, and/or try to rebuild the EL5 SRPM.
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America


Return to CentOS 6 - Software Support

Who is online

Users browsing this forum: No registered users and 5 guests