Problem with apache & mysql version

Issues related to applications and software problems

Problem with apache & mysql version

Postby misaf » 2011/08/08 21:03:29

hi,
i install CentOS 6.0_i386 on my server and then install apache & mysql with command :

1.yum update

2. yum install mysql mysql-server

3. yum install httpd

but after installation, version of apache & mysql is very old, and i need install newer version

Apache 2.2.17
MySQL 5.1.56

this problem its for php anyway...

please help me :-(
misaf
 
Posts: 3
Joined: 2011/08/08 20:58:02

Re: Problem with apache & mysql version

Postby hawaiian717 » 2011/08/09 19:11:57

Neither of these are the correct version for CentOS 6 (or CentOS 5 for that matter). Versions included with CentOS 6 are:

Apache 2.2.15
PHP 5.3.2

Was this a clean install or did you attempt to upgrade from another distribution?
hawaiian717
 
Posts: 172
Joined: 2009/01/30 19:58:25
Location: California

Re: Problem with apache & mysql version

Postby misaf » 2011/08/09 20:24:20

i used clean install,
if these are for centos 6 or 5 why on my dedicated server on hetzner.de datacenter was install apache 2.2.17 and php 5.3.6 ?
misaf
 
Posts: 3
Joined: 2011/08/08 20:58:02

Re: Problem with apache & mysql version

Postby hawaiian717 » 2011/08/09 22:17:45

Sorry, I misread your post's second line with the MySQL version as a PHP version. CentOS 6 comes with MySQL 5.1.47.

See this FAQ entry, which explains how package versions are handled in CentOS: Where can I get the latest version of XyZ.rpm for CentOS? I cannot find it anywhere.
hawaiian717
 
Posts: 172
Joined: 2009/01/30 19:58:25
Location: California

Re: Problem with apache & mysql version

Postby pschaff » 2011/08/11 12:02:31

Welcome to the CentOS fora. Please see the recommended reading for new users linked in my signature.

misaf wrote:
i used clean install,
if these are for centos 6 or 5 why on my dedicated server on hetzner.de datacenter was install apache 2.2.17 and php 5.3.6 ?

We can't say what the provider may have done on a dedicated server. I can find no later Apache packages for CentOS/EL-6 but the Atomic repository has later PHP packages. Please note the warnings on the linked page before proceeding.
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America

Problem with apache & mysql version

Postby gerald_clark » 2011/08/11 14:57:53

CentOS does not have an 'Apache' package.
It has 'httpd' 2.2.15.

If you have an 'Apache' package, you are not running CentOS.
gerald_clark
 
Posts: 7180
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Re: Problem with apache & mysql version

Postby pschaff » 2011/08/11 17:31:24

gerald_clark wrote:
CentOS does not have an 'Apache' package.
It has 'httpd' 2.2.15.

If you have an 'Apache' package, you are not running CentOS.

Code: Select all
$ rpm -qip httpd-2.2.15-5.el6.centos.x86_64.rpm
Name        : httpd                        Relocations: (not relocatable)
Version     : 2.2.15                            Vendor: CentOS
Release     : 5.el6.centos                  Build Date: Thu 07 Jul 2011 06:31:46 AM EDT
Install Date: (not installed)               Build Host: c6b6.bsys.dev.centos.org
Group       : System Environment/Daemons    Source RPM: httpd-2.2.15-5.el6.centos.src.rpm
Size        : 3057369                          License: ASL 2.0
Signature   : RSA/8, Thu 07 Jul 2011 07:50:26 AM EDT, Key ID 0946fca2c105b9de
Packager    : CentOS BuildSystem <http://bugs.centos.org>
URL         : http://httpd.apache.org/
Summary     : [b]Apache[/b] HTTP Server
Description :
The [b]Apache[/b] HTTP Server is a powerful, efficient, and extensible
web server.

:-)
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America

Re: Problem with apache & mysql version

Postby misaf » 2011/08/11 22:03:57

yes,
i mean httpd

but in php 5.3.2 a lot of php functions was not work and in my company we have any problem with this functions.

any one known how we can install imagick on centos 6.0 ?
misaf
 
Posts: 3
Joined: 2011/08/08 20:58:02

Re: Problem with apache & mysql version

Postby pschaff » 2011/08/11 22:13:18

misaf wrote:
but in php 5.3.2 a lot of php functions was not work and in my company we have any problem with this functions.

Do you mean many problems? CentOS-6.1 will have php-5.3.3-3.el6 - hopefully soon now - but there is no way to know if that will fix unspecified problems.

any one known how we can install imagick on centos 6.0 ?

EPEL has php-pecl-imagick-2.2.2-4.el6 but we are wandering rather far off the original topic. If you have additional questions not related to the httpd and mysql versions please start a fresh Topic.
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America


Return to CentOS 6 - Software Support

Who is online

Users browsing this forum: FirebirdTN, markkuk and 4 guests