[SOLVED] VSFTPD usr info mising? Getting connection refused.

Issues related to applications and software problems

[SOLVED] VSFTPD usr info mising? Getting connection refused.

Postby louarnold » 2011/09/03 02:44:29

I have a mall home network that I run Win XP, Win7, Vista and CentOS 6 on.They are connected to a router for internet access.

Previously, on CentOS 5.5, I set up VSFTPD quite successfully to permit access from outside to the VSFTPD server. I tried to duplicate this on CentOS 6, but its not working. On XP, WS_FTP-LE (the ftp client) gives me a "connection refused" message.

The CentOS machine has been assigned a static IP address, and VSFTPD has been set up to disallow local and anonymous logins. SELinux has been disabled as has the firewall. The router has been set up with a DMZ (to the CentOS IP address). There is only one other user - a normal user - defined in the system. I'm trying to log in with that name.

I can ping the CentOS machine via the LAN address (192.168...) and via the router IP address (99.xxx.xxx.xxx), and get packets back successfully. But I cannot verify that the router forwards to the Centos machine.
I cannot understand the difference between inetd started vsftpd and the non-inetd started variety, ie how the are different in operation.

My goal is to vector the one user's FTP to a specific folder on the machine, say' /mnt/bigdisk/FTPShare/'
Here is the vsftpd.conf file:
Code: Select all
#The following lists directives which affect vsftpd's logging behavior.

#Network Options
#The following lists directives which affect how vsftpd interacts with the network.
#1-Disable port style connection = Yes by default.
#2-connect_from_port_20 is NO by default.
#3-Enable passive connection: Yes by default.

#pasv_address — Specifies the IP address for the public facing IP address of the server for servers behind Network Address
# Translation (NAT) firewalls.
# This enables vsftpd to hand out the correct return address for passive mode connections.

And here is the vsftpd.xinetd file
Code: Select all
# default: off
# description: The vsftpd FTP server serves FTP connections. It uses \
#   normal, unencrypted usernames and passwords for authentication.
service ftp
   socket_type      = stream
   wait         = no
   user         = root
   server         = /usr/sbin/vsftpd
   server_args             = /etc/vsftpd/vsftpd.conf
   nice         = 10
   disable         = yes
   flags         = IPv4

banner_fail             = /etc/vsftpd.busy_banner

per_source              = 1
instances               = 1

log_on_success          += PID HOST DURATION
log_on_failure          += HOST

Posts: 107
Joined: 2009/09/16 23:22:47
Location: Ottawa, Canada

Re: VSFTPD usr info mising? Getting connection refused.

Postby louarnold » 2011/09/04 01:02:54

SOLVED - I found the solution at http://forums.opensuse.org/english/get- ... inetd.html

The problem was with "one_process_model=YES". Yes means anonymous only. When I rebooted the server system and tried the FTP again,
from the XP machine I got the message: "500 OOPS: vsftpd: security: 'one_process_model' is anonymous only" Since I set anonymous_enable=NO, things were a bit conflicted. Fixing this helped immensely.

Another item, that may not have caused the failure directly is: listen=Yes. This means that the server operates in stand-alone (daemon) mode. However, I also had the vsftpd file in /etc/xinted.d and that conflicts with listen=yes.

So now ftp from the XP machine works, either to the LAN address or via the router's outside IP address.
Posts: 107
Joined: 2009/09/16 23:22:47
Location: Ottawa, Canada

[SOLVED] VSFTPD usr info mising? Getting connection refused.

Postby pschaff » 2011/09/17 15:37:02

Thanks for reporting back, but I do hope you have now enabled SELinux and the firewall. Marking this thread [SOLVED] for posterity.
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America

Return to CentOS 6 - Software Support

Who is online

Users browsing this forum: No registered users and 6 guests