[SOLVED] remove wpa_supplicant

Issues related to configuring your network
Post Reply
may24
Posts: 30
Joined: 2014/10/13 15:35:36

[SOLVED] remove wpa_supplicant

Post by may24 » 2015/02/15 11:20:47

Hi all,

my Storage Server has a Asus E450 board and comes with on-board Wifi. As it is sitting in my basement there's no need to have the WIFI enabled, and so I removed its config.
However, a "ps -ef" reveals that the wpa_supplicant is still running.
Unfortunately I haven't found a way to disable it from starting.
Does anyone know how to ?

User avatar
AlanBartlett
Forum Moderator
Posts: 9323
Joined: 2007/10/22 11:30:09
Location: ~/Earth/UK/England/Suffolk
Contact:

Re: remove wpa_supplicant

Post by AlanBartlett » 2015/02/15 15:18:05

As I currently do not have access to a CentOS 7 system upon which to check, I presume that wpa_supplicant is started as a "systemd" service. Please take a look at --

man systemctl

My suggestion is therefore --

systemctl -t service

to obtain a current list of services and then, assuming that wpa_supplicant is in the above list --

systemctl stop wpa_supplicant
systemctl disable wpa_supplicant
Image 100% Linux and, previously, Unix. Co-founder of the ELRepo Project.

aks
Posts: 2844
Joined: 2014/09/20 11:22:14

Re: remove wpa_supplicant

Post by aks » 2015/02/15 16:27:17

Can't use nm-connection-editor to disable the connection?

may24
Posts: 30
Joined: 2014/10/13 15:35:36

Re: [SOLVED] remove wpa_supplicant

Post by may24 » 2015/02/15 19:14:47

Thanks a lot

systemctl disable wpa_supplicant did it :)

User avatar
AlanBartlett
Forum Moderator
Posts: 9323
Joined: 2007/10/22 11:30:09
Location: ~/Earth/UK/England/Suffolk
Contact:

Re: [SOLVED] remove wpa_supplicant

Post by AlanBartlett » 2015/02/16 01:30:48

That's good to know. Thank you for reporting back.
Image 100% Linux and, previously, Unix. Co-founder of the ELRepo Project.

highbury
Posts: 2
Joined: 2016/09/22 13:36:31

Re: [SOLVED] remove wpa_supplicant

Post by highbury » 2016/09/22 13:47:26

Just a follow-on to this issue.

I found that

Code: Select all

systemctl disable wpa_supplicant
was not sufficient to stop daemon running after rebooting.

Code: Select all

[root@Steve-kickstart-client01 ~]# systemctl status wpa_supplicant.service
● wpa_supplicant.service - WPA Supplicant daemon
   Loaded: loaded (/usr/lib/systemd/system/wpa_supplicant.service; disabled; vendor preset: disabled)
   Active: active (running) since Thu 2016-09-22 14:19:34 BST; 38s ago
 Main PID: 809 (wpa_supplicant)
   CGroup: /system.slice/wpa_supplicant.service
           └─809 /usr/sbin/wpa_supplicant -u -f /var/log/wpa_supplicant.log -c /etc/wpa_supplicant/wpa_supplicant.conf -u -f /var/log/wpa_supplicant.log -P /var/run/wpa_supplicant.pid

Sep 22 14:19:34 Steve-kickstart-client01 systemd[1]: Starting WPA Supplicant daemon...
Sep 22 14:19:34 Steve-kickstart-client01 systemd[1]: Started WPA Supplicant daemon.
You see, even though its marked as disabled, its still active!

The only solution seemed to be to

Code: Select all

ln -s /dev/null /etc/systemd/system/wpa_supplicant.service
after rebooting

Code: Select all

[root@Steve-kickstart-client01 ~]# systemctl status wpa_supplicant.service
● wpa_supplicant.service
   Loaded: masked (/dev/null)
   Active: inactive (dead)

User avatar
TrevorH
Forum Moderator
Posts: 26983
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: [SOLVED] remove wpa_supplicant

Post by TrevorH » 2016/09/22 14:46:01

The correct command to totally disable a service is systemctl mask wpa_supplicant.service
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply

Return to “CentOS 7 - Networking Support”