[SOLVED] Yum Update Issue

Issues related to applications and software problems
starkp
Posts: 5
Joined: 2011/10/27 12:12:49

[SOLVED] Yum Update Issue

Postby starkp » 2011/10/27 12:20:58

I'm trying to do a yum update after installing the CentOS 6.0 continuous release package and am receiving the following error:

http://mirror.centos.org/centos/6/cr/x8 ... sqlite.bz2: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404"

Below is a copy of the full yum output. I was wondering if anyone has seen this before and has an suggestions on how to resolve the issue.

# yum update
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
epel/metalink | 13 kB 00:00
* base: mirrors.loosefoot.com
* epel: mirror.pnl.gov
* extras: mirror.7x24web.net
* updates: mirrors.loosefoot.com
http://mirrors.loosefoot.com/centos/6.0 ... repomd.xml: [Errno 12] Timeout on http://mirrors.loosefoot.com/centos/6.0 ... repomd.xml: (28, 'Operation too slow. Less than 1 bytes/sec transfered the last 30 seconds')
Trying other mirror.
base | 3.7 kB 00:00
cr | 3.5 kB 00:00
extras | 3.0 kB 00:00
updates | 3.5 kB 00:00
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package avahi-libs.x86_64 0:0.6.25-8.el6 will be updated
---> Package avahi-libs.x86_64 0:0.6.25-11.el6 will be an update
---> Package cups-libs.x86_64 1:1.4.2-35.el6_0.1 will be updated
---> Package cups-libs.x86_64 1:1.4.2-39.el6_1.1 will be an update
---> Package freetype.x86_64 0:2.3.11-6.el6_0.2 will be updated
---> Package freetype.x86_64 0:2.3.11-6.el6_1.6 will be an update
---> Package gtk2.x86_64 0:2.18.9-4.el6 will be updated
---> Package gtk2.x86_64 0:2.18.9-6.el6 will be an update
---> Package libgcj.x86_64 0:4.4.4-13.el6 will be updated
---> Package libgcj.x86_64 0:4.4.5-6.el6 will be an update
---> Package libpng.x86_64 2:1.2.44-1.el6 will be updated
---> Package libpng.x86_64 2:1.2.46-1.el6_1 will be an update
---> Package tomcat6.noarch 0:6.0.24-24.el6_0 will be updated
---> Package tomcat6.noarch 0:6.0.24-33.el6 will be an update
--> Processing Dependency: jakarta-commons-dbcp for package: tomcat6-6.0.24-33.el6.noarch
--> Processing Dependency: jakarta-commons-pool for package: tomcat6-6.0.24-33.el6.noarch
---> Package tomcat6-el-2.1-api.noarch 0:6.0.24-24.el6_0 will be updated
---> Package tomcat6-el-2.1-api.noarch 0:6.0.24-33.el6 will be an update
---> Package tomcat6-jsp-2.1-api.noarch 0:6.0.24-24.el6_0 will be updated
---> Package tomcat6-jsp-2.1-api.noarch 0:6.0.24-33.el6 will be an update
---> Package tomcat6-lib.noarch 0:6.0.24-24.el6_0 will be updated
---> Package tomcat6-lib.noarch 0:6.0.24-33.el6 will be an update
---> Package tomcat6-servlet-2.5-api.noarch 0:6.0.24-24.el6_0 will be updated
---> Package tomcat6-servlet-2.5-api.noarch 0:6.0.24-33.el6 will be an update
--> Running transaction check
---> Package jakarta-commons-dbcp.noarch 0:1.2.1-13.8.el6 will be installed
---> Package jakarta-commons-pool.x86_64 0:1.3-12.7.el6 will be installed
http://mirror.centos.org/centos/6/cr/x8 ... sqlite.bz2: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404"
Trying other mirror.
Error: failure: repodata/832df7750d5bfa897f15dacba07c340406df4ae026fa2b484c152af2f2c96ebd-filelists.sqlite.bz2 from cr: [Errno 256] No more mirrors to try.

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

[SOLVED] Yum Update Issue

Postby pschaff » 2011/10/27 22:32:27

Welcome to the CentOS fora. Please see the recommended reading for new users linked in my signature.

First thing to try is the usual

Code: Select all

yum clean all

r_hartman
Posts: 701
Joined: 2009/03/23 15:08:11
Location: Netherlands
Contact:

Re: Yum Update Issue

Postby r_hartman » 2011/10/28 08:51:52

I happened to notice you are running 3rd party repositories and do not have yum-plugin-priorities installed.
This could compromise your system, so please install and configure yum-plugin-priorities.

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

Re: Yum Update Issue

Postby pschaff » 2011/10/28 09:33:02

Good catch. Although EPEL is pretty safe in isolation, due to their stated policy of not replacing core packages, it's time to say - if more help is needed then please provide more information about your system by running "./getinfo.sh package" and showing us the output file.

starkp
Posts: 5
Joined: 2011/10/27 12:12:49

Re: Yum Update Issue

Postby starkp » 2011/10/28 14:50:07

Thanks Phil and René for the quick reply.

I tried the yum clean all and it looks to still be generating the same error and I also installed the yum-plugin-priorities package and re-ran the yum clean all and am still getting the same error.

I posted the output of the ./getinfo.sh package output to http://pastebin.centos.org/37995.

Not sure if this info helps at all but it looks like I am getting the error when I try yum update libgcj

Thanks again for your help.

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

Re: Yum Update Issue

Postby pschaff » 2011/10/30 01:39:49

All I can see from the script output that is off-nominal is that you have EPEL installed and enabled (as previously noted) and you have yum-plugin-priorities installed but no priorities defined, so everything will default to 99 - the lowest.

Please post the full output from

Code: Select all

yum -v -d 9 update libgcj

User avatar
TrevorH
Forum Moderator
Posts: 18533
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Yum Update Issue

Postby TrevorH » 2011/10/30 11:43:13

Could you also post the stanza from /etc/yum.repos.d/CentOS-Base.repo for the 'base' repo?

I've had so many problems with yum-fastestmirror at work that I think it's worth trying

Code: Select all

yum --disableplugin=fastestmirror update

starkp
Posts: 5
Joined: 2011/10/27 12:12:49

Re: Yum Update Issue

Postby starkp » 2011/10/31 12:20:53

Hi Phil,
I've posted a copy of the output to http://pastebin.centos.org/37997

starkp
Posts: 5
Joined: 2011/10/27 12:12:49

Re: Yum Update Issue

Postby starkp » 2011/10/31 12:22:36

TrevorH,
Below is a copy of the output after disabling fastest mirror

# yum --disableplugin=fastestmirror update
Loaded plugins: priorities
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package libgcj.x86_64 0:4.4.4-13.el6 will be updated
---> Package libgcj.x86_64 0:4.4.5-6.el6 will be an update
http://mirror.centos.org/centos/6/cr/x8 ... sqlite.bz2: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404"
Trying other mirror.
Error: failure: repodata/832df7750d5bfa897f15dacba07c340406df4ae026fa2b484c152af2f2c96ebd-filelists.sqlite.bz2 from cr: [Errno 256] No more mirrors to try.
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

User avatar
TrevorH
Forum Moderator
Posts: 18533
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Yum Update Issue

Postby TrevorH » 2011/10/31 12:55:56

This looks to me like you are picking up the wrong version of repodata/repomd.xml and it's referring to out of date or non-existent files that it then tries to retrieve.

Are you behind a web proxy? I seem to recall a similar problem recently where it was using two different mirrors, one to fetch the repomd.xml and then the other to fetch the actual xml files and they were out of sync. Maybe look at adding http_caching=packages to /etc/yum.conf and see if that helps?


Return to “CentOS 6 - Software Support”

Who is online

Users browsing this forum: No registered users and 0 guests