[SOLVED] Yum problem

Issues related to applications and software problems

[SOLVED] Yum problem

Postby spookie2005 » 2011/12/29 15:58:13

Hi,

I tried to install a new repository becuase I wanted to install transmission.These repositories are called geekery. and epel It didn't work (no longer?),so I wanted to remove these repositories.I tried some pages I found on the net starting from removing the repository itself (the file) or removing the package when there is one found (this case:None).Then I tried yum clean all but I still got these messages

[root@localhost ~]# yum update
Loaded plugins: fastestmirror, refresh-packagekit
Determining fastest mirrors
* base: be.mirror.eurid.eu
* extras: be.mirror.eurid.eu
* rpmforge: apt.sw.be
* updates: be.mirror.eurid.eu
base | 3.7 kB 00:00
base/primary_db | 4.5 MB 00:05
extras | 3.5 kB 00:00
extras/primary_db | 5.3 kB 00:00
rpmforge | 1.1 kB 00:00
rpmforge/primary | 3.9 MB 00:09
rpmforge 10900/10900
updates | 3.5 kB 00:00
updates/primary_db | 654 kB 00:00
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package python-beaker.noarch 0:1.3.1-6.el6 will be updated
---> Package python-beaker.noarch 0:1.5.3-1.el5.rf will be an update
--> Processing Dependency: python(abi) = 2.4 for package: python-beaker-1.5.3-1.el5.rf.noarch
---> Package python-mako.noarch 0:0.3.4-1.el6 will be updated
---> Package python-mako.noarch 0:0.3.5-1.el5.rf will be an update
--> Processing Dependency: python(abi) = 2.4 for package: python-mako-0.3.5-1.el5.rf.noarch
---> Package python-markupsafe.x86_64 0:0.9.2-4.el6 will be updated
---> Package python-markupsafe.x86_64 0:0.11-1.el5.rf will be an update
--> Processing Dependency: python(abi) = 2.4 for package: python-markupsafe-0.11-1.el5.rf.x86_64
---> Package python-paramiko.noarch 0:1.7.5-2.1.el6 will be updated
---> Package python-paramiko.noarch 0:1.7.6-1.el5.rf will be an update
--> Processing Dependency: python(abi) = 2.4 for package: python-paramiko-1.7.6-1.el5.rf.noarch
--> Finished Dependency Resolution
Error: Package: python-paramiko-1.7.6-1.el5.rf.noarch (rpmforge)
Requires: python(abi) = 2.4
Installed: python-2.6.6-29.el6.x86_64 (@base)
python(abi) = 2.6
Error: Package: python-markupsafe-0.11-1.el5.rf.x86_64 (rpmforge)
Requires: python(abi) = 2.4
Installed: python-2.6.6-29.el6.x86_64 (@base)
python(abi) = 2.6
Error: Package: python-beaker-1.5.3-1.el5.rf.noarch (rpmforge)
Requires: python(abi) = 2.4
Installed: python-2.6.6-29.el6.x86_64 (@base)
python(abi) = 2.6
Error: Package: python-mako-0.3.5-1.el5.rf.noarch (rpmforge)
Requires: python(abi) = 2.4
Installed: python-2.6.6-29.el6.x86_64 (@base)
python(abi) = 2.6
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

So I was wondering:What can I do next ? Any ideas? Did I remove too much?
spookie2005
 
Posts: 35
Joined: 2009/06/19 18:35:27

Re: Yum problem

Postby TrevorH » 2011/12/29 17:58:57

---> Package python-beaker.noarch 0:1.5.3-1.el5.rf will be an update


You seem to have the rpmforge for EL5 installed instead of the one for EL6.
User avatar
TrevorH
Forum Moderator
 
Posts: 9103
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Yum problem

Postby spookie2005 » 2011/12/29 22:46:02

Okay,thanks TrevorH,so I uninstall the one for EL5 and install the one for EL6?
spookie2005
 
Posts: 35
Joined: 2009/06/19 18:35:27

Re: Yum problem

Postby TrevorH » 2011/12/30 00:14:31

Sounds like a wise plan :-)
User avatar
TrevorH
Forum Moderator
 
Posts: 9103
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Yum problem

Postby spookie2005 » 2012/01/07 10:53:57

OK,I installed the "el6" but it looks like I still have this problem,still have the same error message...I guess I did something wrong,can you help me out?
spookie2005
 
Posts: 35
Joined: 2009/06/19 18:35:27

[SOLVED] Yum problem

Postby pschaff » 2012/01/07 11:54:40

Please provide more information about your system by running "./getinfo.sh" and showing us the output file, along with the results of
Code: Select all
rpm -qa | fgrep .el5 | sort
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America

Re: Yum problem

Postby spookie2005 » 2012/01/07 13:54:15

Result of ./getinfo.sh

http://pastebin.centos.org/38247

and

[name@localhost tmp]$ rpm -qa | fgrep .el5 | sort
libedit-20090923-3.0_1.el5.rf.x86_64
libffi-3.0.9-1.el5.rf.x86_64
libssh2-1.2.7-1.el5.rf.x86_64
perl-Test-Harness-3.22-1.el5.rf.noarch
perl-Test-Simple-0.98-1.el5.rf.noarch
portreserve-0.0.5-2.el5.rf.x86_64
spookie2005
 
Posts: 35
Joined: 2009/06/19 18:35:27

Re: Yum problem

Postby pschaff » 2012/01/07 14:02:54

All those .el5. packages should be removed or replaced by the el6 versions. libssh2 is particularly problematic as a key core CentOS-6 package has been replaced by the el5 version.

You repo configs show that you have epel-release installed but not showing up in the configured repos. You must have manually deleted or renamed

/etc/yum.repos.d/epel-testing.repo
/etc/yum.repos.d/epel.repo

that are installed by that package. If you do enable both rpmforge and epel then problems are pretty much guaranteed.

You have not installed configured yum priorities plugin to protect base repos from replacement by 3rd-party packages, and to manage multiple 3rd party repos, if used.

After fixing those issues try
Code: Select all
yum clean all
yum update
again and show the complete output if still having problems.
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America

Re: Yum problem

Postby spookie2005 » 2012/01/07 16:17:39

Thank you pschaff ! I followed your advice and do no longer have an error when trying to update....

I guess I installed epel to try to install transmission or audacity on centos 6,I guess I followed the wrong guide?
spookie2005
 
Posts: 35
Joined: 2009/06/19 18:35:27

Re: [SOLVED] Yum problem

Postby pschaff » 2012/01/07 16:29:08

You are welcome. Thanks for reporting back. Marking this thread [SOLVED] for posterity.
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America

Next

Return to CentOS 6 - Software Support

Who is online

Users browsing this forum: No registered users and 4 guests