Cant install mplayer, mcoder, flvtool2

Issues related to applications and software problems

Cant install mplayer, mcoder, flvtool2

Postby Apox » 2012/02/28 11:52:04

Im trying to install mplayer, mcoder, flvtool2 to the server but i cant.


yum -y install ffmpeg ffmpeg-devel mplayer mencoder flvtool2

It gives me this errors.

Code: Select all
Error: Package: mencoder-1.0-0.47.svn20100703.el5.rf.i386 (rpmforge)
           Requires: libfribidi.so.0
Error: Package: mpg123-1.13.4-1.el5.rf.i386 (rpmforge)
           Requires: libltdl.so.3
Error: Package: aalib-1.4.0-5.el5.rf.i386 (rpmforge)
           Requires: libgpm.so.1
Error: Package: mplayer-1.0-0.47.svn20100703.el5.rf.i386 (rpmforge)
           Requires: libfribidi.so.0
Error: Package: flvtool2-1.0.6-1.el5.rf.noarch (rpmforge)
           Requires: /usr/bin/ruby
Error: Package: flvtool2-1.0.6-1.el5.rf.noarch (rpmforge)
           Requires: ruby
 You could try using --skip-broken to work around the problem
** Found 5 pre-existing rpmdb problem(s), 'yum check' output follows:
bandmin-1.6.1-5.noarch has missing requires of perl(bandmin.conf)
bandmin-1.6.1-5.noarch has missing requires of perl(bmversion.pl)
bandmin-1.6.1-5.noarch has missing requires of perl(services.conf)
exim-4.69-30_cpanel_maildir.i386 has missing requires of perl(SafeFile)
frontpage-2002-SR1.2.i386 has missing requires of libexpat.so.0


What shall i do ? I cant find any anser on it.
Apox
 
Posts: 5
Joined: 2011/11/02 18:57:36

Cant install mplayer, mcoder, flvtool2

Postby gerald_clark » 2012/02/28 14:17:59

You are running CentOS 6 and trying to install from a CentOS 5 repo.
Uninstall your rpmforge repo and install the correct one,
gerald_clark
 
Posts: 7166
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Re: Cant install mplayer, mcoder, flvtool2

Postby Apox » 2012/02/28 15:47:57

hm, i get alot more errors now...

Code: Select all
--> Finished Dependency Resolution
Error: Package: mplayer-1.0-0.47.svn20100703.el6.rf.i686 (rpmforge)
           Requires: libXss.so.1
Error: Package: librtmp-devel-2.3-1.el6.rf.i686 (rpmforge)
           Requires: pkgconfig(gnutls)
Error: Package: mencoder-1.0-0.47.svn20100703.el6.rf.i686 (rpmforge)
           Requires: libmng.so.1
Error: Package: mencoder-1.0-0.47.svn20100703.el6.rf.i686 (rpmforge)
           Requires: liblzo2.so.2
Error: Package: mplayer-1.0-0.47.svn20100703.el6.rf.i686 (rpmforge)
           Requires: libpulse.so.0
Error: Package: ffmpeg-0.6.5-1.el6.rf.i686 (rpmforge)
           Requires: libtheoradec.so.1
Error: Package: mencoder-1.0-0.47.svn20100703.el6.rf.i686 (rpmforge)
           Requires: libopenjpeg.so.2
Error: Package: mplayer-1.0-0.47.svn20100703.el6.rf.i686 (rpmforge)
           Requires: libcdda_interface.so.0
Error: Package: mplayer-1.0-0.47.svn20100703.el6.rf.i686 (rpmforge)
           Requires: libXv.so.1
Error: Package: schroedinger-devel-1.0.10-1.el6.rf.i686 (rpmforge)
           Requires: liboil-devel >= 0.3.16
Error: Package: mplayer-1.0-0.47.svn20100703.el6.rf.i686 (rpmforge)
           Requires: libXvMC.so.1
Error: Package: libcaca-0.99-0.1.beta17.el6.rf.i686 (rpmforge)
           Requires: libglut.so.3
Error: Package: mpg123-1.13.4-1.el6.rf.i686 (rpmforge)
           Requires: libesd.so.0
Error: Package: mencoder-1.0-0.47.svn20100703.el6.rf.i686 (rpmforge)
           Requires: libdv.so.4
Error: Package: mplayer-1.0-0.47.svn20100703.el6.rf.i686 (rpmforge)
           Requires: libmpcdec.so.5
Error: Package: flvtool2-1.0.6-1.el6.rf.noarch (rpmforge)
           Requires: /usr/bin/ruby
Error: Package: ffmpeg-devel-0.6.5-1.el6.rf.i686 (rpmforge)
           Requires: libtheora-devel
Error: Package: ffmpeg-0.6.5-1.el6.rf.i686 (rpmforge)
           Requires: libtheoraenc.so.1(libtheoraenc_1.0)
Error: Package: ffmpeg-devel-0.6.5-1.el6.rf.i686 (rpmforge)
           Requires: libdc1394-devel
Error: Package: twolame-0.3.13-1.el6.rf.i686 (rpmforge)
           Requires: libsndfile.so.1(libsndfile.so.1.0)
Error: Package: mplayer-1.0-0.47.svn20100703.el6.rf.i686 (rpmforge)
           Requires: libcdda_paranoia.so.0
Error: Package: mplayer-1.0-0.47.svn20100703.el6.rf.i686 (rpmforge)
           Requires: libopenjpeg.so.2
Error: Package: mplayer-1.0-0.47.svn20100703.el6.rf.i686 (rpmforge)
           Requires: libsmbclient.so.0
Error: Package: mplayer-1.0-0.47.svn20100703.el6.rf.i686 (rpmforge)
           Requires: libartsc.so.0
Error: Package: mplayer-1.0-0.47.svn20100703.el6.rf.i686 (rpmforge)
           Requires: libesd.so.0
Error: Package: ffmpeg-devel-0.6.5-1.el6.rf.i686 (rpmforge)
           Requires: libogg-devel
Error: Package: flvtool2-1.0.6-1.el6.rf.noarch (rpmforge)
           Requires: ruby
Error: Package: mencoder-1.0-0.47.svn20100703.el6.rf.i686 (rpmforge)
           Requires: libsmbclient.so.0
Error: Package: mencoder-1.0-0.47.svn20100703.el6.rf.i686 (rpmforge)
           Requires: libogg.so.0
Error: Package: mencoder-1.0-0.47.svn20100703.el6.rf.i686 (rpmforge)
           Requires: libtheora.so.0(libtheora.so.1.0)
Error: Package: mplayer-1.0-0.47.svn20100703.el6.rf.i686 (rpmforge)
           Requires: libogg.so.0
Error: Package: twolame-0.3.13-1.el6.rf.i686 (rpmforge)
           Requires: libsndfile.so.1
Error: Package: mencoder-1.0-0.47.svn20100703.el6.rf.i686 (rpmforge)
           Requires: libcdda_interface.so.0
Error: Package: mplayer-1.0-0.47.svn20100703.el6.rf.i686 (rpmforge)
           Requires: libtheora.so.0(libtheora.so.1.0)
Error: Package: ffmpeg-0.6.5-1.el6.rf.i686 (rpmforge)
           Requires: libspeex.so.1
Error: Package: mplayer-1.0-0.47.svn20100703.el6.rf.i686 (rpmforge)
           Requires: libXxf86dga.so.1
Error: Package: mplayer-1.0-0.47.svn20100703.el6.rf.i686 (rpmforge)
           Requires: liblzo2.so.2
Error: Package: mplayer-1.0-0.47.svn20100703.el6.rf.i686 (rpmforge)
           Requires: libspeex.so.1
Error: Package: ffmpeg-0.6.5-1.el6.rf.i686 (rpmforge)
           Requires: libtheoradec.so.1(libtheoradec_1.0)
Error: Package: mplayer-1.0-0.47.svn20100703.el6.rf.i686 (rpmforge)
           Requires: libdv.so.4
Error: Package: mencoder-1.0-0.47.svn20100703.el6.rf.i686 (rpmforge)
           Requires: libcdda_paranoia.so.0
Error: Package: mencoder-1.0-0.47.svn20100703.el6.rf.i686 (rpmforge)
           Requires: libspeex.so.1
Error: Package: mencoder-1.0-0.47.svn20100703.el6.rf.i686 (rpmforge)
           Requires: libtheora.so.0
Error: Package: aalib-1.4.0-5.el6.rf.i686 (rpmforge)
           Requires: libgpm.so.2
Error: Package: ffmpeg-0.6.5-1.el6.rf.i686 (rpmforge)
           Requires: libdc1394.so.22
Error: Package: mplayer-1.0-0.47.svn20100703.el6.rf.i686 (rpmforge)
           Requires: libtheora.so.0
Error: Package: ffmpeg-0.6.5-1.el6.rf.i686 (rpmforge)
           Requires: libtheoraenc.so.1
Error: Package: mplayer-1.0-0.47.svn20100703.el6.rf.i686 (rpmforge)
           Requires: libXvMCW.so.1
Error: Package: mencoder-1.0-0.47.svn20100703.el6.rf.i686 (rpmforge)
           Requires: libmpcdec.so.5
Error: Package: mplayer-1.0-0.47.svn20100703.el6.rf.i686 (rpmforge)
           Requires: libmng.so.1
Error: Package: mplayer-1.0-0.47.svn20100703.el6.rf.i686 (rpmforge)
           Requires: libpulse.so.0(PULSE_0)
 You could try using --skip-broken to work around the problem

Apox
 
Posts: 5
Joined: 2011/11/02 18:57:36

Re: Cant install mplayer, mcoder, flvtool2

Postby Apox » 2012/02/28 20:53:36

No one that have any answers ? :/
Apox
 
Posts: 5
Joined: 2011/11/02 18:57:36

Re: Cant install mplayer, mcoder, flvtool2

Postby gerald_clark » 2012/02/29 16:34:16

Try a yum clean all.
If that does not solve the problem, file a bug report with repoforge.
gerald_clark
 
Posts: 7166
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Re: Cant install mplayer, mcoder, flvtool2

Postby TrevorH » 2012/02/29 17:12:13

Or ask cpanel since you appear to be using their control panel!
User avatar
TrevorH
Forum Moderator
 
Posts: 9106
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Cant install mplayer, mcoder, flvtool2

Postby gerald_clark » 2012/02/29 17:29:12

That's a better idea.
I missed that, and cpanel pretty much breaks yum for regular use.
gerald_clark
 
Posts: 7166
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA


Return to CentOS 6 - Software Support

Who is online

Users browsing this forum: No registered users and 3 guests