Installing JDK and PHP Java bridge

Issues related to applications and software problems

Installing JDK and PHP Java bridge

Postby milindsaraswala » 2012/04/09 09:29:19

Hi,

I am very new to this forum and also very new to Linux. So kindly bare with me if I am asking silly questions. I have dedicated hosting server with CentOS 6.0 installed on it with apache web sever. Now I need to install JDK and PHP Java bridge on it. Kindly somebody help to install it or give me some step by step method to install on it.
milindsaraswala
 
Posts: 1
Joined: 2012/04/09 09:23:15

Installing JDK and PHP Java bridge

Postby pschaff » 2012/04/09 18:24:14

Welcome to the CentOS fora. Please see the recommended reading for new users linked in my signature.

Please read about Installing Software and Repositories, and note the warnings and advice about installing and configuring the yum priorities plugin.

The references in those articles should show you how to query the yum database for distro packages. For instance
Code: Select all
# yum list java\*
Loaded plugins: changelog, fastestmirror, priorities, refresh-packagekit
Loading mirror speeds from cached hostfile
 * elrepo: mirror.symnds.com
5 packages excluded due to repository priority protections
Installed Packages
java-1.5.0-gcj.x86_64                  1.5.0.0-29.1.el6                 @sl/6.0
java-1.5.0-gcj-devel.x86_64            1.5.0.0-29.1.el6                 @sl/6.0
java-1.6.0-openjdk.x86_64              1:1.6.0.0-1.43.1.10.6.el6_2      @updates
java-1.6.0-openjdk-demo.x86_64         1:1.6.0.0-1.43.1.10.6.el6_2      @updates
java-1.6.0-openjdk-devel.x86_64        1:1.6.0.0-1.43.1.10.6.el6_2      @updates
java-1.6.0-openjdk-javadoc.x86_64      1:1.6.0.0-1.43.1.10.6.el6_2      @updates
java-1.6.0-openjdk-src.x86_64          1:1.6.0.0-1.43.1.10.6.el6_2      @updates
java_cup.x86_64                        1:0.10k-5.el6                    @sl/6.0
Available Packages
java-1.5.0-gcj-javadoc.x86_64          1.5.0.0-29.1.el6                 base   
java-1.5.0-gcj-src.x86_64              1.5.0.0-29.1.el6                 base   
java_cup-javadoc.x86_64                1:0.10k-5.el6                    base   
java_cup-manual.x86_64                 1:0.10k-5.el6                    base   
javacc.x86_64                          4.1-0.5.el6                      base   
javacc-demo.x86_64                     4.1-0.5.el6                      base   
javacc-manual.x86_64                   4.1-0.5.el6                      base   
javassist.noarch                       3.9.0-6.el6                      base   
javassist-javadoc.noarch               3.9.0-6.el6                      base   

So for a start
Code: Select all
yum install java-1.6.0-openjdk

I don't know anything about PHP Java bridge and a yum search for that is not helpful:
Code: Select all
# yum --noplugins --showduplicates --enablerepo \* --disablerepo c6-media,\*debug\*,\*-source search php java bridge
============================ N/S Matched: php, java ============================
php-pear-HTML_Javascript-1.1.1-4.el6.noarch : Class for creating simple JS
                                            : scripts

========================== N/S Matched: java, bridge ===========================
eclipse-mylyn-java-3.4.2-9.el6.x86_64 : Mylyn Bridge:  Java Development
orbited-0.7.10-6.el6.noarch : A browser(javascript)->tcp bridge

=============================== N/S Matched: php ===============================
collectd-php-collection-5.0.1-1.el6.rft.x86_64 : collect php webfrontent
... snip ...


Do note that 6.0 is seriously obsolete. The current release is 6.2. A "yum update" is highly recommended. By not updating you are implicitly accepting that you will live with numerous bugs and security issues (and associated known exploits) that have subsequently been fixed.
pschaff
Retired Moderator
 
Posts: 18277
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America


Return to CentOS 6 - Software Support

Who is online

Users browsing this forum: No registered users and 2 guests