[SOLVED] Graphical corruption on CentOS 7 (Intel graphics)

General support questions
jb2cool
Posts: 8
Joined: 2012/10/05 09:04:22
Location: Bracknell, UK

[SOLVED] Graphical corruption on CentOS 7 (Intel graphics)

Postby jb2cool » 2016/02/04 12:58:43

I'm having graphical corruption issues on a couple of small PCs in the last couple of days, first of all i thought it was just something wrong with the first PC but then i built up a new one and i have the same issue on that. Some graphical objects (wallpaper and toolbars) are fine but some (Desktop icons and terminal text) are all messed up with horizontal lines.

The desktop PC is a Dell Optiplex 780 and we've got a fair few of these all running CentOS 7 fine. We are using an internal software repo and the installs are all scripted to make them identical in case that makes any difference, a build directly off the DVD and updated from external repos seems unaffected.

Any ideas where to even start with this?

IMG.jpg
IMG.jpg (205.06 KiB) Viewed 1291 times
Last edited by jb2cool on 2016/02/04 13:54:03, edited 2 times in total.

User avatar
TrevorH
Forum Moderator
Posts: 17799
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Graphical corruption on CentOS 7 (Intel graphics)

Postby TrevorH » 2016/02/04 13:03:19

If you are using Intel graphics then you might want to try using AccelMethod uxa not the default of sna.
CentOS 5 dies in March 2017 - migrate soon!
Full time Geek, part time moderator. Use the FAQ Luke

jb2cool
Posts: 8
Joined: 2012/10/05 09:04:22
Location: Bracknell, UK

Re: Graphical corruption on CentOS 7 (Intel graphics)

Postby jb2cool » 2016/02/04 13:26:29

TrevorH wrote:If y ou are using Intel graphics then you might want to try using AccelMethod uxa not the default of sna.

Indeed it does help.

I created a file called 20-intel.conf file in /etc/X11/xorg.conf.d with the following contents;

Code: Select all

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "uxa"
EndSection


Sorted me out. Thanks!

For a full history, there are also similar issues encountered here (https://www.centos.org/forums/viewtopic ... 47&t=55557) and here (https://www.centos.org/forums/viewtopic ... 1&p=233339) and they implemented the same fix.

yoshi3899
Posts: 1
Joined: 2016/02/05 09:47:11

Re: [SOLVED] Graphical corruption on CentOS 7 (Intel graphic

Postby yoshi3899 » 2016/02/05 10:26:02

I had the same issue too.

I tried to connected to a monitor(dell) and a TV(sharp), but neither worked.
yum update didn't fix the problem as well.

All Images on CentOS7 gnome desktop were corrupted or interlaced when the mouse goes over or goes away from them.
gnome terminal was garbled and messy, almost unable to read unless I hit Ctrl-L (refresh screen) every time.


The code worked.
my CentOS7 desktop is now back and working!

Thanks jb2cool and TrevorH!

---
HP Compaq dc 7900 (SFF) Business PC Personal Computers
Intel Q45 Express Chipset
Intel Graphics Media Accelerator 4500 (integrated graphics controller)

rmerrf
Posts: 1
Joined: 2016/04/16 15:55:27

Re: [SOLVED] Graphical corruption on CentOS 7 (Intel graphics)

Postby rmerrf » 2016/04/16 16:10:17

Works perfectly! I installed Centos 7 on a Toughbook CF-30 and had this same issue. Thinking it was a desktop environment, I tried both Gnome 3 and Cinnamon and experienced the same problem. Thanks for the solution!.


Return to “CentOS 7 - General Support”

Who is online

Users browsing this forum: svennd and 2 guests