which compat-gcc-34 rpm package?

Issues related to applications and software problems
centux
Posts: 7
Joined: 2016/03/01 20:56:19

which compat-gcc-34 rpm package?

Postby centux » 2016/03/13 21:27:25

Hello,
I have a list of system prerequisites that tells me to install compat-gcc-34.x86_64 , but on my centos 7 machine yum only knows about compat-gcc-44.x86_64 . Since these packages to my understanding provide compatibility for older gcc versions, I assume gcc 4.4 compatibility does not help, if gcc 3.4 compatibility is required ... right?

At http://www.rpmfind.net I found packages compat-gcc-34.x86_64 for centos 6.7, 5.11, and fedora 21,22,23, respectively.

Which is my best bet to try an installion on centos 7 ? Or do I have to look elsewhere?

Many Thanks in advance!

User avatar
TrevorH
Forum Moderator
Posts: 19450
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: which compat-gcc-34 rpm package?

Postby TrevorH » 2016/03/13 21:44:53

Most likely you either need an application that will build with newer gcc versions or you need to use CentOS 6 (still another 5 years of life left) which does have compat-gcc-34.x86_64

You could always try to build whatever it is with the newer gcc and see if it builds. I'd guess that it will explode during compile not during run time.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

centux
Posts: 7
Joined: 2016/03/01 20:56:19

Re: which compat-gcc-34 rpm package?

Postby centux » 2016/03/13 22:17:37

Thanks for your quick reply! Hm, if prospects are that grim, I need to check with the software vendor support how badly this library is needed. It is stated that the software installs on RHEL7, so I thought CentOS 7 is worth a try.

But from your reply I learn that it is not advisable to try to install, say, centos 6.7 packages on a centos 7 machine.

Many Thanks!

User avatar
dmunk
Posts: 37
Joined: 2016/03/16 03:33:49

Re: which compat-gcc-34 rpm package?

Postby dmunk » 2016/03/16 05:25:40

Hello,


Alot of time gcc will work fine even if it is a newer version. However, mind if I ask what your trying to build? I may be able to help.

centux
Posts: 7
Joined: 2016/03/01 20:56:19

Re: which compat-gcc-34 rpm package?

Postby centux » 2016/03/17 16:42:23

Thanks for asking! I want to install from ANSYS 17.0 the software for computational fluid dynamics (FLUENT) including geometry and meshing (Workbench). This is commercial and comes all compiled. Except for some C-code that one may write and compile for FLUENT (so called user defined functions, udf), which I intend to use heavily. I already asked their customer support and am waiting for an answer. What I cannot tell is, if they use some old binaires that need this package .. as I clearly have no idea how and when exactly the package manages to provide compatiblity or where this is required ...

Again, thanks for asking and best regards!

User avatar
dmunk
Posts: 37
Joined: 2016/03/16 03:33:49

Re: which compat-gcc-34 rpm package?

Postby dmunk » 2016/03/20 16:58:04

Hello,

No problem. Seems I am out of my depth though. All I have ever done is built software from source. I have seldom / never had an issue just using gcc from the repo. However, in my case it was a whole application. In your case, it seems you know way more about C than me if you plan on writing and building your own plug-ins. Wish I could have been of more help.

Guess I was basing my offer of help on

1. You using a source tarball
2. Your seeing errors from "./configure" or some such.
3. The whole application being built using the same compiler.

Any way, good luck.


Return to “CentOS 7 - Software Support”

Who is online

Users browsing this forum: Au{R}oN and 0 guests