[SOLVED] Problem with VMware Workstation 12 on Centos 7 with Kernel 4.5.0-1.el7.elrepo.x86_64

Issues related to applications and software problems
firewire2013
Posts: 13
Joined: 2016/03/28 07:43:00
Location: UK
Contact:

[SOLVED] Problem with VMware Workstation 12 on Centos 7 with Kernel 4.5.0-1.el7.elrepo.x86_64

Postby firewire2013 » 2016/04/13 06:58:28

Hello all,

I have a problem with VMware Workstation 12, it would appear there is something not quite right with my kernal headers which is stopping the VMware process from starting.

This is a fresh install of Centos 7, updated with Kernel 4.5.0-1.el7.elrepo.x86_64

Code: Select all

[root@james]# uname -r
4.5.0-1.el7.elrepo.x86_64


When I start VMware, a box pops up
Image

I click install

Image

Then it fails

Image

The output of the log is below:

Code: Select all

2016-04-13T07:50:43.555+01:00| vthread-4| I125: Log for VMware Workstation pid=12665 version=12.0.0 build=build-2985596 option=Release
2016-04-13T07:50:43.555+01:00| vthread-4| I125: The process is 64-bit.
2016-04-13T07:50:43.555+01:00| vthread-4| I125: Host codepage=UTF-8 encoding=UTF-8
2016-04-13T07:50:43.555+01:00| vthread-4| I125: Host is Linux 4.5.0-1.el7.elrepo.x86_64 CentOS Linux release 7.2.1511 (Core)
2016-04-13T07:50:43.554+01:00| vthread-4| I125: DictionaryLoad: Cannot open file "/usr/lib/vmware/settings": No such file or directory.
2016-04-13T07:50:43.554+01:00| vthread-4| I125: PREF Optional preferences file not found at /usr/lib/vmware/settings. Using default values.
2016-04-13T07:50:43.555+01:00| vthread-4| I125: DictionaryLoad: Cannot open file "/home/james/.vmware/config": No such file or directory.
2016-04-13T07:50:43.555+01:00| vthread-4| I125: PREF Optional preferences file not found at /home/james/.vmware/config. Using default values.
2016-04-13T07:50:43.555+01:00| vthread-4| I125: PREF Unable to check permissions for preferences file.
2016-04-13T07:50:43.555+01:00| vthread-4| I125: DictionaryLoad: Cannot open file "/home/james/.vmware/preferences": No such file or directory.
2016-04-13T07:50:43.555+01:00| vthread-4| I125: PREF Failed to load user preferences.
2016-04-13T07:50:43.558+01:00| vthread-4| W115: Logging to /tmp/vmware-root/vmware-12665.log
2016-04-13T07:50:43.563+01:00| vthread-4| I125: Obtaining info using the running kernel.
2016-04-13T07:50:43.563+01:00| vthread-4| I125: Created new pathsHash.
2016-04-13T07:50:43.563+01:00| vthread-4| I125: Setting header path for 4.5.0-1.el7.elrepo.x86_64 to "/lib/modules/4.5.0-1.el7.elrepo.x86_64/build/include".
2016-04-13T07:50:43.563+01:00| vthread-4| I125: Validating path "/lib/modules/4.5.0-1.el7.elrepo.x86_64/build/include" for kernel release "4.5.0-1.el7.elrepo.x86_64".
2016-04-13T07:50:43.563+01:00| vthread-4| I125: using /usr/bin/gcc for preprocess check
2016-04-13T07:50:43.569+01:00| vthread-4| I125: Preprocessed UTS_RELEASE, got value "4.5.0-1.el7.elrepo.x86_64".
2016-04-13T07:50:43.569+01:00| vthread-4| I125: The header path "/lib/modules/4.5.0-1.el7.elrepo.x86_64/build/include" for the kernel "4.5.0-1.el7.elrepo.x86_64" is valid.  Whoohoo!
2016-04-13T07:50:43.738+01:00| vthread-4| I125: found symbol version file /lib/modules/4.5.0-1.el7.elrepo.x86_64/build/Module.symvers
2016-04-13T07:50:43.738+01:00| vthread-4| I125: Reading symbol versions from /lib/modules/4.5.0-1.el7.elrepo.x86_64/build/Module.symvers.
2016-04-13T07:50:43.757+01:00| vthread-4| I125: Read 16630 symbol versions
2016-04-13T07:50:43.757+01:00| vthread-4| I125: Reading in info for the vmmon module.
2016-04-13T07:50:43.757+01:00| vthread-4| I125: Reading in info for the vmnet module.
2016-04-13T07:50:43.757+01:00| vthread-4| I125: Reading in info for the vmblock module.
2016-04-13T07:50:43.757+01:00| vthread-4| I125: Reading in info for the vmci module.
2016-04-13T07:50:43.757+01:00| vthread-4| I125: Reading in info for the vsock module.
2016-04-13T07:50:43.757+01:00| vthread-4| I125: Setting vsock to depend on vmci.
2016-04-13T07:50:43.757+01:00| vthread-4| I125: Invoking modinfo on "vmmon".
2016-04-13T07:50:43.759+01:00| vthread-4| I125: "/sbin/modinfo" exited with status 256.
2016-04-13T07:50:43.759+01:00| vthread-4| I125: Invoking modinfo on "vmnet".
2016-04-13T07:50:43.761+01:00| vthread-4| I125: "/sbin/modinfo" exited with status 0.
2016-04-13T07:50:43.761+01:00| vthread-4| I125: Invoking modinfo on "vmblock".
2016-04-13T07:50:43.762+01:00| vthread-4| I125: "/sbin/modinfo" exited with status 256.
2016-04-13T07:50:43.762+01:00| vthread-4| I125: Invoking modinfo on "vmci".
2016-04-13T07:50:43.764+01:00| vthread-4| I125: "/sbin/modinfo" exited with status 256.
2016-04-13T07:50:43.764+01:00| vthread-4| I125: Invoking modinfo on "vsock".
2016-04-13T07:50:43.766+01:00| vthread-4| I125: "/sbin/modinfo" exited with status 0.
2016-04-13T07:50:43.778+01:00| vthread-4| I125: to be installed: vmmon status: 0
2016-04-13T07:50:43.786+01:00| vthread-4| I125: Obtaining info using the running kernel.
2016-04-13T07:50:43.786+01:00| vthread-4| I125: Setting header path for 4.5.0-1.el7.elrepo.x86_64 to "/lib/modules/4.5.0-1.el7.elrepo.x86_64/build/include".
2016-04-13T07:50:43.786+01:00| vthread-4| I125: Validating path "/lib/modules/4.5.0-1.el7.elrepo.x86_64/build/include" for kernel release "4.5.0-1.el7.elrepo.x86_64".
2016-04-13T07:50:43.786+01:00| vthread-4| I125: using /usr/bin/gcc for preprocess check
2016-04-13T07:50:43.791+01:00| vthread-4| I125: Preprocessed UTS_RELEASE, got value "4.5.0-1.el7.elrepo.x86_64".
2016-04-13T07:50:43.791+01:00| vthread-4| I125: The header path "/lib/modules/4.5.0-1.el7.elrepo.x86_64/build/include" for the kernel "4.5.0-1.el7.elrepo.x86_64" is valid.  Whoohoo!
2016-04-13T07:50:43.964+01:00| vthread-4| I125: found symbol version file /lib/modules/4.5.0-1.el7.elrepo.x86_64/build/Module.symvers
2016-04-13T07:50:43.964+01:00| vthread-4| I125: Reading symbol versions from /lib/modules/4.5.0-1.el7.elrepo.x86_64/build/Module.symvers.
2016-04-13T07:50:43.984+01:00| vthread-4| I125: Read 16630 symbol versions
2016-04-13T07:50:43.984+01:00| vthread-4| I125: Kernel header path retrieved from FileEntry: /lib/modules/4.5.0-1.el7.elrepo.x86_64/build/include
2016-04-13T07:50:43.984+01:00| vthread-4| I125: Update kernel header path to /lib/modules/4.5.0-1.el7.elrepo.x86_64/build/include
2016-04-13T07:50:43.984+01:00| vthread-4| I125: Validating path "/lib/modules/4.5.0-1.el7.elrepo.x86_64/build/include" for kernel release "4.5.0-1.el7.elrepo.x86_64".
2016-04-13T07:50:43.984+01:00| vthread-4| I125: using /usr/bin/gcc for preprocess check
2016-04-13T07:50:43.991+01:00| vthread-4| I125: Preprocessed UTS_RELEASE, got value "4.5.0-1.el7.elrepo.x86_64".
2016-04-13T07:50:43.991+01:00| vthread-4| I125: The header path "/lib/modules/4.5.0-1.el7.elrepo.x86_64/build/include" for the kernel "4.5.0-1.el7.elrepo.x86_64" is valid.  Whoohoo!
2016-04-13T07:50:43.992+01:00| vthread-4| I125: Found compiler at "/usr/bin/gcc"
2016-04-13T07:50:43.996+01:00| vthread-4| I125: Got gcc version "4.8.5".
2016-04-13T07:50:43.996+01:00| vthread-4| I125: The GCC version matches the kernel GCC minor version like a glove.
2016-04-13T07:50:43.996+01:00| vthread-4| I125: Using user supplied compiler "/usr/bin/gcc".
2016-04-13T07:50:43.999+01:00| vthread-4| I125: Got gcc version "4.8.5".
2016-04-13T07:50:43.999+01:00| vthread-4| I125: The GCC version matches the kernel GCC minor version like a glove.
2016-04-13T07:50:44.000+01:00| vthread-4| I125: Trying to find a suitable PBM set for kernel "4.5.0-1.el7.elrepo.x86_64".
2016-04-13T07:50:44.001+01:00| vthread-4| I125: No matching PBM set was found for kernel "4.5.0-1.el7.elrepo.x86_64".
2016-04-13T07:50:44.001+01:00| vthread-4| I125: The GCC version matches the kernel GCC minor version like a glove.
2016-04-13T07:50:44.001+01:00| vthread-4| I125: Validating path "/lib/modules/4.5.0-1.el7.elrepo.x86_64/build/include" for kernel release "4.5.0-1.el7.elrepo.x86_64".
2016-04-13T07:50:44.001+01:00| vthread-4| I125: using /usr/bin/gcc for preprocess check
2016-04-13T07:50:44.007+01:00| vthread-4| I125: Preprocessed UTS_RELEASE, got value "4.5.0-1.el7.elrepo.x86_64".
2016-04-13T07:50:44.007+01:00| vthread-4| I125: The header path "/lib/modules/4.5.0-1.el7.elrepo.x86_64/build/include" for the kernel "4.5.0-1.el7.elrepo.x86_64" is valid.  Whoohoo!
2016-04-13T07:50:44.024+01:00| vthread-4| I125: The GCC version matches the kernel GCC minor version like a glove.
2016-04-13T07:50:44.024+01:00| vthread-4| I125: Validating path "/lib/modules/4.5.0-1.el7.elrepo.x86_64/build/include" for kernel release "4.5.0-1.el7.elrepo.x86_64".
2016-04-13T07:50:44.024+01:00| vthread-4| I125: using /usr/bin/gcc for preprocess check
2016-04-13T07:50:44.032+01:00| vthread-4| I125: Preprocessed UTS_RELEASE, got value "4.5.0-1.el7.elrepo.x86_64".
2016-04-13T07:50:44.032+01:00| vthread-4| I125: The header path "/lib/modules/4.5.0-1.el7.elrepo.x86_64/build/include" for the kernel "4.5.0-1.el7.elrepo.x86_64" is valid.  Whoohoo!
2016-04-13T07:50:44.032+01:00| vthread-4| I125: Using temp dir "/tmp".
2016-04-13T07:50:44.033+01:00| vthread-4| I125: Obtaining info using the running kernel.
2016-04-13T07:50:44.033+01:00| vthread-4| I125: Setting header path for 4.5.0-1.el7.elrepo.x86_64 to "/lib/modules/4.5.0-1.el7.elrepo.x86_64/build/include".
2016-04-13T07:50:44.033+01:00| vthread-4| I125: Validating path "/lib/modules/4.5.0-1.el7.elrepo.x86_64/build/include" for kernel release "4.5.0-1.el7.elrepo.x86_64".
2016-04-13T07:50:44.033+01:00| vthread-4| I125: using /usr/bin/gcc for preprocess check
2016-04-13T07:50:44.041+01:00| vthread-4| I125: Preprocessed UTS_RELEASE, got value "4.5.0-1.el7.elrepo.x86_64".
2016-04-13T07:50:44.041+01:00| vthread-4| I125: The header path "/lib/modules/4.5.0-1.el7.elrepo.x86_64/build/include" for the kernel "4.5.0-1.el7.elrepo.x86_64" is valid.  Whoohoo!
2016-04-13T07:50:44.215+01:00| vthread-4| I125: found symbol version file /lib/modules/4.5.0-1.el7.elrepo.x86_64/build/Module.symvers
2016-04-13T07:50:44.215+01:00| vthread-4| I125: Reading symbol versions from /lib/modules/4.5.0-1.el7.elrepo.x86_64/build/Module.symvers.
2016-04-13T07:50:44.238+01:00| vthread-4| I125: Read 16630 symbol versions
2016-04-13T07:50:44.238+01:00| vthread-4| I125: Invoking modinfo on "vmmon".
2016-04-13T07:50:44.241+01:00| vthread-4| I125: "/sbin/modinfo" exited with status 256.
2016-04-13T07:50:44.304+01:00| vthread-4| I125: Setting destination path for vmmon to "/lib/modules/4.5.0-1.el7.elrepo.x86_64/misc/vmmon.ko".
2016-04-13T07:50:44.304+01:00| vthread-4| I125: Extracting the vmmon source from "/usr/lib/vmware/modules/source/vmmon.tar".
2016-04-13T07:50:44.318+01:00| vthread-4| I125: Successfully extracted the vmmon source.
2016-04-13T07:50:44.318+01:00| vthread-4| I125: Building module with command "/usr/bin/make -j4 -C /tmp/modconfig-f3aXLl/vmmon-only auto-build HEADER_DIR=/lib/modules/4.5.0-1.el7.elrepo.x86_64/build/include CC=/usr/bin/gcc IS_GCC_3=no"
2016-04-13T07:50:45.855+01:00| vthread-4| W115: Failed to build vmmon.  Failed to execute the build command.




Also this is the output from the Terminal

Code: Select all

[root@james]# vmware
Stopping vmware (via systemctl):                           [  OK  ]
Using kernel build system.
make: Entering directory `/tmp/modconfig-WvsfOC/vmmon-only'
/usr/bin/make -C /lib/modules/4.5.0-1.el7.elrepo.x86_64/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. \
  MODULEBUILDDIR= modules
make[1]: Entering directory `/usr/src/kernels/4.5.0-1.el7.elrepo.x86_64'
  CC [M]  /tmp/modconfig-WvsfOC/vmmon-only/linux/driver.o
  CC [M]  /tmp/modconfig-WvsfOC/vmmon-only/linux/hostif.o
  CC [M]  /tmp/modconfig-WvsfOC/vmmon-only/linux/driverLog.o
  CC [M]  /tmp/modconfig-WvsfOC/vmmon-only/common/memtrack.o
  CC [M]  /tmp/modconfig-WvsfOC/vmmon-only/common/apic.o
  CC [M]  /tmp/modconfig-WvsfOC/vmmon-only/common/hashFunc.o
  CC [M]  /tmp/modconfig-WvsfOC/vmmon-only/common/vmx86.o
  CC [M]  /tmp/modconfig-WvsfOC/vmmon-only/common/cpuid.o
/tmp/modconfig-WvsfOC/vmmon-only/linux/driver.c: In function ‘cleanup_module’:
/tmp/modconfig-WvsfOC/vmmon-only/linux/driver.c:390:8: error: void value not ignored as it ought to be
    if (misc_deregister(&linuxState.misc)) {
        ^
/tmp/modconfig-WvsfOC/vmmon-only/linux/driver.c: At top level:
/tmp/modconfig-WvsfOC/vmmon-only/linux/driver.c:1285:1: warning: always_inline function might not be inlinable [-Wattributes]
 LinuxDriverSyncReadTSCs(uint64 *delta) // OUT: TSC max - TSC min
 ^
make[2]: *** [/tmp/modconfig-WvsfOC/vmmon-only/linux/driver.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[1]: *** [_module_/tmp/modconfig-WvsfOC/vmmon-only] Error 2
make[1]: Leaving directory `/usr/src/kernels/4.5.0-1.el7.elrepo.x86_64'
make: *** [vmmon.ko] Error 2
make: Leaving directory `/tmp/modconfig-WvsfOC/vmmon-only'
Starting vmware (via systemctl):  Job for vmware.service failed because the control process exited with error code. See "systemctl status vmware.service" and "journalctl -xe" for details.
                                                           [FAILED]


Any ideas?

Thanks for your help!
Last edited by firewire2013 on 2016/04/13 18:24:55, edited 1 time in total.

User avatar
toracat
Forum Moderator
Posts: 7164
Joined: 2006/09/03 16:37:24
Location: California, US
Contact:

Re: Problem with VMware Workstation 12 on Centos 7 with Kernel 4.5.0-1.el7.elrepo.x86_64

Postby toracat » 2016/04/13 16:18:34

Can you show us the output from:

rpm -qa kernel\* | sort
uname -mr
CentOS Forum FAQ

firewire2013
Posts: 13
Joined: 2016/03/28 07:43:00
Location: UK
Contact:

Re: Problem with VMware Workstation 12 on Centos 7 with Kernel 4.5.0-1.el7.elrepo.x86_64

Postby firewire2013 » 2016/04/13 17:06:57

Code: Select all

[root@james]# rpm -qa kernel\* | sort
kernel-3.10.0-327.13.1.el7.x86_64
kernel-3.10.0-327.el7.x86_64
kernel-devel-3.10.0-327.13.1.el7.x86_64
kernel-devel-3.10.0-327.el7.x86_64
kernel-headers-3.10.0-327.13.1.el7.x86_64
kernel-ml-4.5.0-1.el7.elrepo.x86_64
kernel-ml-devel-4.5.0-1.el7.elrepo.x86_64
kernel-ml-doc-4.5.0-1.el7.elrepo.noarch
kernel-tools-3.10.0-327.13.1.el7.x86_64
kernel-tools-libs-3.10.0-327.13.1.el7.x86_64
kernel-tools-libs-devel-3.10.0-327.13.1.el7.x86_64

Code: Select all

[root@james]# uname -mr
4.5.0-1.el7.elrepo.x86_64 x86_64
[root@james]#


Thanks

User avatar
toracat
Forum Moderator
Posts: 7164
Joined: 2006/09/03 16:37:24
Location: California, US
Contact:

Re: Problem with VMware Workstation 12 on Centos 7 with Kernel 4.5.0-1.el7.elrepo.x86_64

Postby toracat » 2016/04/13 17:41:46

Thanks. Just wanted to double-check it was not an issue with mismatching -devel.

Looks like this is a known problem? I see this page:

https://www.reddit.com/r/linuxquestions ... _problems/
CentOS Forum FAQ

firewire2013
Posts: 13
Joined: 2016/03/28 07:43:00
Location: UK
Contact:

Re: Problem with VMware Workstation 12 on Centos 7 with Kernel 4.5.0-1.el7.elrepo.x86_64

Postby firewire2013 » 2016/04/13 18:24:23

Very cool!

That worked like charm, thankyou

User avatar
toracat
Forum Moderator
Posts: 7164
Joined: 2006/09/03 16:37:24
Location: California, US
Contact:

Re: [SOLVED] Problem with VMware Workstation 12 on Centos 7 with Kernel 4.5.0-1.el7.elrepo.x86_64

Postby toracat » 2016/04/13 18:43:28

That's so nice to know. Thanks for reporting back.
CentOS Forum FAQ


Return to “CentOS 7 - Software Support”

Who is online

Users browsing this forum: No registered users and 3 guests