Errno 14] HTTP Error 404 - Not Found Trying other mirror.

General support questions
Post Reply
alix
Posts: 13
Joined: 2016/01/25 21:13:17

Errno 14] HTTP Error 404 - Not Found Trying other mirror.

Post by alix » 2016/06/24 12:11:41

I am having problems with installing packages with YUM , every time when i run command yum install i get this error:
yum install alacarte
Loaded plugins: fastestmirror, langpacks
adobe-linux-x86_64 | 951 B 00:00:00
base | 3.6 kB 00:00:00
epel/x86_64/metalink | 21 kB 00:00:00
extras | 3.4 kB 00:00:00
google-chrome | 951 B 00:00:00
google-chrome-unstable | 951 B 00:00:00
mariadb | 2.9 kB 00:00:00
http://repo.mysql.com/yum/mysql-connect ... repomd.xml: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
To address this issue please refer to the below knowledge base article

https://access.redhat.com/articles/1320623

If above article doesn't help to resolve this issue please create a bug on https://bugs.centos.org/



One of the configured repositories failed (MySQL Connectors Community),
and yum doesn't have enough cached data to continue. At this point the only
safe thing yum can do is fail. There are a few ways to work "fix" this:

1. Contact the upstream for the repository and get them to fix the problem.

2. Reconfigure the baseurl/etc. for the repository, to point to a working
upstream. This is most often useful if you are using a newer
distribution release than is supported by the repository (and the
packages for the previous distribution release still work).

3. Disable the repository, so yum won't use it by default. Yum will then
just ignore the repository until you permanently enable it again or use
--enablerepo for temporary usage:

yum-config-manager --disable mysql-connectors-community

4. Configure the failing repository to be skipped, if it is unavailable.
Note that yum will try to contact the repo. when it runs most commands,
so will have to try and fail each time (and thus. yum will be be much
slower). If it is a very temporary problem though, this is often a nice
compromise:

yum-config-manager --save --setopt=mysql-connectors-community.skip_if_unavailable=true

failure: repodata/repomd.xml from mysql-connectors-community: [Errno 256] No more mirrors to try.
http://repo.mysql.com/yum/mysql-connect ... repomd.xml: [Errno 14] HTTP Error 404 - Not Found
I recently update all packages!

User avatar
TrevorH
Forum Moderator
Posts: 23204
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Errno 14] HTTP Error 404 - Not Found Trying other mirror.

Post by TrevorH » 2016/06/24 12:28:04

You need to report this to the mysql guys as it's their repo giving the errors. You could temporarily add --disablerepo=whatevertherepoiscalled to your yum command or edit the .repo file in /etc/yum.repos.d and set enabled=0 in there.

Also I notice that you have the mariadb repo installed and it's probably not a great idea to use both that and mysql.

You do know that the CentOS repos already contain mariadb (mysql by another name) andteh various connectors?
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

alix
Posts: 13
Joined: 2016/01/25 21:13:17

Re: Errno 14] HTTP Error 404 - Not Found Trying other mirror.

Post by alix » 2016/06/24 21:44:08

Hi Trevor,

Thank you for the reply, editing the repo file of mysql by setting enabled=0 helpt.

This is offcourse offtopic but i am using mariaDB. De reason is why i have mysql repo its becouse i needed a MySQL workbench. And the only way to install mysql-workbench is via mysql repos.

Post Reply