[RESOLVED] yum cannot update glibc after interrupted

Issues related to applications and software problems

[RESOLVED] yum cannot update glibc after interrupted

Postby hacrot3000 » 2012/08/29 10:37:52

The error step is:

1. I ran yum update to update some package, they are:

Code: Select all
glibc.i686                                                      2.12-1.80.el6_3.5                                             updates
glibc.x86_64                                                    2.12-1.80.el6_3.5                                             updates
glibc-devel.x86_64                                              2.12-1.80.el6_3.5                                             updates
glibc-headers.x86_64                                            2.12-1.80.el6_3.5                                             updates

and some other package (I don't remember the remaining).

2. When the installer was running, our disk is out of space, the free became 0 byte, it make the installer failed and stoped.

3. I clean up my hardisk, now it have more than 1.6Gb for free

4. I ran yum-complete-transaction, it ask me to remove glibc, and also many many other depend package, including core package. And finaly, it failed because it canot remove these packages.

6. I ran yum-complete-transaction --cleanup-only

7. I ran yum clean all

8. I tried to run yum update again but it cause this error:

Loaded plugins: fastestmirror, refresh-packagekit, security
Loading mirror speeds from cached hostfile
* base: mirrors.btte.net
* epel: kartolo.sby.datautama.net.id
* extras: mirrors.sin3.sg.voxel.net
* rpmforge: be.mirror.eurid.eu
* updates: mirror.neu.edu.cn
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package glibc.i686 0:2.12-1.80.el6_3.4 will be updated
--> Processing Dependency: glibc = 2.12-1.80.el6_3.4 for package: glibc-common-2.12-1.80.el6_3.4.x86_64
---> Package glibc.x86_64 0:2.12-1.80.el6_3.4 will be updated
--> Processing Dependency: glibc = 2.12-1.80.el6_3.4 for package: glibc-common-2.12-1.80.el6_3.4.x86_64
---> Package glibc.i686 0:2.12-1.80.el6_3.5 will be an update
---> Package glibc.x86_64 0:2.12-1.80.el6_3.5 will be an update
---> Package glibc-devel.x86_64 0:2.12-1.80.el6_3.4 will be updated
---> Package glibc-devel.x86_64 0:2.12-1.80.el6_3.5 will be an update
---> Package glibc-headers.x86_64 0:2.12-1.80.el6_3.4 will be updated
---> Package glibc-headers.x86_64 0:2.12-1.80.el6_3.5 will be an update
--> Finished Dependency Resolution
Error: Package: glibc-common-2.12-1.80.el6_3.4.x86_64 (@updates)
Requires: glibc = 2.12-1.80.el6_3.4
Removing: glibc-2.12-1.80.el6_3.4.i686 (@updates)
glibc = 2.12-1.80.el6_3.4
Updated By: glibc-2.12-1.80.el6_3.5.i686 (updates)
glibc = 2.12-1.80.el6_3.5
Available: glibc-2.12-1.80.el6.i686 (base)
glibc = 2.12-1.80.el6
Available: glibc-2.12-1.80.el6_3.3.i686 (updates)
glibc = 2.12-1.80.el6_3.3
You could try using --skip-broken to work around the problem
** Found 10 pre-existing rpmdb problem(s), 'yum check' output follows:
glibc-common-2.12-1.80.el6_3.5.x86_64 is a duplicate with glibc-common-2.12-1.80.el6_3.4.x86_64
glibc-common-2.12-1.80.el6_3.5.x86_64 has missing requires of glibc = ('0', '2.12', '1.80.el6_3.5')
sed-4.2.1-10.el6.x86_64 is a duplicate with sed-4.2.1-7.el6.x86_64
selinux-policy-3.7.19-155.el6_3.noarch is a duplicate with selinux-policy-3.7.19-126.el6_2.10.noarch
selinux-policy-targeted-3.7.19-155.el6_3.noarch is a duplicate with selinux-policy-targeted-3.7.19-126.el6_2.10.noarch
spice-xpi-2.7-20.el6.x86_64 is a duplicate with spice-xpi-2.4-4.el6.x86_64
system-config-printer-libs-1.1.16-23.el6.x86_64 is a duplicate with system-config-printer-libs-1.1.16-22.el6.x86_64
tzdata-java-2012c-3.el6.noarch is a duplicate with tzdata-java-2012c-1.el6.noarch
2:vim-common-7.2.411-1.8.el6.x86_64 is a duplicate with 2:vim-common-7.2.411-1.6.el6.x86_64
xmlrpc-c-1.16.24-1209.1840.el6.x86_64 is a duplicate with xmlrpc-c-1.16.24-1200.1840.el6_1.4.x86_64


I ran yum update --skip-broken, the result is:

Loaded plugins: fastestmirror, refresh-packagekit, security
Loading mirror speeds from cached hostfile
* base: mirrors.btte.net
* epel: kartolo.sby.datautama.net.id
* extras: mirrors.sin3.sg.voxel.net
* rpmforge: be.mirror.eurid.eu
* updates: mirror.neu.edu.cn
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package glibc.i686 0:2.12-1.80.el6_3.4 will be updated
--> Processing Dependency: glibc = 2.12-1.80.el6_3.4 for package: glibc-common-2.12-1.80.el6_3.4.x86_64
---> Package glibc.x86_64 0:2.12-1.80.el6_3.4 will be updated
--> Processing Dependency: glibc = 2.12-1.80.el6_3.4 for package: glibc-common-2.12-1.80.el6_3.4.x86_64
---> Package glibc.i686 0:2.12-1.80.el6_3.5 will be an update
---> Package glibc.x86_64 0:2.12-1.80.el6_3.5 will be an update
---> Package glibc-devel.x86_64 0:2.12-1.80.el6_3.4 will be updated
---> Package glibc-devel.x86_64 0:2.12-1.80.el6_3.5 will be an update
---> Package glibc-headers.x86_64 0:2.12-1.80.el6_3.4 will be updated
---> Package glibc-headers.x86_64 0:2.12-1.80.el6_3.5 will be an update
--> Finished Dependency Resolution
--> Running transaction check
---> Package glibc-devel.x86_64 0:2.12-1.80.el6_3.4 will be updated
---> Package glibc-headers.x86_64 0:2.12-1.80.el6_3.4 will be updated
--> Finished Dependency Resolution

Packages skipped because of dependency problems:
glibc-2.12-1.80.el6_3.5.i686 from updates
glibc-2.12-1.80.el6_3.5.x86_64 from updates
glibc-devel-2.12-1.80.el6_3.5.x86_64 from updates
glibc-headers-2.12-1.80.el6_3.5.x86_64 from updates



I tried to search on the internet and this forum (clean up cache, disable respose, disable plugins, try to reinstall package, download and install by manual ...), and done alot of solution but still cannot fix this error :-?

Please help me to fix it.

Many thank in advance
hacrot3000
 
Posts: 3
Joined: 2012/05/03 15:58:11

Re: yum cannot update glibc after interrupted

Postby hacrot3000 » 2012/08/29 11:16:19

I found i by myself :-)

When ran "rpm -qa | grep glibc" I got glibc-common twice:
glibc-common-2.12-1.80.el6_3.5.x86_64
glibc-common-2.12-1.80.el6_3.4.x86_64

I removed the 3.5 version:

rpm -e glibc-common-2.12-1.80.el6_3.5.x86_64

Afte that, the "yum update" ran successfully
hacrot3000
 
Posts: 3
Joined: 2012/05/03 15:58:11

[RESOLVED] yum cannot update glibc after interrupted

Postby AlanBartlett » 2012/08/29 12:55:25

Thank you for reporting back with the solution that you used.

On your behalf, and for posterity, this thread is now marked [RESOLVED].
User avatar
AlanBartlett
Forum Moderator
 
Posts: 9172
Joined: 2007/10/22 11:30:09
Location: ~/Earth/UK/England/Suffolk

Re: [RESOLVED] yum cannot update glibc after interrupted

Postby sjlx1 » 2013/03/10 20:55:47

I had pretty much similar issue.
Fresh CentOS 6.3 installation. I have centosplus, contrib and epel-repo enabled.
After install I updated it to date. No issues.
But when I tried to install GCC, I got following error:

[root@xnas lib]# yum install gcc
Loaded plugins: fastestmirror, presto
Loading mirror speeds from cached hostfile
epel/metalink | 18 kB 00:00
* base: ftp.availo.se
* centosplus: ftp.availo.se
* contrib: ftp.availo.se
* epel: ftp.df.lth.se
* extras: ftp.availo.se
* updates: ftp.availo.se
base | 3.7 kB 00:00
centosplus | 3.5 kB 00:00
contrib | 2.9 kB 00:00
extras | 3.5 kB 00:00
updates | 3.5 kB 00:00
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package gcc.x86_64 0:4.4.6-4.el6 will be installed
--> Processing Dependency: libgomp = 4.4.6-4.el6 for package: gcc-4.4.6-4.el6.x86_64
--> Processing Dependency: cpp = 4.4.6-4.el6 for package: gcc-4.4.6-4.el6.x86_64
--> Processing Dependency: glibc-devel >= 2.2.90-12 for package: gcc-4.4.6-4.el6.x86_64
--> Processing Dependency: cloog-ppl >= 0.15 for package: gcc-4.4.6-4.el6.x86_64
--> Processing Dependency: libgomp.so.1()(64bit) for package: gcc-4.4.6-4.el6.x86_64
--> Running transaction check
---> Package cloog-ppl.x86_64 0:0.15.7-1.2.el6 will be installed
--> Processing Dependency: libppl_c.so.2()(64bit) for package: cloog-ppl-0.15.7-1.2.el6.x86_64
--> Processing Dependency: libppl.so.7()(64bit) for package: cloog-ppl-0.15.7-1.2.el6.x86_64
---> Package cpp.x86_64 0:4.4.6-4.el6 will be installed
--> Processing Dependency: libmpfr.so.1()(64bit) for package: cpp-4.4.6-4.el6.x86_64
---> Package glibc-devel.x86_64 0:2.12-1.80.el6 will be installed
--> Processing Dependency: glibc-headers = 2.12-1.80.el6 for package: glibc-devel-2.12-1.80.el6.x86_64
--> Processing Dependency: glibc = 2.12-1.80.el6 for package: glibc-devel-2.12-1.80.el6.x86_64
--> Processing Dependency: glibc-headers for package: glibc-devel-2.12-1.80.el6.x86_64
---> Package libgomp.x86_64 0:4.4.6-4.el6 will be installed
--> Running transaction check
---> Package glibc.i686 0:2.12-1.80.el6 will be installed
--> Processing Dependency: glibc-common = 2.12-1.80.el6 for package: glibc-2.12-1.80.el6.i686
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.12-1.80.el6.i686
--> Processing Dependency: libfreebl3.so for package: glibc-2.12-1.80.el6.i686
---> Package glibc-headers.x86_64 0:2.12-1.80.el6 will be installed
--> Processing Dependency: kernel-headers >= 2.2.1 for package: glibc-headers-2.12-1.80.el6.x86_64
--> Processing Dependency: kernel-headers for package: glibc-headers-2.12-1.80.el6.x86_64
---> Package mpfr.x86_64 0:2.4.1-6.el6 will be installed
---> Package ppl.x86_64 0:0.10.2-11.el6 will be installed
--> Running transaction check
---> Package glibc.i686 0:2.12-1.80.el6 will be installed
--> Processing Dependency: glibc-common = 2.12-1.80.el6 for package: glibc-2.12-1.80.el6.i686
---> Package kernel-headers.x86_64 0:2.6.32-358.0.1.el6.centos.plus will be installed
---> Package nss-softokn-freebl.i686 0:3.12.9-11.el6 will be installed
--> Finished Dependency Resolution
Error: Package: glibc-2.12-1.80.el6.i686 (base)
Requires: glibc-common = 2.12-1.80.el6
Installed: glibc-common-2.12-1.80.el6_3.7.x86_64 (@updates)
glibc-common = 2.12-1.80.el6_3.7
Available: glibc-common-2.12-1.80.el6.x86_64 (base)
glibc-common = 2.12-1.80.el6
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest


I haven't installed any i686 packages, so that glibc.i686 was odd.
Only installed version was glibc-2.12-1.80.el6_3.7.x86_64, so I had nothing to remove either.
After trying several workarounds, I just remembered why I like this distro so much.
Downgrading options are very good and they do usually work also.
So, I was previously updated the system. Now I was just willing to downgrade it a bit - libc only.

[root@xnas lib]# yum downgrade glibc-2.12-1.80.el6.x86_64 glibc-common-2.12-1.80.el6.x86_64
Loaded plugins: fastestmirror, presto
Setting up Downgrade Process
Loading mirror speeds from cached hostfile
* base: ftp.availo.se
* centosplus: ftp.availo.se
* contrib: ftp.availo.se
* epel: www.nic.funet.fi
* extras: ftp.availo.se
* updates: ftp.availo.se
Resolving Dependencies
--> Running transaction check
---> Package glibc.x86_64 0:2.12-1.80.el6 will be a downgrade
---> Package glibc.x86_64 0:2.12-1.80.el6_3.7 will be erased
---> Package glibc-common.x86_64 0:2.12-1.80.el6 will be a downgrade
---> Package glibc-common.x86_64 0:2.12-1.80.el6_3.7 will be erased
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================================================================================================================================
Package Arch Version Repository Size
================================================================================================================================================================================================
Downgrading:
glibc x86_64 2.12-1.80.el6 base 3.8 M
glibc-common x86_64 2.12-1.80.el6 base 14 M

Transaction Summary
================================================================================================================================================================================================
Downgrade 2 Package(s)

Total download size: 18 M
Is this ok [y/N]: y
Downloading Packages:
Setting up and reading Presto delta metadata
Processing delta metadata
Package(s) data still to download: 18 M
(1/2): glibc-2.12-1.80.el6.x86_64.rpm | 3.8 MB 00:08
(2/2): glibc-common-2.12-1.80.el6.x86_64.rpm | 14 MB 00:23
------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total 565 kB/s | 18 MB 00:32
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Installing : glibc-common-2.12-1.80.el6.x86_64 1/4
Installing : glibc-2.12-1.80.el6.x86_64 2/4
Cleanup : glibc-2.12-1.80.el6_3.7.x86_64 3/4
Cleanup : glibc-common-2.12-1.80.el6_3.7.x86_64 4/4
Verifying : glibc-2.12-1.80.el6.x86_64 1/4
Verifying : glibc-common-2.12-1.80.el6.x86_64 2/4
Verifying : glibc-common-2.12-1.80.el6_3.7.x86_64 3/4
Verifying : glibc-2.12-1.80.el6_3.7.x86_64 4/4

Removed:
glibc.x86_64 0:2.12-1.80.el6_3.7 glibc-common.x86_64 0:2.12-1.80.el6_3.7

Installed:
glibc.x86_64 0:2.12-1.80.el6 glibc-common.x86_64 0:2.12-1.80.el6

Complete!


So I downgraded to the version listed in gcc dependencies, then retry:

[root@xnas lib]# yum install gcc
Loaded plugins: fastestmirror, presto
Loading mirror speeds from cached hostfile
* base: ftp.availo.se
* centosplus: ftp.availo.se
* contrib: ftp.availo.se
* epel: ftp.df.lth.se
* extras: ftp.availo.se
* updates: ftp.availo.se
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package gcc.x86_64 0:4.4.6-4.el6 will be installed
--> Processing Dependency: libgomp = 4.4.6-4.el6 for package: gcc-4.4.6-4.el6.x86_64
--> Processing Dependency: cpp = 4.4.6-4.el6 for package: gcc-4.4.6-4.el6.x86_64
--> Processing Dependency: glibc-devel >= 2.2.90-12 for package: gcc-4.4.6-4.el6.x86_64
--> Processing Dependency: cloog-ppl >= 0.15 for package: gcc-4.4.6-4.el6.x86_64
--> Processing Dependency: libgomp.so.1()(64bit) for package: gcc-4.4.6-4.el6.x86_64
--> Running transaction check
---> Package cloog-ppl.x86_64 0:0.15.7-1.2.el6 will be installed
--> Processing Dependency: libppl_c.so.2()(64bit) for package: cloog-ppl-0.15.7-1.2.el6.x86_64
--> Processing Dependency: libppl.so.7()(64bit) for package: cloog-ppl-0.15.7-1.2.el6.x86_64
---> Package cpp.x86_64 0:4.4.6-4.el6 will be installed
--> Processing Dependency: libmpfr.so.1()(64bit) for package: cpp-4.4.6-4.el6.x86_64
---> Package glibc-devel.x86_64 0:2.12-1.80.el6 will be installed
--> Processing Dependency: glibc-headers = 2.12-1.80.el6 for package: glibc-devel-2.12-1.80.el6.x86_64
--> Processing Dependency: glibc-headers for package: glibc-devel-2.12-1.80.el6.x86_64
---> Package libgomp.x86_64 0:4.4.6-4.el6 will be installed
--> Running transaction check
---> Package glibc-headers.x86_64 0:2.12-1.80.el6 will be installed
--> Processing Dependency: kernel-headers >= 2.2.1 for package: glibc-headers-2.12-1.80.el6.x86_64
--> Processing Dependency: kernel-headers for package: glibc-headers-2.12-1.80.el6.x86_64
---> Package mpfr.x86_64 0:2.4.1-6.el6 will be installed
---> Package ppl.x86_64 0:0.10.2-11.el6 will be installed
--> Running transaction check
---> Package kernel-headers.x86_64 0:2.6.32-358.0.1.el6.centos.plus will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================================================================================================================================
Package Arch Version Repository Size
================================================================================================================================================================================================
Installing:
gcc x86_64 4.4.6-4.el6 base 10 M
Installing for dependencies:
cloog-ppl x86_64 0.15.7-1.2.el6 base 93 k
cpp x86_64 4.4.6-4.el6 base 3.7 M
glibc-devel x86_64 2.12-1.80.el6 base 970 k
glibc-headers x86_64 2.12-1.80.el6 base 600 k
kernel-headers x86_64 2.6.32-358.0.1.el6.centos.plus centosplus 2.3 M
libgomp x86_64 4.4.6-4.el6 base 117 k
mpfr x86_64 2.4.1-6.el6 base 157 k
ppl x86_64 0.10.2-11.el6 base 1.3 M

Transaction Summary
================================================================================================================================================================================================
Install 9 Package(s)

Total download size: 19 M
Installed size: 39 M
Is this ok [y/N]: y
Downloading Packages:
Setting up and reading Presto delta metadata
Processing delta metadata
Package(s) data still to download: 19 M
(1/9): cloog-ppl-0.15.7-1.2.el6.x86_64.rpm | 93 kB 00:00
(2/9): cpp-4.4.6-4.el6.x86_64.rpm | 3.7 MB 00:04
(3/9): gcc-4.4.6-4.el6.x86_64.rpm | 10 MB 00:21
(4/9): glibc-devel-2.12-1.80.el6.x86_64.rpm | 970 kB 00:00
(5/9): glibc-headers-2.12-1.80.el6.x86_64.rpm | 600 kB 00:00
(6/9): kernel-headers-2.6.32-358.0.1.el6.centos.plus.x86_64.rpm | 2.3 MB 00:03
(7/9): libgomp-4.4.6-4.el6.x86_64.rpm | 117 kB 00:00
(8/9): mpfr-2.4.1-6.el6.x86_64.rpm | 157 kB 00:00
(9/9): ppl-0.10.2-11.el6.x86_64.rpm | 1.3 MB 00:01
------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total 573 kB/s | 19 MB 00:34
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Installing : ppl-0.10.2-11.el6.x86_64 1/9
Installing : cloog-ppl-0.15.7-1.2.el6.x86_64 2/9
Installing : libgomp-4.4.6-4.el6.x86_64 3/9
Installing : mpfr-2.4.1-6.el6.x86_64 4/9
Installing : cpp-4.4.6-4.el6.x86_64 5/9
Installing : kernel-headers-2.6.32-358.0.1.el6.centos.plus.x86_64 6/9
Installing : glibc-headers-2.12-1.80.el6.x86_64 7/9
Installing : glibc-devel-2.12-1.80.el6.x86_64 8/9
Installing : gcc-4.4.6-4.el6.x86_64 9/9
Verifying : glibc-devel-2.12-1.80.el6.x86_64 1/9
Verifying : kernel-headers-2.6.32-358.0.1.el6.centos.plus.x86_64 2/9
Verifying : gcc-4.4.6-4.el6.x86_64 3/9
Verifying : mpfr-2.4.1-6.el6.x86_64 4/9
Verifying : glibc-headers-2.12-1.80.el6.x86_64 5/9
Verifying : libgomp-4.4.6-4.el6.x86_64 6/9
Verifying : cpp-4.4.6-4.el6.x86_64 7/9
Verifying : ppl-0.10.2-11.el6.x86_64 8/9
Verifying : cloog-ppl-0.15.7-1.2.el6.x86_64 9/9

Installed:
gcc.x86_64 0:4.4.6-4.el6

Dependency Installed:
cloog-ppl.x86_64 0:0.15.7-1.2.el6 cpp.x86_64 0:4.4.6-4.el6 glibc-devel.x86_64 0:2.12-1.80.el6 glibc-headers.x86_64 0:2.12-1.80.el6 kernel-headers.x86_64 0:2.6.32-358.0.1.el6.centos.plus
libgomp.x86_64 0:4.4.6-4.el6 mpfr.x86_64 0:2.4.1-6.el6 ppl.x86_64 0:0.10.2-11.el6

Complete!


That's it. I hope someone would find this information useful :-)
sjlx1
 
Posts: 1
Joined: 2013/03/10 20:35:41


Return to CentOS 6 - Software Support

Who is online

Users browsing this forum: No registered users and 5 guests