[SOLVED] BOOTMGR is missing, Windows 7 (32) + CentOS 6.3 (32b)

Issues related to applications and software problems
Posts: 3
Joined: 2013/01/16 10:55:48

[SOLVED] BOOTMGR is missing, Windows 7 (32) + CentOS 6.3 (32b)

Postby lxrazz » 2013/01/16 12:44:28

Dear readers,

Last night I installed CentOS 6.3 on my PC alongside windows 7.
I've fallen for linux for a while now and am educating myself in this matter.
I've come to understand that in a common installation (dual boot windows + Linux) you should have less than 4 primary partitions.
And you should select enough free space for the linux partition and mount it as root (I had ext4 as fs)
I selected a swap partition same size as my RAM (4GB).
So after installing I did a system update and after the normal required reboot...
Then at the bootscreen I selected TAB for other options... So I thought lets go back to windows for some time, I needed to do something in Win7.

But then BOOTMGR is missing...
Now I'm gonna say "I don't know what the exact problem is" since I hate to assume myself...
But if I had to guess? I would say "It has to do with the Bootloader of linux"

How do I tackle this problem, without losing my Windows Installation and keep my CentOS Installation?
Is this grub-fixable? (Neither am I experienced in grub, but I'm not... lets just say "I'm a quick learner")

My CentOS installation may be deleted / purged in order to save my Win7 installation since it is a quite fresh one.

I pre-apologise for any confusion or lack of information within my post.

Thanks in advance...

Posts: 312
Joined: 2012/03/06 22:30:17
Location: Ottawa

Re: BOOTMGR is missing, Windows 7 (32) + CentOS 6.3 (32b)

Postby YBellefeuille » 2013/01/16 23:40:53

I'll guess that one of the things you did, although you don't mention it, is that you resized your Windows partition in order to create a new partition for Linux. Am I right?

Resizing the Windows partition isn't wrong, but it can cause the problem you describe. It's a Windows problem, not a Linux problem.

Boot into Windows using your System repair disc and choose "Startup Repair". This should fix your problem.

If you don't have a System repair disc, boot Windows using your installation DVD and open the System recovery options.

If you have neither a System repair disc nor an installation DVD, make a System repair disc using another computer with Windows 7.

If that's not possible, you can use your system's Startup Repair or Recovery command, if it has one. This might reinstall Windows, thereby deleting all your Windows files.

If none of these is possible, then I don't know what to suggest. Look for information about reinstalling BOOTMGR or the boot sector on Windows 7.

Posts: 3
Joined: 2013/01/16 10:55:48

Re: BOOTMGR is missing, Windows 7 (32) + CentOS 6.3 (32b)

Postby lxrazz » 2013/01/17 16:01:23

Hello YBellefeuille,

First, thanks for your reaction to my post.
I could'nt tell you with certainty if I resized the partition.

I will try your method tonight see if it helps.
I will report the results.


Posts: 3
Joined: 2013/01/16 10:55:48

Re: BOOTMGR is missing, Windows 7 (32) + CentOS 6.3 (32b)

Postby lxrazz » 2013/01/21 22:45:41

To give other grub newbies like me the advatage of time-saving.
I have found out that, after I installed Windows 7, CentOS installation could'nt find at what exact partition my windows was installed on.
After installing CentOS opened a terminal

# fdisk -l

Device Boot Start End Blocks Id System
/dev/sda1 1 21673 174080000 7 HPFS/NTFS
/dev/sda2 21673 21736 512000 83 Linux
/dev/sda3 * 38245 121601 669558784 7 HPFS/NTFS
/dev/sda4 21736 38245 132608000 5 Extended
/dev/sda5 21736 38245 132606976 8e Linux LVM

The results contained two NTFS partitions, my guess is that it marked the first NTFS partition as the "Other" boot option
While the second NTFS (third in the list) partition was my Windows installation partition.
So opened grub.conf

And changed hd0,0 to hd0,2 (say first physical disk, third partition) saved and rebooted.
After trying other (Yes!) it booted me to windows.

title Other
rootnoverify (hd0,2)
chainloader +1

And done...

Thanks YBellefeuille for your help.

User avatar
Forum Moderator
Posts: 9313
Joined: 2007/10/22 11:30:09
Location: ~/Earth/UK/England/Suffolk

[SOLVED] BOOTMGR is missing, Windows 7 (32) + CentOS 6.3 (32

Postby AlanBartlett » 2013/01/21 23:15:00

Thank you for reporting back with news of your success.

On your behalf and for posterity, this thread is now marked [SOLVED].

Posts: 1
Joined: 2013/11/23 19:33:43

Re: [SOLVED] BOOTMGR is missing, Windows 7 (32) + CentOS 6.3

Postby kefalonitis » 2013/11/23 19:39:00

Thanks a lot, you are the best !!!!!!!!!!!!!!!