Yum update issues

General support questions
Post Reply
prajwel
Posts: 2
Joined: 2017/09/20 11:09:09

Yum update issues

Post by prajwel » 2017/09/20 11:12:37

Hi all,
I tried to do

Code: Select all

sudo yum update
But I am getting the following errors.

Code: Select all

--> Finished Dependency Resolution
Error: Package: libgpod-0.8.3-14.el7.x86_64 (@epel)
           Requires: libplist.so.1()(64bit)
           Removing: libplist-1.10-4.el7.x86_64 (@anaconda)
               libplist.so.1()(64bit)
           Updated By: libplist-1.12-3.el7.x86_64 (base)
              ~libplist.so.3()(64bit)
Error: Package: libgpod-0.8.3-14.el7.x86_64 (@epel)
           Requires: libusbmuxd.so.2()(64bit)
           Removing: usbmuxd-1.0.8-11.el7.x86_64 (@anaconda)
               libusbmuxd.so.2()(64bit)
           Obsoleted By: usbmuxd-1.1.0-1.el7.x86_64 (base)
               Not found
Error: Package: libgpod-0.8.3-14.el7.x86_64 (@epel)
           Requires: libimobiledevice.so.4()(64bit)
           Removing: libimobiledevice-1.1.5-6.el7.x86_64 (@anaconda)
               libimobiledevice.so.4()(64bit)
           Updated By: libimobiledevice-1.2.0-1.el7.x86_64 (base)
              ~libimobiledevice.so.6()(64bit)
 You could try using --skip-broken to work around the problem
** Found 4 pre-existing rpmdb problem(s), 'yum check' output follows:
ipa-client-4.4.0-14.el7.centos.7.x86_64 has installed conflicts freeipa-client: ipa-client-4.4.0-14.el7.centos.7.x86_64
ipa-client-common-4.4.0-14.el7.centos.7.noarch has installed conflicts freeipa-client-common: ipa-client-common-4.4.0-14.el7.centos.7.noarch
ipa-common-4.4.0-14.el7.centos.7.noarch has installed conflicts freeipa-common: ipa-common-4.4.0-14.el7.centos.7.noarch
ipa-python-compat-4.4.0-14.el7.centos.7.noarch has installed conflicts freeipa-python-compat: ipa-python-compat-4.4.0-14.el7.centos.7.noarch
Please help me to resolve this issue. Thank you.

stevemowbray
Posts: 470
Joined: 2012/06/26 14:20:47

Re: Yum update issues

Post by stevemowbray » 2017/09/20 12:19:53

You need to read the 7.4 release notes.

Code: Select all

yum downgrade libgpod
, then do the update.

User avatar
TrevorH
Forum Moderator
Posts: 26311
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Yum update issues

Post by TrevorH » 2017/09/20 12:46:32

CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

behrouzjaz
Posts: 1
Joined: 2018/01/04 13:11:00

Re: Yum update issues

Post by behrouzjaz » 2018/01/04 13:13:48

stevemowbray wrote:You need to read the 7.4 release notes.

Code: Select all

yum downgrade libgpod
, then do the update.
Nice, it worked! as they always say RTFM!!

Thanks mate.
Cheers,

Behrouz

Post Reply