yum update error

General support questions
Post Reply
ehinkle33
Posts: 1
Joined: 2017/10/06 16:37:44

yum update error

Post by ehinkle33 » 2017/10/06 16:47:21

Hi,

New to the forum and have an issue with an install of centos running yum update. Not sure what I need to do to resolve. i am getting the below errors and have posted the full output of running yum update. this was a clean centos 7 1708 install.

Code: Select all

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: centos.vwtonline.net
 * extras: bay.uchicago.edu
 * updates: bay.uchicago.edu
Resolving Dependencies
--> Running transaction check
---> Package NetworkManager.x86_64 1:1.4.0-20.el7_3 will be obsoleted
---> Package NetworkManager.x86_64 1:1.8.0-9.el7 will be obsoleting
---> Package NetworkManager-ppp.x86_64 1:1.8.0-9.el7 will be obsoleting
---> Package NetworkManager-team.x86_64 1:1.4.0-20.el7_3 will be updated
---> Package NetworkManager-team.x86_64 1:1.8.0-9.el7 will be an update
---> Package NetworkManager-tui.x86_64 1:1.4.0-20.el7_3 will be updated
---> Package NetworkManager-tui.x86_64 1:1.8.0-9.el7 will be an update
---> Package NetworkManager-wifi.x86_64 1:1.4.0-20.el7_3 will be updated
---> Package NetworkManager-wifi.x86_64 1:1.8.0-9.el7 will be an update
---> Package alsa-lib.x86_64 0:1.1.1-1.el7 will be updated
---> Package alsa-lib.x86_64 0:1.1.3-3.el7 will be an update
---> Package audit.x86_64 0:2.6.5-3.el7_3.1 will be updated
---> Package audit.x86_64 0:2.7.6-3.el7 will be an update
---> Package bind-libs-lite.x86_64 32:9.9.4-50.el7_3.1 will be updated
---> Package bind-libs-lite.x86_64 32:9.9.4-51.el7 will be an update
---> Package bind-license.noarch 32:9.9.4-50.el7_3.1 will be updated
---> Package bind-license.noarch 32:9.9.4-51.el7 will be an update
---> Package binutils.x86_64 0:2.25.1-22.base.el7 will be updated
---> Package binutils.x86_64 0:2.25.1-32.base.el7_4.1 will be an update
---> Package biosdevname.x86_64 0:0.7.2-1.el7 will be updated
---> Package biosdevname.x86_64 0:0.7.2-2.el7 will be an update
---> Package btrfs-progs.x86_64 0:4.4.1-1.el7 will be updated
---> Package btrfs-progs.x86_64 0:4.9.1-1.el7 will be an update
---> Package cronie.x86_64 0:1.4.11-14.el7_2.1 will be updated
---> Package cronie.x86_64 0:1.4.11-17.el7 will be an update
---> Package cronie-anacron.x86_64 0:1.4.11-14.el7_2.1 will be updated
---> Package cronie-anacron.x86_64 0:1.4.11-17.el7 will be an update
---> Package cryptsetup-libs.x86_64 0:1.7.2-1.el7 will be updated
---> Package cryptsetup-libs.x86_64 0:1.7.4-3.el7 will be an update
---> Package curl.x86_64 0:7.29.0-35.el7.centos will be updated
---> Package curl.x86_64 0:7.29.0-42.el7 will be an update
---> Package cyrus-sasl-lib.x86_64 0:2.1.26-20.el7_2 will be updated
---> Package cyrus-sasl-lib.x86_64 0:2.1.26-21.el7 will be an update
---> Package device-mapper.x86_64 7:1.02.135-1.el7_3.5 will be updated
---> Package device-mapper.x86_64 7:1.02.140-8.el7 will be an update
---> Package device-mapper-event.x86_64 7:1.02.135-1.el7_3.5 will be updated
---> Package device-mapper-event.x86_64 7:1.02.140-8.el7 will be an update
---> Package device-mapper-event-libs.x86_64 7:1.02.135-1.el7_3.5 will be updated
---> Package device-mapper-event-libs.x86_64 7:1.02.140-8.el7 will be an update
---> Package device-mapper-libs.x86_64 7:1.02.135-1.el7_3.5 will be updated
---> Package device-mapper-libs.x86_64 7:1.02.140-8.el7 will be an update
---> Package device-mapper-persistent-data.x86_64 0:0.6.3-1.el7 will be updated
---> Package device-mapper-persistent-data.x86_64 0:0.7.0-0.1.rc6.el7 will be an update
---> Package dhclient.x86_64 12:4.2.5-47.el7.centos will be updated
---> Package dhclient.x86_64 12:4.2.5-58.el7.centos will be an update
---> Package dhcp-common.x86_64 12:4.2.5-47.el7.centos will be updated
---> Package dhcp-common.x86_64 12:4.2.5-58.el7.centos will be an update
---> Package dhcp-libs.x86_64 12:4.2.5-47.el7.centos will be updated
---> Package dhcp-libs.x86_64 12:4.2.5-58.el7.centos will be an update
---> Package dmidecode.x86_64 1:3.0-2.1.el7_3 will be updated
---> Package dmidecode.x86_64 1:3.0-5.el7 will be an update
---> Package dnsmasq.x86_64 0:2.66-21.el7 will be updated
---> Package dnsmasq.x86_64 0:2.76-2.el7_4.2 will be an update
---> Package dracut.x86_64 0:033-463.el7_3.2 will be updated
---> Package dracut.x86_64 0:033-502.el7 will be an update
---> Package dracut-config-rescue.x86_64 0:033-463.el7_3.2 will be updated
---> Package dracut-config-rescue.x86_64 0:033-502.el7 will be an update
---> Package dracut-network.x86_64 0:033-463.el7_3.2 will be updated
---> Package dracut-network.x86_64 0:033-502.el7 will be an update
---> Package e2fsprogs.x86_64 0:1.42.9-9.el7 will be updated
---> Package e2fsprogs.x86_64 0:1.42.9-10.el7 will be an update
---> Package firewalld.noarch 0:0.4.3.2-8.1.el7_3.3 will be updated
---> Package firewalld.noarch 0:0.4.4.4-6.el7 will be an update
---> Package freetype.x86_64 0:2.4.11-12.el7 will be updated
---> Package freetype.x86_64 0:2.4.11-15.el7 will be an update
---> Package fuse.x86_64 0:2.9.2-7.el7 will be updated
---> Package fuse.x86_64 0:2.9.2-8.el7 will be an update
---> Package fuse-libs.x86_64 0:2.9.2-7.el7 will be updated
---> Package fuse-libs.x86_64 0:2.9.2-8.el7 will be an update
---> Package glib-networking.x86_64 0:2.42.0-1.el7 will be updated
---> Package glib-networking.x86_64 0:2.50.0-1.el7 will be an update
---> Package gmp.x86_64 1:6.0.0-12.el7_1 will be updated
---> Package gmp.x86_64 1:6.0.0-15.el7 will be an update
---> Package gnutls.x86_64 0:3.3.24-1.el7 will be updated
---> Package gnutls.x86_64 0:3.3.26-9.el7 will be an update
---> Package gobject-introspection.x86_64 0:1.42.0-1.el7 will be updated
---> Package gobject-introspection.x86_64 0:1.50.0-1.el7 will be an update
---> Package grub2.x86_64 1:2.02-0.44.el7.centos will be obsoleted
---> Package grub2.x86_64 1:2.02-0.64.el7.centos will be obsoleting
--> Processing Dependency: grub2-pc = 1:2.02-0.64.el7.centos for package: 1:grub2-2.02-0.64.el7.centos.x86_64
---> Package grub2-tools.x86_64 1:2.02-0.44.el7.centos will be obsoleted
---> Package grub2-tools.x86_64 1:2.02-0.64.el7.centos will be obsoleting
---> Package grub2-tools-efi.x86_64 1:2.02-0.64.el7.centos will be obsoleting
---> Package grub2-tools-extra.x86_64 1:2.02-0.64.el7.centos will be obsoleting
---> Package grub2-tools-minimal.x86_64 1:2.02-0.64.el7.centos will be obsoleting
---> Package grubby.x86_64 0:8.28-21.el7_3 will be updated
---> Package grubby.x86_64 0:8.28-23.el7 will be an update
---> Package hwdata.x86_64 0:0.252-8.4.el7 will be updated
---> Package hwdata.x86_64 0:0.252-8.6.el7 will be an update
---> Package initscripts.x86_64 0:9.49.37-1.el7_3.1 will be updated
---> Package initscripts.x86_64 0:9.49.39-1.el7 will be an update
---> Package iprutils.x86_64 0:2.4.13.1-1.el7 will be updated
---> Package iprutils.x86_64 0:2.4.14.1-1.el7 will be an update
---> Package ipset.x86_64 0:6.19-6.el7 will be updated
---> Package ipset.x86_64 0:6.29-1.el7 will be an update
---> Package ipset-libs.x86_64 0:6.19-6.el7 will be updated
---> Package ipset-libs.x86_64 0:6.29-1.el7 will be an update
---> Package iputils.x86_64 0:20160308-8.el7 will be updated
---> Package iputils.x86_64 0:20160308-10.el7 will be an update
---> Package irqbalance.x86_64 3:1.0.7-6.el7_3.1 will be updated
---> Package irqbalance.x86_64 3:1.0.7-10.el7 will be an update
---> Package iwl100-firmware.noarch 0:39.31.5.1-49.el7 will be updated
---> Package iwl100-firmware.noarch 0:39.31.5.1-56.el7 will be an update
---> Package iwl1000-firmware.noarch 1:39.31.5.1-49.el7 will be updated
---> Package iwl1000-firmware.noarch 1:39.31.5.1-56.el7 will be an update
---> Package iwl105-firmware.noarch 0:18.168.6.1-49.el7 will be updated
---> Package iwl105-firmware.noarch 0:18.168.6.1-56.el7 will be an update
---> Package iwl135-firmware.noarch 0:18.168.6.1-49.el7 will be updated
---> Package iwl135-firmware.noarch 0:18.168.6.1-56.el7 will be an update
---> Package iwl2000-firmware.noarch 0:18.168.6.1-49.el7 will be updated
---> Package iwl2000-firmware.noarch 0:18.168.6.1-56.el7 will be an update
---> Package iwl2030-firmware.noarch 0:18.168.6.1-49.el7 will be updated
---> Package iwl2030-firmware.noarch 0:18.168.6.1-56.el7 will be an update
---> Package iwl3160-firmware.noarch 0:22.0.7.0-49.el7 will be updated
---> Package iwl3160-firmware.noarch 0:22.0.7.0-56.el7 will be an update
---> Package iwl3945-firmware.noarch 0:15.32.2.9-49.el7 will be updated
---> Package iwl3945-firmware.noarch 0:15.32.2.9-56.el7 will be an update
---> Package iwl4965-firmware.noarch 0:228.61.2.24-49.el7 will be updated
---> Package iwl4965-firmware.noarch 0:228.61.2.24-56.el7 will be an update
---> Package iwl5000-firmware.noarch 0:8.83.5.1_1-49.el7 will be updated
---> Package iwl5000-firmware.noarch 0:8.83.5.1_1-56.el7 will be an update
---> Package iwl5150-firmware.noarch 0:8.24.2.2-49.el7 will be updated
---> Package iwl5150-firmware.noarch 0:8.24.2.2-56.el7 will be an update
---> Package iwl6000-firmware.noarch 0:9.221.4.1-49.el7 will be updated
---> Package iwl6000-firmware.noarch 0:9.221.4.1-56.el7 will be an update
---> Package iwl6000g2a-firmware.noarch 0:17.168.5.3-49.el7 will be updated
---> Package iwl6000g2a-firmware.noarch 0:17.168.5.3-56.el7 will be an update
---> Package iwl6000g2b-firmware.noarch 0:17.168.5.2-49.el7 will be updated
---> Package iwl6000g2b-firmware.noarch 0:17.168.5.2-56.el7 will be an update
---> Package iwl6050-firmware.noarch 0:41.28.5.1-49.el7 will be updated
---> Package iwl6050-firmware.noarch 0:41.28.5.1-56.el7 will be an update
---> Package iwl7260-firmware.noarch 0:22.0.7.0-49.el7 will be updated
---> Package iwl7260-firmware.noarch 0:22.0.7.0-56.el7 will be an update
---> Package iwl7265-firmware.noarch 0:22.0.7.0-49.el7 will be updated
---> Package iwl7265-firmware.noarch 0:22.0.7.0-56.el7 will be an update
---> Package kbd.x86_64 0:1.15.5-12.el7 will be updated
---> Package kbd.x86_64 0:1.15.5-13.el7 will be an update
---> Package kbd-legacy.noarch 0:1.15.5-12.el7 will be updated
---> Package kbd-legacy.noarch 0:1.15.5-13.el7 will be an update
---> Package kbd-misc.noarch 0:1.15.5-12.el7 will be updated
---> Package kbd-misc.noarch 0:1.15.5-13.el7 will be an update
---> Package kernel.x86_64 0:3.10.0-693.2.2.el7 will be installed
---> Package kernel-tools.x86_64 0:3.10.0-514.26.2.el7 will be updated
---> Package kernel-tools.x86_64 0:3.10.0-693.2.2.el7 will be an update
---> Package kernel-tools-libs.x86_64 0:3.10.0-514.26.2.el7 will be updated
---> Package kernel-tools-libs.x86_64 0:3.10.0-693.2.2.el7 will be an update
---> Package kexec-tools.x86_64 0:2.0.7-50.el7 will be updated
---> Package kexec-tools.x86_64 0:2.0.14-17.el7 will be an update
---> Package kmod.x86_64 0:20-9.el7 will be updated
---> Package kmod.x86_64 0:20-15.el7_4.2 will be an update
---> Package kpartx.x86_64 0:0.4.9-99.el7_3.3 will be updated
---> Package kpartx.x86_64 0:0.4.9-111.el7 will be an update
---> Package libcurl.x86_64 0:7.29.0-35.el7.centos will be updated
---> Package libcurl.x86_64 0:7.29.0-42.el7 will be an update
---> Package libdb-utils.x86_64 0:5.3.21-19.el7 will be updated
---> Package libdb-utils.x86_64 0:5.3.21-20.el7 will be an update
---> Package libdrm.x86_64 0:2.4.67-3.el7 will be updated
---> Package libdrm.x86_64 0:2.4.74-1.el7 will be an update
---> Package libgudev1.x86_64 0:219-30.el7_3.9 will be updated
---> Package libgudev1.x86_64 0:219-42.el7_4.1 will be an update
---> Package libmspack.x86_64 0:0.5-0.4.alpha.el7 will be updated
---> Package libmspack.x86_64 0:0.5-0.5.alpha.el7 will be an update
---> Package libpcap.x86_64 14:1.5.3-8.el7 will be updated
---> Package libpcap.x86_64 14:1.5.3-9.el7 will be an update
---> Package libselinux-python.x86_64 0:2.5-6.el7 will be updated
---> Package libselinux-python.x86_64 0:2.5-11.el7 will be an update
---> Package libsoup.x86_64 0:2.48.1-6.el7 will be updated
---> Package libsoup.x86_64 0:2.56.0-4.el7_4 will be an update
---> Package libss.x86_64 0:1.42.9-9.el7 will be updated
---> Package libss.x86_64 0:1.42.9-10.el7 will be an update
---> Package linux-firmware.noarch 0:20160830-49.git7534e19.el7 will be updated
---> Package linux-firmware.noarch 0:20170606-56.gitc990aae.el7 will be an update
---> Package logrotate.x86_64 0:3.8.6-12.el7 will be updated
---> Package logrotate.x86_64 0:3.8.6-14.el7 will be an update
---> Package lsscsi.x86_64 0:0.27-4.el7 will be updated
---> Package lsscsi.x86_64 0:0.27-6.el7 will be an update
---> Package lvm2.x86_64 7:2.02.166-1.el7_3.5 will be updated
---> Package lvm2.x86_64 7:2.02.171-8.el7 will be an update
---> Package lvm2-libs.x86_64 7:2.02.166-1.el7_3.5 will be updated
---> Package lvm2-libs.x86_64 7:2.02.171-8.el7 will be an update
---> Package mariadb-libs.x86_64 1:5.5.52-1.el7 will be updated
---> Package mariadb-libs.x86_64 1:5.5.56-2.el7 will be an update
---> Package microcode_ctl.x86_64 2:2.1-16.3.el7_3 will be updated
---> Package microcode_ctl.x86_64 2:2.1-22.el7 will be an update
---> Package ncurses.x86_64 0:5.9-13.20130511.el7 will be updated
---> Package ncurses.x86_64 0:5.9-14.20130511.el7_4 will be an update
---> Package net-tools.x86_64 0:2.0-0.17.20131004git.el7 will be updated
---> Package net-tools.x86_64 0:2.0-0.22.20131004git.el7 will be an update
---> Package nss.x86_64 0:3.28.4-1.2.el7_3 will be updated
---> Package nss.x86_64 0:3.28.4-11.el7_4 will be updated
---> Package nss.x86_64 0:3.28.4-12.el7_4 will be an update
---> Package nss-sysinit.x86_64 0:3.28.4-1.2.el7_3 will be updated
---> Package nss-sysinit.x86_64 0:3.28.4-11.el7_4 will be updated
---> Package nss-sysinit.x86_64 0:3.28.4-12.el7_4 will be an update
---> Package nss-tools.x86_64 0:3.28.4-1.2.el7_3 will be updated
---> Package nss-tools.x86_64 0:3.28.4-11.el7_4 will be updated
---> Package nss-tools.x86_64 0:3.28.4-12.el7_4 will be an update
---> Package open-vm-tools.x86_64 0:10.0.5-4.el7_3 will be updated
---> Package open-vm-tools.x86_64 0:10.1.5-3.el7 will be an update
---> Package openldap.x86_64 0:2.4.40-13.el7 will be updated
---> Package openldap.x86_64 0:2.4.44-5.el7 will be an update
---> Package openssh.x86_64 0:6.6.1p1-35.el7_3 will be updated
---> Package openssh.x86_64 0:7.4p1-12.el7_4 will be an update
---> Package openssh-clients.x86_64 0:6.6.1p1-35.el7_3 will be updated
---> Package openssh-clients.x86_64 0:7.4p1-12.el7_4 will be an update
---> Package openssh-server.x86_64 0:6.6.1p1-35.el7_3 will be updated
---> Package openssh-server.x86_64 0:7.4p1-12.el7_4 will be an update
---> Package pciutils.x86_64 0:3.5.1-1.el7 will be updated
---> Package pciutils.x86_64 0:3.5.1-2.el7 will be an update
---> Package plymouth.x86_64 0:0.8.9-0.26.20140113.el7.centos will be updated
---> Package plymouth.x86_64 0:0.8.9-0.28.20140113.el7.centos will be an update
---> Package plymouth-scripts.x86_64 0:0.8.9-0.26.20140113.el7.centos will be updated
---> Package plymouth-scripts.x86_64 0:0.8.9-0.28.20140113.el7.centos will be an update
---> Package pygobject3-base.x86_64 0:3.14.0-3.el7 will be obsoleted
---> Package python-firewall.noarch 0:0.4.3.2-8.1.el7_3.3 will be updated
---> Package python-firewall.noarch 0:0.4.4.4-6.el7 will be an update
---> Package python-gobject-base.x86_64 0:3.22.0-1.el7 will be obsoleting
---> Package rdma.noarch 0:7.3_4.7_rc2-6.el7_3 will be obsoleted
---> Package rdma-core.i686 0:13-7.el7 will be obsoleting
--> Processing Dependency: libudev.so.1(LIBUDEV_183) for package: rdma-core-13-7.el7.i686
--> Processing Dependency: libudev.so.1 for package: rdma-core-13-7.el7.i686
--> Processing Dependency: libc.so.6(GLIBC_2.16) for package: rdma-core-13-7.el7.i686
---> Package rdma-core.x86_64 0:13-7.el7 will be obsoleting
---> Package rpm.x86_64 0:4.11.3-21.el7 will be updated
---> Package rpm.x86_64 0:4.11.3-25.el7 will be an update
---> Package rpm-build-libs.x86_64 0:4.11.3-21.el7 will be updated
---> Package rpm-build-libs.x86_64 0:4.11.3-25.el7 will be an update
---> Package rpm-libs.x86_64 0:4.11.3-21.el7 will be updated
---> Package rpm-libs.x86_64 0:4.11.3-25.el7 will be an update
---> Package rpm-python.x86_64 0:4.11.3-21.el7 will be updated
---> Package rpm-python.x86_64 0:4.11.3-25.el7 will be an update
---> Package rsyslog.x86_64 0:7.4.7-16.el7 will be updated
---> Package rsyslog.x86_64 0:8.24.0-12.el7 will be an update
--> Processing Dependency: libfastjson.so.4()(64bit) for package: rsyslog-8.24.0-12.el7.x86_64
---> Package selinux-policy.noarch 0:3.13.1-102.el7_3.16 will be updated
---> Package selinux-policy.noarch 0:3.13.1-166.el7_4.4 will be an update
--> Processing Dependency: policycoreutils >= 2.5 for package: selinux-policy-3.13.1-166.el7_4.4.noarch
---> Package selinux-policy-targeted.noarch 0:3.13.1-102.el7_3.16 will be updated
---> Package selinux-policy-targeted.noarch 0:3.13.1-166.el7_4.4 will be an update
---> Package sudo.x86_64 0:1.8.6p7-23.el7_3 will be updated
---> Package sudo.x86_64 0:1.8.19p2-11.el7_4 will be an update
---> Package systemd.x86_64 0:219-30.el7_3.9 will be updated
---> Package systemd.x86_64 0:219-42.el7_4.1 will be an update
---> Package systemd-sysv.x86_64 0:219-30.el7_3.9 will be updated
---> Package systemd-sysv.x86_64 0:219-42.el7_4.1 will be an update
---> Package trousers.x86_64 0:0.3.13-1.el7 will be updated
---> Package trousers.x86_64 0:0.3.14-2.el7 will be an update
---> Package tuned.noarch 0:2.7.1-3.el7_3.2 will be updated
---> Package tuned.noarch 0:2.8.0-5.el7 will be an update
---> Package util-linux.x86_64 0:2.23.2-33.el7_3.2 will be updated
---> Package util-linux.x86_64 0:2.23.2-43.el7 will be an update
---> Package vim-minimal.x86_64 2:7.4.160-1.el7_3.1 will be updated
---> Package vim-minimal.x86_64 2:7.4.160-2.el7 will be an update
---> Package virt-what.x86_64 0:1.13-8.el7 will be updated
---> Package virt-what.x86_64 0:1.13-10.el7 will be an update
---> Package wpa_supplicant.x86_64 1:2.0-21.el7_3 will be updated
---> Package wpa_supplicant.x86_64 1:2.6-5.el7 will be an update
---> Package xfsprogs.x86_64 0:4.5.0-10.el7_3 will be updated
---> Package xfsprogs.x86_64 0:4.5.0-12.el7 will be an update
---> Package yum.noarch 0:3.4.3-150.el7.centos will be updated
---> Package yum.noarch 0:3.4.3-154.el7.centos will be an update
---> Package yum-plugin-fastestmirror.noarch 0:1.1.31-40.el7 will be updated
---> Package yum-plugin-fastestmirror.noarch 0:1.1.31-42.el7 will be an update
--> Running transaction check
---> Package glibc.i686 0:2.17-196.el7 will be installed
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.17-196.el7.i686
--> Processing Dependency: libfreebl3.so for package: glibc-2.17-196.el7.i686
---> Package grub2-pc.x86_64 1:2.02-0.64.el7.centos will be installed
---> Package libfastjson.x86_64 0:0.99.4-2.el7 will be installed
---> Package policycoreutils.x86_64 0:2.5-17.1.el7 will be installed
--> Processing Dependency: libselinux-utils >= 2.5-6 for package: policycoreutils-2.5-17.1.el7.x86_64
---> Package systemd-libs.i686 0:219-42.el7_4.1 will be installed
--> Processing Dependency: libselinux.so.1 for package: systemd-libs-219-42.el7_4.1.i686
--> Processing Dependency: libpam_misc.so.0(LIBPAM_MISC_1.0) for package: systemd-libs-219-42.el7_4.1.i686
--> Processing Dependency: libpam_misc.so.0 for package: systemd-libs-219-42.el7_4.1.i686
--> Processing Dependency: libpam.so.0(LIBPAM_MODUTIL_1.0) for package: systemd-libs-219-42.el7_4.1.i686
--> Processing Dependency: libpam.so.0(LIBPAM_EXTENSION_1.0) for package: systemd-libs-219-42.el7_4.1.i686
--> Processing Dependency: libpam.so.0(LIBPAM_1.0) for package: systemd-libs-219-42.el7_4.1.i686
--> Processing Dependency: libpam.so.0 for package: systemd-libs-219-42.el7_4.1.i686
--> Processing Dependency: liblzma.so.5(XZ_5.0) for package: systemd-libs-219-42.el7_4.1.i686
--> Processing Dependency: liblzma.so.5 for package: systemd-libs-219-42.el7_4.1.i686
--> Processing Dependency: libgpg-error.so.0 for package: systemd-libs-219-42.el7_4.1.i686
--> Processing Dependency: libgcrypt.so.11(GCRYPT_1.2) for package: systemd-libs-219-42.el7_4.1.i686
--> Processing Dependency: libgcrypt.so.11 for package: systemd-libs-219-42.el7_4.1.i686
--> Processing Dependency: libgcc_s.so.1(GLIBC_2.0) for package: systemd-libs-219-42.el7_4.1.i686
--> Processing Dependency: libgcc_s.so.1(GCC_3.3.1) for package: systemd-libs-219-42.el7_4.1.i686
--> Processing Dependency: libgcc_s.so.1(GCC_3.0) for package: systemd-libs-219-42.el7_4.1.i686
--> Processing Dependency: libgcc_s.so.1 for package: systemd-libs-219-42.el7_4.1.i686
--> Processing Dependency: libdw.so.1 for package: systemd-libs-219-42.el7_4.1.i686
--> Processing Dependency: libcap.so.2 for package: systemd-libs-219-42.el7_4.1.i686
--> Running transaction check
---> Package elfutils-libs.i686 0:0.168-8.el7 will be installed
--> Processing Dependency: elfutils-libelf(x86-32) = 0.168-8.el7 for package: elfutils-libs-0.168-8.el7.i686
--> Processing Dependency: libz.so.1(ZLIB_1.2.2.3) for package: elfutils-libs-0.168-8.el7.i686
--> Processing Dependency: libz.so.1 for package: elfutils-libs-0.168-8.el7.i686
--> Processing Dependency: libelf.so.1(ELFUTILS_1.7) for package: elfutils-libs-0.168-8.el7.i686
--> Processing Dependency: libelf.so.1(ELFUTILS_1.6) for package: elfutils-libs-0.168-8.el7.i686
--> Processing Dependency: libelf.so.1(ELFUTILS_1.5) for package: elfutils-libs-0.168-8.el7.i686
--> Processing Dependency: libelf.so.1(ELFUTILS_1.4) for package: elfutils-libs-0.168-8.el7.i686
--> Processing Dependency: libelf.so.1(ELFUTILS_1.3) for package: elfutils-libs-0.168-8.el7.i686
--> Processing Dependency: libelf.so.1(ELFUTILS_1.1.1) for package: elfutils-libs-0.168-8.el7.i686
--> Processing Dependency: libelf.so.1(ELFUTILS_1.0) for package: elfutils-libs-0.168-8.el7.i686
--> Processing Dependency: libelf.so.1 for package: elfutils-libs-0.168-8.el7.i686
--> Processing Dependency: libbz2.so.1 for package: elfutils-libs-0.168-8.el7.i686
---> Package libcap.i686 0:2.22-9.el7 will be installed
--> Processing Dependency: libattr.so.1(ATTR_1.0) for package: libcap-2.22-9.el7.i686
--> Processing Dependency: libattr.so.1 for package: libcap-2.22-9.el7.i686
---> Package libgcc.i686 0:4.8.5-16.el7 will be installed
---> Package libgcrypt.i686 0:1.5.3-14.el7 will be installed
---> Package libgpg-error.i686 0:1.12-3.el7 will be installed
---> Package libselinux.i686 0:2.5-11.el7 will be installed
--> Processing Dependency: libsepol(x86-32) >= 2.5-6 for package: libselinux-2.5-11.el7.i686
--> Processing Dependency: libsepol.so.1(LIBSEPOL_1.0) for package: libselinux-2.5-11.el7.i686
--> Processing Dependency: libsepol.so.1 for package: libselinux-2.5-11.el7.i686
--> Processing Dependency: libpcre.so.1 for package: libselinux-2.5-11.el7.i686
---> Package libselinux-utils.x86_64 0:2.5-11.el7 will be installed
---> Package nss-softokn-freebl.i686 0:3.28.3-8.el7_4 will be installed
---> Package pam.i686 0:1.1.8-18.el7 will be installed
--> Processing Dependency: libdb-5.3.so for package: pam-1.1.8-18.el7.i686
--> Processing Dependency: libcrack.so.2 for package: pam-1.1.8-18.el7.i686
--> Processing Dependency: libaudit.so.1 for package: pam-1.1.8-18.el7.i686
---> Package xz-libs.i686 0:5.2.2-1.el7 will be installed
--> Running transaction check
---> Package audit-libs.i686 0:2.7.6-3.el7 will be installed
--> Processing Dependency: libcap-ng.so.0 for package: audit-libs-2.7.6-3.el7.i686
---> Package bzip2-libs.i686 0:1.0.6-13.el7 will be installed
---> Package cracklib.i686 0:2.9.0-11.el7 will be installed
---> Package elfutils-libelf.i686 0:0.168-8.el7 will be installed
---> Package libattr.i686 0:2.4.46-12.el7 will be installed
---> Package libdb.i686 0:5.3.21-20.el7 will be installed
---> Package libsepol.i686 0:2.5-6.el7 will be installed
---> Package pcre.i686 0:8.32-17.el7 will be installed
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.9) for package: pcre-8.32-17.el7.i686
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4) for package: pcre-8.32-17.el7.i686
--> Processing Dependency: libstdc++.so.6(CXXABI_1.3) for package: pcre-8.32-17.el7.i686
--> Processing Dependency: libstdc++.so.6 for package: pcre-8.32-17.el7.i686
---> Package zlib.i686 0:1.2.7-17.el7 will be installed
--> Running transaction check
---> Package libcap-ng.i686 0:0.7.5-4.el7 will be installed
---> Package libstdc++.i686 0:4.8.5-16.el7 will be installed
--> Finished Dependency Resolution
Error:  Multilib version problems found. This often means that the root
       cause is something else and multilib version checking is just
       pointing out that there is a problem. Eg.:

         1. You have an upgrade for systemd-libs which is missing some
            dependency that another package requires. Yum is trying to
            solve this by installing an older version of systemd-libs of the
            different architecture. If you exclude the bad architecture
            yum will tell you what the root cause is (which package
            requires what). You can try redoing the upgrade with
            --exclude systemd-libs.otherarch ... this should give you an error
            message showing the root cause of the problem.

         2. You have multiple architectures of systemd-libs installed, but
            yum can only see an upgrade for one of those architectures.
            If you don't want/need both architectures anymore then you
            can remove the one with the missing update and everything
            will work.

         3. You have duplicate versions of systemd-libs installed already.
            You can use "yum check" to get yum show these errors.

       ...you can also use --setopt=protected_multilib=false to remove
       this checking, however this is almost never the correct thing to
       do as something else is very likely to go wrong (often causing
       much more problems).

       Protected multilib versions: systemd-libs-219-42.el7_4.1.i686 != systemd-libs-219-30.el7_3.9.x86_64
Error: Protected multilib versions: audit-libs-2.7.6-3.el7.i686 != audit-libs-2.6.5-3.el7_3.1.x86_64
Error: Protected multilib versions: glibc-2.17-196.el7.i686 != glibc-2.17-157.el7_3.5.x86_64
Error: Protected multilib versions: libgcrypt-1.5.3-14.el7.i686 != libgcrypt-1.5.3-13.el7_3.1.x86_64
Error: Protected multilib versions: elfutils-libs-0.168-8.el7.i686 != elfutils-libs-0.166-2.el7.x86_64
Error: Protected multilib versions: libstdc++-4.8.5-16.el7.i686 != libstdc++-4.8.5-11.el7.x86_64
Error: Protected multilib versions: pcre-8.32-17.el7.i686 != pcre-8.32-15.el7_2.1.x86_64
Error: Protected multilib versions: libgcc-4.8.5-16.el7.i686 != libgcc-4.8.5-11.el7.x86_64
Error: Protected multilib versions: libselinux-2.5-11.el7.i686 != libselinux-2.5-6.el7.x86_64
Error: Protected multilib versions: elfutils-libelf-0.168-8.el7.i686 != elfutils-libelf-0.166-2.el7.x86_64
Error: Protected multilib versions: libcap-2.22-9.el7.i686 != libcap-2.22-8.el7.x86_64
Error: Protected multilib versions: nss-softokn-freebl-3.28.3-8.el7_4.i686 != nss-softokn-freebl-3.16.2.3-14.4.el7.x86_64
Error: Protected multilib versions: libdb-5.3.21-20.el7.i686 != libdb-5.3.21-19.el7.x86_64

User avatar
avij
Forum Moderator
Posts: 2579
Joined: 2010/12/01 19:25:52
Location: Helsinki, Finland
Contact:

Re: yum update error

Post by avij » 2017/10/06 18:38:52

That looks more like you had installed 7.3.1611.. But it's alright, it can be updated to 7.4.1708 just fine.

Please see https://wiki.centos.org/Manuals/ReleaseNotes/CentOS7 and search for "rdma".

Post Reply