I am facing the reposity conflict

Issues related to applications and software problems
Post Reply
eric2kwok
Posts: 11
Joined: 2015/10/23 16:16:04

I am facing the reposity conflict

Post by eric2kwok » 2018/03/01 19:11:57

Loaded plugins: fastestmirror, refresh-packagekit, security
Setting up Update Process
Loading mirror speeds from cached hostfile
* base: mirror.sunnyvision.com
* elrepo: mirrors.thzhost.com
* elrepo-testing: mirrors.thzhost.com
* epel: mirror.ehost.vn
* extras: mirror.sunnyvision.com
* nux-dextop: li.nux.ro
* remi-safe: mirrors.thzhost.com
* updates: mirror.sunnyvision.com
Resolving Dependencies
--> Running transaction check
---> Package celt.i686 0:0.8.0-1.el6 will be updated
--> Processing Dependency: libcelt0.so.1 for package: ffmpeg-libs-0.10.16-1.el6.i686
---> Package celt.i686 0:0.11.1-3.el6.nux will be an update
--> Running transaction check
---> Package ffmpeg-libs.i686 0:0.10.16-1.el6 will be updated
--> Processing Dependency: libavcodec.so.53 for package: libquicktime-1.2.4-1.el6.i686
--> Processing Dependency: libavcodec.so.53 for package: vlc-core-2.0.10-3.el6.i686
--> Processing Dependency: libavcodec.so.53(LIBAVCODEC_53) for package: libquicktime-1.2.4-1.el6.i686
--> Processing Dependency: libavcodec.so.53(LIBAVCODEC_53) for package: vlc-core-2.0.10-3.el6.i686
--> Processing Dependency: libavformat.so.53 for package: vlc-core-2.0.10-3.el6.i686
--> Processing Dependency: libavformat.so.53(LIBAVFORMAT_53) for package: vlc-core-2.0.10-3.el6.i686
--> Processing Dependency: libavutil.so.51 for package: vlc-core-2.0.10-3.el6.i686
--> Processing Dependency: libavutil.so.51(LIBAVUTIL_51) for package: vlc-core-2.0.10-3.el6.i686
--> Processing Dependency: libpostproc.so.52 for package: vlc-core-2.0.10-3.el6.i686
--> Processing Dependency: libpostproc.so.52(LIBPOSTPROC_52) for package: vlc-core-2.0.10-3.el6.i686
--> Processing Dependency: libswscale.so.2 for package: libquicktime-1.2.4-1.el6.i686
--> Processing Dependency: libswscale.so.2 for package: vlc-core-2.0.10-3.el6.i686
--> Processing Dependency: libswscale.so.2(LIBSWSCALE_2) for package: libquicktime-1.2.4-1.el6.i686
--> Processing Dependency: libswscale.so.2(LIBSWSCALE_2) for package: vlc-core-2.0.10-3.el6.i686
---> Package ffmpeg-libs.i686 0:2.6.8-3.el6.nux will be an update
--> Processing Dependency: libx265.so.79 for package: ffmpeg-libs-2.6.8-3.el6.nux.i686
--> Processing Dependency: libx264.so.142 for package: ffmpeg-libs-2.6.8-3.el6.nux.i686
--> Processing Dependency: libsoxr.so.0 for package: ffmpeg-libs-2.6.8-3.el6.nux.i686
--> Processing Dependency: libfaac.so.0 for package: ffmpeg-libs-2.6.8-3.el6.nux.i686
--> Running transaction check
---> Package faac.i686 0:1.28-2.el6.nux will be installed
--> Processing Dependency: libmp4v2.so.0 for package: faac-1.28-2.el6.nux.i686
---> Package libquicktime.i686 0:1.2.4-1.el6 will be updated
---> Package libquicktime.i686 0:1.2.4-19.el6.nux will be an update
---> Package soxr.i686 0:0.1.1-3.el6.nux will be installed
---> Package vlc-core.i686 0:2.0.10-3.el6 will be updated
--> Processing Dependency: libvlccore.so.5 for package: vlc-2.0.10-3.el6.i686
--> Processing Dependency: vlc-core(x86-32) = 2.0.10-3.el6 for package: vlc-2.0.10-3.el6.i686
---> Package vlc-core.i686 0:2.1.6-2.el6.nux will be an update
--> Processing Dependency: live555date(x86-32) = 2012.01.25 for package: vlc-core-2.1.6-2.el6.nux.i686
--> Processing Dependency: libfreerdp-utils.so.1.0 for package: vlc-core-2.1.6-2.el6.nux.i686
--> Processing Dependency: libfreerdp-rail.so.1.0 for package: vlc-core-2.1.6-2.el6.nux.i686
--> Processing Dependency: libfreerdp-kbd.so.1.0 for package: vlc-core-2.1.6-2.el6.nux.i686
--> Processing Dependency: libfreerdp-gdi.so.1.0 for package: vlc-core-2.1.6-2.el6.nux.i686
--> Processing Dependency: libfreerdp-core.so.1.0 for package: vlc-core-2.1.6-2.el6.nux.i686
--> Processing Dependency: libfreerdp-codec.so.1.0 for package: vlc-core-2.1.6-2.el6.nux.i686
--> Processing Dependency: libfreerdp-channels.so.1.0 for package: vlc-core-2.1.6-2.el6.nux.i686
--> Processing Dependency: libdvbpsi.so.9 for package: vlc-core-2.1.6-2.el6.nux.i686
--> Processing Dependency: libchromaprint.so.0 for package: vlc-core-2.1.6-2.el6.nux.i686
---> Package x264-libs.i686 0:0.120-5.20120303.el6 will be updated
--> Processing Dependency: libx264.so.120 for package: ffmpeg-compat-0.6.7-1.el6.i686
--> Processing Dependency: libx264.so.120 for package: gstreamer-plugins-ugly-0.10.18-4.el6.i686
---> Package x264-libs.i686 0:0.142-7.20140728gitaf8e768.el6.nux will be an update
---> Package x265-libs.i686 0:1.9-1.el6.nux will be installed
--> Running transaction check
---> Package ffmpeg-compat.i686 0:0.6.7-1.el6 will be updated
---> Package ffmpeg-compat.i686 0:0.6.7-9.el6.nux will be an update
--> Processing Dependency: libjack.so.0 for package: ffmpeg-compat-0.6.7-9.el6.nux.i686
---> Package freerdp-libs.i686 0:1.0.2-5.el6 will be installed
---> Package libchromaprint.i686 0:1.0-1.el6 will be installed
--> Processing Dependency: libfftw3.so.3 for package: libchromaprint-1.0-1.el6.i686
---> Package libdvbpsi.i686 0:1.2.0-3.el6 will be installed
---> Package libmp4v2.i686 0:1.5.0.1-10.el6 will be installed
---> Package vlc.i686 0:2.0.10-3.el6 will be updated
---> Package vlc.i686 0:2.1.6-2.el6.nux will be an update
---> Package vlc-core.i686 0:2.1.6-2.el6.nux will be an update
--> Processing Dependency: live555date(x86-32) = 2012.01.25 for package: vlc-core-2.1.6-2.el6.nux.i686
---> Package x264-libs.i686 0:0.120-5.20120303.el6 will be updated
--> Processing Dependency: libx264.so.120 for package: gstreamer-plugins-ugly-0.10.18-4.el6.i686
--> Running transaction check
---> Package fftw.i686 0:3.2.1-3.1.el6 will be installed
---> Package jack-audio-connection-kit.i686 0:0.121.3-1.el6 will be installed
---> Package vlc-core.i686 0:2.1.6-2.el6.nux will be an update
--> Processing Dependency: live555date(x86-32) = 2012.01.25 for package: vlc-core-2.1.6-2.el6.nux.i686
---> Package x264-libs.i686 0:0.120-5.20120303.el6 will be updated
--> Processing Dependency: libx264.so.120 for package: gstreamer-plugins-ugly-0.10.18-4.el6.i686
--> Finished Dependency Resolution
Error: Package: vlc-core-2.1.6-2.el6.nux.i686 (nux-dextop)
Requires: live555date(x86-32) = 2012.01.25
Installed: live555-0-0.37.2012.04.27.el6.i686 (@rpmfusion-free-updates)
live555date(x86-32) = 2012.04.27
Available: live555-0-0.34.2012.01.25.el6.nux.i686 (nux-dextop)
live555date(x86-32) = 2012.01.25
Available: live555-0-0.27.2010.04.09.el6.nux.i686 (nux-dextop)
Not found
Error: Package: gstreamer-plugins-ugly-0.10.18-4.el6.i686 (@rpmfusion-free-updates)
Requires: libx264.so.120
Removing: x264-libs-0.120-5.20120303.el6.i686 (@rpmfusion-free-updates)
libx264.so.120
Updated By: x264-libs-0.142-7.20140728gitaf8e768.el6.nux.i686 (nux-dextop)
Not found
Available: x264-libs-0.120-5.20120303.el6.nux.i686 (nux-dextop)
libx264.so.120
Available: x264-libs-0.120-6.20120303.el6.nux.i686 (nux-dextop)
libx264.so.120
Available: x264-libs-0.0.0-0.28.20100706gitd058f37.el6.nux.i686 (nux-dextop)
Not found
Available: x264-libs-0.0.0-0.31.20110811.el6.nux.i686 (nux-dextop)
Not found
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

If any solution can be provided would be grateful, Thanks in advance!

owl102
Posts: 315
Joined: 2014/06/10 19:13:41

Re: I am facing the reposity conflict

Post by owl102 » 2018/03/01 19:15:17

Use either rpmfusion or nux-desktop, not both.

User avatar
TrevorH
Forum Moderator
Posts: 23690
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: I am facing the reposity conflict

Post by TrevorH » 2018/03/02 00:13:20

You don't seem to have rpmfusion enabled at the moment but you do have packages from it that are already installed and nux-dextop supplies those same packages, possibly by different names. You'll need to remove the conflicting ones first. If you do that with 'yum remove' then be aware that it will then go ahead and expand the selection to include any packages that are dependent on the ones you're about to remove so make sure you check the list carefully before you reply Y.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

eric2kwok
Posts: 11
Joined: 2015/10/23 16:16:04

Re: I am facing the reposity conflict

Post by eric2kwok » 2018/03/02 02:46:28

So, what should I do right now? I tried to use this 'yum-config-manager --disable nux-dextop or rpmfusion' both command to disable nux-dextop or rpmfusion repos either one. But seems doesn't work. Still keep the same. No change...........

User avatar
TrevorH
Forum Moderator
Posts: 23690
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: I am facing the reposity conflict

Post by TrevorH » 2018/03/02 07:12:11

Read my post?
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

aegersz
Posts: 82
Joined: 2016/04/04 07:42:58

Re: I am facing the reposity conflict

Post by aegersz » 2018/03/06 06:36:30

@TrevorH: is a funny man who solves Yellowdog Updater Modifier and/or Redhat Package Manager conflicts all over the world [ :geek: ]

Post Reply