Dell 5577 with centos6.9: CPU i7 7700hq, Nvida Gforce1050: Monitor unkown, and Can't adjust brightness and Resolution

Issues related to hardware problems
Post Reply
fivedai
Posts: 13
Joined: 2018/03/05 08:54:13

Dell 5577 with centos6.9: CPU i7 7700hq, Nvida Gforce1050: Monitor unkown, and Can't adjust brightness and Resolution

Post by fivedai » 2018/04/09 10:00:57

1, My laptop is Dell 5577, CPU is i7 7700hq, intel GPU Intel® HD Graphics 630 + Nvidia Geforce 1050
daixw@localdai 15:50 434> nvidia-detect -v
Probing for supported NVIDIA devices...
[10de:1c8d] NVIDIA Corporation GP107M [GeForce GTX 1050 Mobile]
This device requires the current 390.48 NVIDIA driver kmod-nvidia
[8086:591b] Intel Corporation Device 591b
An Intel display controller was also detected
2, After install I can't adjust screen resolution and brightness, and can't adjust brightness in Power Manegement. Pls reffer the picture below:

Monitor unkown: Resolution fixed to 1920X1080.
Refresh rate 0Hz



after I add the Power Manager Brightness Applet 2.28.3 to panel, it can't adjust brightness, and shows: cannot get laptop panel brightness.


In Power Managerment preferences, no tool-bar can adjust brightness.

3, So in ordter to adjust the brightens, I tried many ways, but all failed.

3.1 using xgamma → no effect
daixw@localdai 16:49 446> xgamma -gamma 0.5
-> Red 1.000, Green 1.000, Blue 1.000
<- Red 0.500, Green 0.500, Blue 0.500
3.2 Fn+F11 or Fn+F12 no effect.
3.3 setterm -background 0.2 → no effect.
3.4 change file brightness → failed due to no exist file.
daixw@localdai 16:56 451> echo 5 > /sys/class/backlight/intel_backlight/brightness
bash: /sys/class/backlight/intel_backlight/brightness: No such file or directory
3.4 set_pci → failed
daixw@localdai 17:00 455> setpci -s 00:02.0 F4.B=FF
pcilib: Cannot open /sys/bus/pci/devices/0000:00:02.0/config

3.5, my install files has no /etc/X11/xorg.conf
daixw@localdai 17:02 461> sudo ls /etc/X11/xorg.conf
ls: cannot access /etc/X11/xorg.conf: No such file or directory

4, So the default inter and nouveau has problem to adjust brightness and resolution. So I decice to install the Nvidia driver .
Simuliar to the way as link below.
https://blog.csdn.net/u013378306/articl ... s/69229919
4.1 blacklist nouveau
4.2 initramfs image (rebuild the image)
4.3 reboot and run: lsmod | grep nouveau get nothing.
4.4 nvidia-detect -v
daixw@localdai 17:13 464> nvidia-detect -v
Probing for supported NVIDIA devices...
[10de:1c8d] NVIDIA Corporation GP107M [GeForce GTX 1050 Mobile]
This device requires the current 390.48 NVIDIA driver kmod-nvidia
[8086:591b] Intel Corporation Device 591b
An Intel display controller was also detected
4.5 yum -y install kmod-nvidia
4.6 reboot run nvidia setting panel: it show no xorg.conf file, so I run nvidia-xconfig as root to gnerate it.
daixw@localdai 17:19 466> sudo nvidia-xconfig

WARNING: Unable to locate/open X configuration file.

New X configuration file written to '/etc/X11/xorg.conf'

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 390.48 (buildmeister@swio-display-x86-rhel47-07) Thu Mar 22 01:07:32 PDT 2018

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
FontPath "/usr/share/fonts/default/Type1"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from data in "/etc/sysconfig/keyboard"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbLayout" "us"
Option "XkbModel" "pc105"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection


4.8 Reboot, the booting blocks, So I have to use Alter+ F2 to use command line, and startx
it shows that (EE) no screns found(EE). I also chang the grub.conf to remove nomodset, it still doesn't work.


4.9 after remove the xorg.conf I can startx ok.
4.10. after enable nouveau, each reboot, it shows unknown hardware version, and nouveau unknown chip-set (137000a1) as show in picture below.

4.11 Can't use external HDMI Screen and Laptop Screen at the same time.
4.11.1 If no external HDMI connected during power up, the Dell laptop screen is work ok, then I insert the external screen to the HDMI, the external screen doesn't work, it's black.
4.11.2 If external HDMI connected before power up, the external Screen works ok , but the Dell laptop screen is black. If I disconnect HDMI, the laptop screen is still black. At this time the Centos can't switch to Laptop screen unless reboot with HDMI unconnected.

5. Conclusion

I think the centos 6.9 can't detect Dell laptop 5577 monitor, it's not due to the Nvidia driver.
Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option "DPMS"
EndSection

can anyboy help me out the adjust brightness and Switch ok between externl screen and internal screen .
Attachments
power_setting.png
power_setting.png (33.46 KiB) Viewed 922 times
cannot_get_laptop_panel.png
cannot_get_laptop_panel.png (73.77 KiB) Viewed 922 times
Monitor_unkown.png
Monitor_unkown.png (47.86 KiB) Viewed 922 times
Last edited by fivedai on 2018/04/10 10:17:11, edited 3 times in total.

fivedai
Posts: 13
Joined: 2018/03/05 08:54:13

Re: Monitor unkown, and Can't adjust brightness and brightness

Post by fivedai » 2018/04/10 09:42:48

attach below is the Xorg.0.log file if i remove /etc/X11/xorg.conf
[ 229.356]
X.Org X Server 1.17.4
Release Date: 2015-10-28
[ 229.406] X Protocol Version 11, Revision 0
[ 229.423] Build Operating System: x86_64_01 3.10.0-693.2.2.el7.x86_64
[ 229.441] Current Operating System: Linux localdai 2.6.32-696.23.1.el6.x86_64 #1 SMP Tue Mar 13 22:44:18 UTC 2018 x86_64
[ 229.441] Kernel command line: ro root=/dev/mapper/vg_localdai-V_root rd_NO_LUKS LANG=en_US.UTF-8 rd_LVM_LV=vg_localdai/LogVol02 rd_NO_MD SYSFONT=latarcyrheb-sun16 crashkernel=128M rd_LVM_LV=vg_localdai/V_root KEYBOARDTYPE=pc KEYTABLE=us rd_NO_DM quiet acpi_backlight=vendor acpi_osi=linux
[ 229.504] Build Date: 26 January 2018 07:41:19AM
[ 229.525] Build ID: xorg-x11-server 1.17.4-16.el6.centos.1
[ 229.547] Current version of pixman: 0.32.8
[ 229.591] Before reporting problems, check http://wiki.centos.org/Documentation
to make sure that you have the latest version.
[ 229.591] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 229.683] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Apr 9 19:40:31 2018
[ 229.819] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 229.819] (==) No Layout section. Using the first Screen section.
[ 229.819] (==) No screen section available. Using defaults.
[ 229.819] (**) |-->Screen "Default Screen Section" (0)
[ 229.819] (**) | |-->Monitor "<default monitor>"
[ 229.819] (==) No monitor specified for screen "Default Screen Section".
Using a default monitor configuration.
[ 229.819] (==) Automatically adding devices
[ 229.819] (==) Automatically enabling devices
[ 229.819] (==) Not automatically adding GPU devices
[ 229.819] (==) Max clients allowed: 256, resource mask: 0x1fffff
[ 229.819] (==) FontPath set to:
catalogue:/etc/X11/fontpath.d,
built-ins
[ 229.819] (==) ModulePath set to "/usr/lib64/xorg/modules"
[ 229.819] (II) The server relies on HAL to provide the list of input devices.
If no devices become available, reconfigure HAL or disable AutoAddDevices.
[ 229.819] (II) Loader magic: 0x7f8c13e5b020
[ 229.819] (II) Module ABI versions:
[ 229.819] X.Org ANSI C Emulation: 0.4
[ 229.819] X.Org Video Driver: 19.0
[ 229.819] X.Org XInput driver : 21.0
[ 229.819] X.Org Server Extension : 9.0
[ 229.822] (--) PCI:*(0:0:2:0) 8086:591b:1028:07e1 rev 4, Mem @ 0xdd000000/16777216, 0xb0000000/268435456, I/O @ 0x0000f000/64, BIOS @ 0x????????/131072
[ 229.823] (--) PCI: (0:1:0:0) 10de:1c8d:1028:07e1 rev 161, Mem @ 0xde000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288
[ 229.823] (II) LoadModule: "glx"
[ 229.823] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[ 229.824] (II) Module glx: vendor="X.Org Foundation"
[ 229.824] compiled for 1.17.4, module version = 1.0.0
[ 229.824] ABI class: X.Org Server Extension, version 9.0
[ 229.824] (==) AIGLX enabled
[ 229.824] (==) Matched intel as autoconfigured driver 0
[ 229.824] (==) Matched modesetting as autoconfigured driver 1
[ 229.824] (==) Matched fbdev as autoconfigured driver 2
[ 229.824] (==) Matched vesa as autoconfigured driver 3
[ 229.824] (==) Assigned the driver to the xf86ConfigLayout
[ 229.824] (II) LoadModule: "intel"
[ 229.824] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
[ 229.866] (II) Module intel: vendor="X.Org Foundation"
[ 229.866] compiled for 1.17.4, module version = 2.99.917
[ 229.866] Module class: X.Org Video Driver
[ 229.866] ABI class: X.Org Video Driver, version 19.0
[ 229.866] (II) LoadModule: "modesetting"
[ 229.866] (II) Loading /usr/lib64/xorg/modules/drivers/modesetting_drv.so
[ 229.891] (II) Module modesetting: vendor="X.Org Foundation"
[ 229.891] compiled for 1.17.4, module version = 1.17.4
[ 229.891] Module class: X.Org Video Driver
[ 229.891] ABI class: X.Org Video Driver, version 19.0
[ 229.891] (II) LoadModule: "fbdev"
[ 229.891] (II) Loading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
[ 229.901] (II) Module fbdev: vendor="X.Org Foundation"
[ 229.901] compiled for 1.17.4, module version = 0.4.3
[ 229.901] Module class: X.Org Video Driver
[ 229.901] ABI class: X.Org Video Driver, version 19.0
[ 229.901] (II) LoadModule: "vesa"
[ 229.901] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
[ 229.909] (II) Module vesa: vendor="X.Org Foundation"
[ 229.909] compiled for 1.17.4, module version = 2.3.4
[ 229.909] Module class: X.Org Video Driver
[ 229.909] ABI class: X.Org Video Driver, version 19.0
[ 229.909] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[ 229.910] (II) intel: Driver for Intel(R) HD Graphics: 2000-6000
[ 229.910] (II) intel: Driver for Intel(R) Iris(TM) Graphics: 5100, 6100
[ 229.910] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics: 5200, 6200, P6300
[ 229.910] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[ 229.910] (II) FBDEV: driver for framebuffer: fbdev
[ 229.910] (II) VESA: driver for VESA chipsets: vesa
[ 229.910] (--) using VT number 7

[ 230.294] (EE) open /dev/dri/card0: No such file or directory
[ 230.294] (WW) Falling back to old probe method for modesetting
[ 230.294] (EE) open /dev/dri/card0: No such file or directory
[ 230.294] (II) Loading sub module "fbdevhw"
[ 230.294] (II) LoadModule: "fbdevhw"
[ 230.294] (II) Loading /usr/lib64/xorg/modules/libfbdevhw.so
[ 230.311] (II) Module fbdevhw: vendor="X.Org Foundation"
[ 230.311] compiled for 1.17.4, module version = 0.0.2
[ 230.311] ABI class: X.Org Video Driver, version 19.0
[ 230.311] (EE) Unable to find a valid framebuffer device
[ 230.311] (WW) Falling back to old probe method for fbdev
[ 230.311] (II) Loading sub module "fbdevhw"
[ 230.311] (II) LoadModule: "fbdevhw"
[ 230.311] (II) Loading /usr/lib64/xorg/modules/libfbdevhw.so
[ 230.311] (II) Module fbdevhw: vendor="X.Org Foundation"
[ 230.311] compiled for 1.17.4, module version = 0.0.2
[ 230.311] ABI class: X.Org Video Driver, version 19.0
[ 230.311] (II) FBDEV(2): using default device
[ 230.311] (EE) Screen 0 deleted because of no matching config section.
[ 230.311] (II) UnloadModule: "modesetting"
[ 230.311] (EE) Screen 0 deleted because of no matching config section.
[ 230.311] (II) UnloadModule: "fbdev"
[ 230.311] (II) UnloadSubModule: "fbdevhw"
[ 230.311] (II) FBDEV(0): Creating default Display subsection in Screen section
"Default Screen Section" for depth/fbbpp 24/32
[ 230.311] (==) FBDEV(0): Depth 24, (==) framebuffer bpp 32
[ 230.311] (==) FBDEV(0): RGB weight 888
[ 230.311] (==) FBDEV(0): Default visual is TrueColor
[ 230.311] (==) FBDEV(0): Using gamma correction (1.0, 1.0, 1.0)
[ 230.311] (II) FBDEV(0): hardware: simple (video memory: 8100kB)
[ 230.311] (II) FBDEV(0): checking modes against framebuffer device...
[ 230.311] (II) FBDEV(0): checking modes against monitor...
[ 230.311] (--) FBDEV(0): Virtual size is 1920x1080 (pitch 1920)
[ 230.311] (**) FBDEV(0): Built-in mode "current"
[ 230.311] (==) FBDEV(0): DPI set to (96, 96)
[ 230.311] (II) Loading sub module "fb"
[ 230.311] (II) LoadModule: "fb"
[ 230.311] (II) Loading /usr/lib64/xorg/modules/libfb.so
[ 230.327] (II) Module fb: vendor="X.Org Foundation"
[ 230.327] compiled for 1.17.4, module version = 1.0.0
[ 230.327] ABI class: X.Org ANSI C Emulation, version 0.4
[ 230.327] (**) FBDEV(0): using shadow framebuffer
[ 230.327] (II) Loading sub module "shadow"
[ 230.327] (II) LoadModule: "shadow"
[ 230.327] (II) Loading /usr/lib64/xorg/modules/libshadow.so
[ 230.342] (II) Module shadow: vendor="X.Org Foundation"
[ 230.342] compiled for 1.17.4, module version = 1.1.0
[ 230.342] ABI class: X.Org ANSI C Emulation, version 0.4
[ 230.342] (II) Loading sub module "vbe"
[ 230.342] (II) LoadModule: "vbe"
[ 230.342] (II) Loading /usr/lib64/xorg/modules/libvbe.so
[ 230.342] (II) Module vbe: vendor="X.Org Foundation"
[ 230.342] compiled for 1.17.4, module version = 1.1.0
[ 230.342] ABI class: X.Org Video Driver, version 19.0
[ 230.342] (II) Loading sub module "int10"
[ 230.342] (II) LoadModule: "int10"
[ 230.366] (II) Loading /usr/lib64/xorg/modules/libint10.so
[ 230.385] (II) Module int10: vendor="X.Org Foundation"
[ 230.385] compiled for 1.17.4, module version = 1.0.0
[ 230.385] ABI class: X.Org Video Driver, version 19.0
[ 230.385] (II) VESA(1): initializing int10
[ 230.385] (EE) VESA(1): V_BIOS address 0x0 out of range
[ 230.385] (II) UnloadModule: "vesa"
[ 230.385] (II) UnloadSubModule: "int10"
[ 230.385] (II) Unloading int10
[ 230.385] (II) UnloadSubModule: "vbe"
[ 230.385] (II) Unloading vbe
[ 230.385] (==) Depth 24 pixmap format is 32 bpp
[ 230.386] (EE) FBDEV(0): FBIOBLANK: Invalid argument
[ 230.426] (==) FBDEV(0): Backing store enabled
[ 230.427] (==) FBDEV(0): DPMS enabled
[ 230.428] (==) RandR enabled
[ 230.432] (II) SELinux: Disabled by boolean
[ 230.433] (II) AIGLX: Screen 0 is not DRI2 capable
[ 230.433] (EE) AIGLX: reverting to software rendering
[ 231.439] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
[ 231.439] (II) AIGLX: Loaded and initialized swrast
[ 231.439] (II) GLX: Initialized DRISWRAST GL provider for screen 0
[ 232.045] (II) config/hal: Adding input device Logitech Lenovo USB Optical Mouse
[ 232.045] (II) LoadModule: "evdev"
[ 232.045] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
[ 232.062] (II) Module evdev: vendor="X.Org Foundation"
[ 232.062] compiled for 1.17.4, module version = 2.9.2
[ 232.062] Module class: X.Org XInput Driver
[ 232.062] ABI class: X.Org XInput driver, version 21.0
[ 232.063] (II) Using input driver 'evdev' for 'Logitech Lenovo USB Optical Mouse'
[ 232.063] (**) Logitech Lenovo USB Optical Mouse: always reports core events
[ 232.063] (**) evdev: Logitech Lenovo USB Optical Mouse: Device: "/dev/input/event9"
[ 232.071] (--) evdev: Logitech Lenovo USB Optical Mouse: Vendor 0x17ef Product 0x6019
[ 232.071] (--) evdev: Logitech Lenovo USB Optical Mouse: Found 3 mouse buttons
[ 232.071] (--) evdev: Logitech Lenovo USB Optical Mouse: Found scroll wheel(s)
[ 232.071] (--) evdev: Logitech Lenovo USB Optical Mouse: Found relative axes
[ 232.071] (--) evdev: Logitech Lenovo USB Optical Mouse: Found x and y relative axes
[ 232.071] (II) evdev: Logitech Lenovo USB Optical Mouse: Configuring as mouse
[ 232.071] (II) evdev: Logitech Lenovo USB Optical Mouse: Adding scrollwheel support
[ 232.071] (**) evdev: Logitech Lenovo USB Optical Mouse: YAxisMapping: buttons 4 and 5
[ 232.071] (**) evdev: Logitech Lenovo USB Optical Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[ 232.071] (**) Option "config_info" "hal:/org/freedesktop/Hal/devices/usb_device_17ef_6019_noserial_if0_logicaldev_input"
[ 232.071] (II) XINPUT: Adding extended input device "Logitech Lenovo USB Optical Mouse" (type: MOUSE, id 6)
[ 232.071] (II) evdev: Logitech Lenovo USB Optical Mouse: initialized for relative axes.
[ 232.071] (**) Logitech Lenovo USB Optical Mouse: (accel) keeping acceleration scheme 1
[ 232.071] (**) Logitech Lenovo USB Optical Mouse: (accel) acceleration profile 0
[ 232.071] (**) Logitech Lenovo USB Optical Mouse: (accel) acceleration factor: 2.000
[ 232.071] (**) Logitech Lenovo USB Optical Mouse: (accel) acceleration threshold: 4
[ 232.075] (II) config/hal: Adding input device AT Translated Set 2 keyboard
[ 232.075] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
[ 232.075] (**) AT Translated Set 2 keyboard: always reports core events
[ 232.075] (**) evdev: AT Translated Set 2 keyboard: Device: "/dev/input/event5"
[ 232.087] (--) evdev: AT Translated Set 2 keyboard: Vendor 0x1 Product 0x1
[ 232.087] (--) evdev: AT Translated Set 2 keyboard: Found keys
[ 232.087] (II) evdev: AT Translated Set 2 keyboard: Configuring as keyboard
[ 232.087] (**) Option "config_info" "hal:/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port_logicaldev_input"
[ 232.087] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 7)
[ 232.087] (**) Option "xkb_rules" "evdev"
[ 232.087] (**) Option "xkb_model" "pc105+inet"
[ 232.087] (**) Option "xkb_layout" "us"
[ 232.087] (WW) Option "xkb_variant" requires a string value
[ 232.087] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[ 232.115] (II) config/hal: Adding input device PS/2 Elantech Touchpad
[ 232.115] (II) Using input driver 'evdev' for 'PS/2 Elantech Touchpad'
[ 232.115] (**) PS/2 Elantech Touchpad: always reports core events
[ 232.115] (**) evdev: PS/2 Elantech Touchpad: Device: "/dev/input/event6"
[ 232.124] (--) evdev: PS/2 Elantech Touchpad: Vendor 0x2 Product 0x1
[ 232.124] (--) evdev: PS/2 Elantech Touchpad: Found 3 mouse buttons
[ 232.124] (--) evdev: PS/2 Elantech Touchpad: Found relative axes
[ 232.124] (--) evdev: PS/2 Elantech Touchpad: Found x and y relative axes
[ 232.124] (II) evdev: PS/2 Elantech Touchpad: Configuring as mouse
[ 232.124] (**) evdev: PS/2 Elantech Touchpad: YAxisMapping: buttons 4 and 5
[ 232.124] (**) evdev: PS/2 Elantech Touchpad: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[ 232.124] (**) Option "config_info" "hal:/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX_port_logicaldev_input"
[ 232.124] (II) XINPUT: Adding extended input device "PS/2 Elantech Touchpad" (type: MOUSE, id 8)
[ 232.125] (II) evdev: PS/2 Elantech Touchpad: initialized for relative axes.
[ 232.125] (**) PS/2 Elantech Touchpad: (accel) keeping acceleration scheme 1
[ 232.125] (**) PS/2 Elantech Touchpad: (accel) acceleration profile 0
[ 232.125] (**) PS/2 Elantech Touchpad: (accel) acceleration factor: 2.000
[ 232.125] (**) PS/2 Elantech Touchpad: (accel) acceleration threshold: 4
[ 232.137] (II) config/hal: Adding input device HDA Intel Front Headphone
[ 232.137] (II) Using input driver 'evdev' for 'HDA Intel Front Headphone'
[ 232.137] (**) HDA Intel Front Headphone: always reports core events
[ 232.137] (**) evdev: HDA Intel Front Headphone: Device: "/dev/input/event10"
[ 232.144] (--) evdev: HDA Intel Front Headphone: Vendor 0 Product 0
[ 232.144] (WW) evdev: HDA Intel Front Headphone: Don't know how to use device
[ 232.152] (EE) PreInit returned 8 for "HDA Intel Front Headphone"
[ 232.152] (II) UnloadModule: "evdev"
[ 232.152] (EE) config/hal: NewInputDeviceRequest failed (8)
[ 232.161] (II) config/hal: Adding input device Lid Switch
[ 232.161] (II) Using input driver 'evdev' for 'Lid Switch'
[ 232.161] (**) Lid Switch: always reports core events
[ 232.161] (**) evdev: Lid Switch: Device: "/dev/input/event2"
[ 232.168] (--) evdev: Lid Switch: Vendor 0 Product 0x5
[ 232.168] (II) Lid Switch: Adding for lid switch
[ 232.168] (WW) evdev: Lid Switch: Don't know how to use device
[ 232.168] (**) Option "config_info" "hal:/org/freedesktop/Hal/devices/computer_logicaldev_input_3"
[ 232.168] (II) XINPUT: Adding extended input device "Lid Switch" (type: UNKNOWN, id 9)
[ 232.184] (II) config/hal: Adding input device Integrated_Webcam_HD
[ 232.184] (II) Using input driver 'evdev' for 'Integrated_Webcam_HD'
[ 232.184] (**) Integrated_Webcam_HD: always reports core events
[ 232.184] (**) evdev: Integrated_Webcam_HD: Device: "/dev/input/event12"
[ 232.188] (--) evdev: Integrated_Webcam_HD: Vendor 0x1bcf Product 0x2b8a
[ 232.188] (--) evdev: Integrated_Webcam_HD: Found keys
[ 232.188] (II) evdev: Integrated_Webcam_HD: Configuring as keyboard
[ 232.188] (**) Option "config_info" "hal:/org/freedesktop/Hal/devices/usb_device_1bcf_2b8a_noserial_if0_logicaldev_input"
[ 232.188] (II) XINPUT: Adding extended input device "Integrated_Webcam_HD" (type: KEYBOARD, id 10)
[ 232.188] (**) Option "xkb_rules" "evdev"
[ 232.188] (**) Option "xkb_model" "pc105+inet"
[ 232.188] (**) Option "xkb_layout" "us"
[ 232.188] (WW) Option "xkb_variant" requires a string value
[ 232.188] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[ 232.205] (II) config/hal: Adding input device SIGMACHIP USB Keyboard
[ 232.205] (II) Using input driver 'evdev' for 'SIGMACHIP USB Keyboard'
[ 232.205] (**) SIGMACHIP USB Keyboard: always reports core events
[ 232.205] (**) evdev: SIGMACHIP USB Keyboard: Device: "/dev/input/event8"
[ 232.209] (--) evdev: SIGMACHIP USB Keyboard: Vendor 0x1c4f Product 0x2
[ 232.209] (--) evdev: SIGMACHIP USB Keyboard: Found 1 mouse buttons
[ 232.209] (--) evdev: SIGMACHIP USB Keyboard: Found scroll wheel(s)
[ 232.209] (--) evdev: SIGMACHIP USB Keyboard: Found relative axes
[ 232.209] (II) evdev: SIGMACHIP USB Keyboard: Forcing relative x/y axes to exist.
[ 232.209] (--) evdev: SIGMACHIP USB Keyboard: Found absolute axes
[ 232.209] (II) evdev: SIGMACHIP USB Keyboard: Forcing absolute x/y axes to exist.
[ 232.209] (--) evdev: SIGMACHIP USB Keyboard: Found keys
[ 232.209] (II) evdev: SIGMACHIP USB Keyboard: Configuring as mouse
[ 232.209] (II) evdev: SIGMACHIP USB Keyboard: Configuring as keyboard
[ 232.209] (II) evdev: SIGMACHIP USB Keyboard: Adding scrollwheel support
[ 232.209] (**) evdev: SIGMACHIP USB Keyboard: YAxisMapping: buttons 4 and 5
[ 232.209] (**) evdev: SIGMACHIP USB Keyboard: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[ 232.209] (**) Option "config_info" "hal:/org/freedesktop/Hal/devices/usb_device_1c4f_2_noserial_if1_logicaldev_input"
[ 232.209] (II) XINPUT: Adding extended input device "SIGMACHIP USB Keyboard" (type: KEYBOARD, id 11)
[ 232.209] (**) Option "xkb_rules" "evdev"
[ 232.209] (**) Option "xkb_model" "pc105+inet"
[ 232.209] (**) Option "xkb_layout" "us"
[ 232.209] (WW) Option "xkb_variant" requires a string value
[ 232.209] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[ 232.209] (II) evdev: SIGMACHIP USB Keyboard: initialized for relative axes.
[ 232.209] (WW) evdev: SIGMACHIP USB Keyboard: ignoring absolute axes.
[ 232.210] (**) SIGMACHIP USB Keyboard: (accel) keeping acceleration scheme 1
[ 232.210] (**) SIGMACHIP USB Keyboard: (accel) acceleration profile 0
[ 232.210] (**) SIGMACHIP USB Keyboard: (accel) acceleration factor: 2.000
[ 232.210] (**) SIGMACHIP USB Keyboard: (accel) acceleration threshold: 4
[ 232.226] (II) config/hal: Adding input device SIGMACHIP USB Keyboard
[ 232.226] (II) Using input driver 'evdev' for 'SIGMACHIP USB Keyboard'
[ 232.226] (**) SIGMACHIP USB Keyboard: always reports core events
[ 232.226] (**) evdev: SIGMACHIP USB Keyboard: Device: "/dev/input/event7"
[ 232.230] (--) evdev: SIGMACHIP USB Keyboard: Vendor 0x1c4f Product 0x2
[ 232.230] (--) evdev: SIGMACHIP USB Keyboard: Found keys
[ 232.230] (II) evdev: SIGMACHIP USB Keyboard: Configuring as keyboard
[ 232.230] (**) Option "config_info" "hal:/org/freedesktop/Hal/devices/usb_device_1c4f_2_noserial_if0_logicaldev_input"
[ 232.230] (II) XINPUT: Adding extended input device "SIGMACHIP USB Keyboard" (type: KEYBOARD, id 12)
[ 232.230] (**) Option "xkb_rules" "evdev"
[ 232.230] (**) Option "xkb_model" "pc105+inet"
[ 232.230] (**) Option "xkb_layout" "us"
[ 232.230] (WW) Option "xkb_variant" requires a string value
[ 232.230] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[ 232.242] (II) config/hal: Adding input device Sleep Button
[ 232.242] (II) Using input driver 'evdev' for 'Sleep Button'
[ 232.242] (**) Sleep Button: always reports core events
[ 232.242] (**) evdev: Sleep Button: Device: "/dev/input/event0"
[ 232.247] (--) evdev: Sleep Button: Vendor 0 Product 0x3
[ 232.247] (--) evdev: Sleep Button: Found keys
[ 232.247] (II) evdev: Sleep Button: Configuring as keyboard
[ 232.247] (**) Option "config_info" "hal:/org/freedesktop/Hal/devices/computer_logicaldev_input_1"
[ 232.247] (II) XINPUT: Adding extended input device "Sleep Button" (type: KEYBOARD, id 13)
[ 232.247] (**) Option "xkb_rules" "evdev"
[ 232.247] (**) Option "xkb_model" "pc105+inet"
[ 232.247] (**) Option "xkb_layout" "us"
[ 232.247] (WW) Option "xkb_variant" requires a string value
[ 232.247] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[ 232.259] (II) config/hal: Adding input device Power Button
[ 232.259] (II) Using input driver 'evdev' for 'Power Button'
[ 232.259] (**) Power Button: always reports core events
[ 232.259] (**) evdev: Power Button: Device: "/dev/input/event1"
[ 232.264] (--) evdev: Power Button: Vendor 0 Product 0x1
[ 232.264] (--) evdev: Power Button: Found keys
[ 232.264] (II) evdev: Power Button: Configuring as keyboard
[ 232.264] (**) Option "config_info" "hal:/org/freedesktop/Hal/devices/computer_logicaldev_input_0"
[ 232.264] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 14)
[ 232.264] (**) Option "xkb_rules" "evdev"
[ 232.264] (**) Option "xkb_model" "pc105+inet"
[ 232.264] (**) Option "xkb_layout" "us"
[ 232.264] (WW) Option "xkb_variant" requires a string value
[ 232.264] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[ 232.276] (II) config/hal: Adding input device Power Button
[ 232.276] (II) Using input driver 'evdev' for 'Power Button'
[ 232.276] (**) Power Button: always reports core events
[ 232.276] (**) evdev: Power Button: Device: "/dev/input/event3"
[ 232.282] (--) evdev: Power Button: Vendor 0 Product 0x1
[ 232.282] (--) evdev: Power Button: Found keys
[ 232.282] (II) evdev: Power Button: Configuring as keyboard
[ 232.282] (**) Option "config_info" "hal:/org/freedesktop/Hal/devices/computer_logicaldev_input"
[ 232.282] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 15)
[ 232.282] (**) Option "xkb_rules" "evdev"
[ 232.282] (**) Option "xkb_model" "pc105+inet"
[ 232.282] (**) Option "xkb_layout" "us"
[ 232.282] (WW) Option "xkb_variant" requires a string value
[ 232.282] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[ 232.292] (II) config/hal: Adding input device Macintosh mouse button emulation
[ 232.292] (II) Using input driver 'evdev' for 'Macintosh mouse button emulation'
[ 232.292] (**) Macintosh mouse button emulation: always reports core events
[ 232.292] (**) evdev: Macintosh mouse button emulation: Device: "/dev/input/event4"
[ 232.299] (--) evdev: Macintosh mouse button emulation: Vendor 0x1 Product 0x1
[ 232.299] (--) evdev: Macintosh mouse button emulation: Found 3 mouse buttons
[ 232.299] (--) evdev: Macintosh mouse button emulation: Found relative axes
[ 232.299] (--) evdev: Macintosh mouse button emulation: Found x and y relative axes
[ 232.299] (II) evdev: Macintosh mouse button emulation: Configuring as mouse
[ 232.299] (**) evdev: Macintosh mouse button emulation: YAxisMapping: buttons 4 and 5
[ 232.299] (**) evdev: Macintosh mouse button emulation: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[ 232.299] (**) Option "config_info" "hal:/org/freedesktop/Hal/devices/computer_logicaldev_input_2"
[ 232.299] (II) XINPUT: Adding extended input device "Macintosh mouse button emulation" (type: MOUSE, id 16)
[ 232.299] (II) evdev: Macintosh mouse button emulation: initialized for relative axes.
[ 232.299] (**) Macintosh mouse button emulation: (accel) keeping acceleration scheme 1
[ 232.299] (**) Macintosh mouse button emulation: (accel) acceleration profile 0
[ 232.299] (**) Macintosh mouse button emulation: (accel) acceleration factor: 2.000
[ 232.299] (**) Macintosh mouse button emulation: (accel) acceleration threshold: 4
[ 232.311] (II) config/hal: Adding input device HDA Intel HDMI/DP,pcm=3
[ 232.311] (II) Using input driver 'evdev' for 'HDA Intel HDMI/DP,pcm=3'
[ 232.311] (**) HDA Intel HDMI/DP,pcm=3: always reports core events
[ 232.311] (**) evdev: HDA Intel HDMI/DP,pcm=3: Device: "/dev/input/event11"
[ 232.316] (--) evdev: HDA Intel HDMI/DP,pcm=3: Vendor 0 Product 0
[ 232.316] (WW) evdev: HDA Intel HDMI/DP,pcm=3: Don't know how to use device
[ 232.332] (EE) PreInit returned 8 for "HDA Intel HDMI/DP,pcm=3"
[ 232.332] (II) UnloadModule: "evdev"
[ 232.332] (EE) config/hal: NewInputDeviceRequest failed (8)
[ 232.332] (EE) FBDEV(0): FBIOBLANK: Invalid argument

fivedai
Posts: 13
Joined: 2018/03/05 08:54:13

Re: Monitor unkown, and Can't adjust brightness and brightness

Post by fivedai » 2018/04/10 09:48:42

below are the xorg.0.log if using the xorg.conf generated by nvidia-xconfig
[ 68.688]
X.Org X Server 1.17.4
Release Date: 2015-10-28
[ 68.688] X Protocol Version 11, Revision 0
[ 68.689] Build Operating System: x86_64_01 3.10.0-693.2.2.el7.x86_64
[ 68.690] Current Operating System: Linux localdai 2.6.32-696.23.1.el6.x86_64 #1 SMP Tue Mar 13 22:44:18 UTC 2018 x86_64
[ 68.690] Kernel command line: ro root=/dev/mapper/vg_localdai-V_root rd_NO_LUKS LANG=en_US.UTF-8 rd_LVM_LV=vg_localdai/LogVol02 rd_NO_MD SYSFONT=latarcyrheb-sun16 crashkernel=128M rd_LVM_LV=vg_localdai/V_root KEYBOARDTYPE=pc KEYTABLE=us rd_NO_DM quiet acpi_backlight=vendor acpi_osi=linux
[ 68.693] Build Date: 26 January 2018 07:41:19AM
[ 68.693] Build ID: xorg-x11-server 1.17.4-16.el6.centos.1
[ 68.694] Current version of pixman: 0.32.8
[ 68.695] Before reporting problems, check http://wiki.centos.org/Documentation
to make sure that you have the latest version.
[ 68.695] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 68.697] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Apr 9 19:37:50 2018
[ 68.698] (==) Using config file: "/etc/X11/xorg.conf"
[ 68.699] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 68.699] (==) ServerLayout "Layout0"
[ 68.699] (**) |-->Screen "Screen0" (0)
[ 68.699] (**) | |-->Monitor "Monitor0"
[ 68.699] (**) | |-->Device "Device0"
[ 68.699] (**) |-->Input Device "Keyboard0"
[ 68.699] (**) |-->Input Device "Mouse0"
[ 68.699] (==) Automatically adding devices
[ 68.699] (==) Automatically enabling devices
[ 68.699] (==) Not automatically adding GPU devices
[ 68.699] (==) Max clients allowed: 256, resource mask: 0x1fffff
[ 68.699] (**) FontPath set to:
/usr/share/fonts/default/Type1,
catalogue:/etc/X11/fontpath.d,
built-ins
[ 68.699] (==) ModulePath set to "/usr/lib64/xorg/modules"
[ 68.699] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[ 68.699] (WW) Disabling Keyboard0
[ 68.699] (WW) Disabling Mouse0
[ 68.699] (II) Loader magic: 0x7fb0830dc020
[ 68.699] (II) Module ABI versions:
[ 68.699] X.Org ANSI C Emulation: 0.4
[ 68.699] X.Org Video Driver: 19.0
[ 68.699] X.Org XInput driver : 21.0
[ 68.699] X.Org Server Extension : 9.0
[ 68.709] (--) PCI:*(0:0:2:0) 8086:591b:1028:07e1 rev 4, Mem @ 0xdd000000/16777216, 0xb0000000/268435456, I/O @ 0x0000f000/64, BIOS @ 0x????????/131072
[ 68.709] (--) PCI: (0:1:0:0) 10de:1c8d:1028:07e1 rev 161, Mem @ 0xde000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288
[ 68.709] (II) LoadModule: "glx"
[ 68.710] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[ 68.710] (II) Module glx: vendor="X.Org Foundation"
[ 68.710] compiled for 1.17.4, module version = 1.0.0
[ 68.710] ABI class: X.Org Server Extension, version 9.0
[ 68.710] (==) AIGLX enabled
[ 68.710] (II) LoadModule: "nvidia"
[ 68.711] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[ 68.711] (II) Module nvidia: vendor="NVIDIA Corporation"
[ 68.711] compiled for 4.0.2, module version = 1.0.0
[ 68.711] Module class: X.Org Video Driver
[ 68.711] (II) NVIDIA dlloader X Driver 390.48 Wed Mar 21 23:18:15 PDT 2018
[ 68.711] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[ 68.711] (--) using VT number 7

[ 68.852] (EE) No devices detected.
[ 68.852] (EE)
Fatal server error:
[ 68.852] (EE) no screens found(EE)
[ 68.852] (EE)
Please consult the CentOS support
at http://wiki.centos.org/Documentation
for help.
[ 68.852] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 68.852] (EE)

fivedai
Posts: 13
Joined: 2018/03/05 08:54:13

Re: Monitor unkown, and Can't adjust brightness and brightness

Post by fivedai » 2018/04/10 09:52:43

I also chang the grub.conf as show below: still not work...
delet nomodeset and add acpi_backlight=vendor acpi_osi=linux


device (hd0) HD(4,250ad800,64000,043655ce-74d8-47dc-b5d1-71e566435a00)
default=0
timeout=3
splashimage=(hd0,4)/grub/splash.xpm.gz
hiddenmenu
title CentOS (2.6.32-696.23.1.el6.x86_64)
root (hd0,4)
kernel /vmlinuz-2.6.32-696.23.1.el6.x86_64 ro root=/dev/mapper/vg_localdai-V_root rd_NO_LUKS LANG=en_US.UTF-8 rd_LVM_LV=vg_localdai/LogVol02 rd_NO_MD SYSFONT=latarcyrheb-sun16 crashkernel=128M rd_LVM_LV=vg_localdai/V_root KEYBOARDTYPE=pc KEYTABLE=us rd_NO_DM quiet acpi_backlight=vendor acpi_osi=linux
initrd /initramfs-2.6.32-696.23.1.el6.x86_64.img
title CentOS 6 (2.6.32-696.el6.x86_64)
root (hd0,4)
kernel /vmlinuz-2.6.32-696.el6.x86_64 ro root=/dev/mapper/vg_localdai-V_root rd_NO_LUKS LANG=en_US.UTF-8 rd_LVM_LV=vg_localdai/LogVol02 rd_NO_MD SYSFONT=latarcyrheb-sun16 crashkernel=128M rd_LVM_LV=vg_localdai/V_root KEYBOARDTYPE=pc KEYTABLE=us rd_NO_DM quiet
initrd /initramfs-2.6.32-696.el6.x86_64.img
title Win10(SSD)
root (hd0,3)
chainloader /EFI/Microsoft/Boot/bootmgfw.efi

fivedai
Posts: 13
Joined: 2018/03/05 08:54:13

Re: Monitor unkown, and Can't adjust brightness and brightness

Post by fivedai » 2018/04/10 10:12:12

during reboot: undetect chipset
Attachments
undetct_chipset.png
undetct_chipset.png (68.26 KiB) Viewed 888 times

Post Reply