Installing eclipse for a specific version of Java

Issues related to applications and software problems
Post Reply
phil.e
Posts: 31
Joined: 2018/02/13 20:28:14

Installing eclipse for a specific version of Java

Post by phil.e » 2018/05/01 14:34:17

Hello,

I have a bunch of CentOS 6.9 workstations that have Java 1.5, 1.6, and 1.7 installed (and several of them have 1.8 installed too).
I want to remove 1.5 and 1.6. Removing 1.5 also removes the installed Eclipse java programming environment, which some, but not all, users are using.
I tried removing Java 1.5 and 1.6 on a test machine, thinking if I went to re-install Eclipse after that, that it would attach itself to the Java 1.7 that was already installed, but it listed java-1.5.0-gcj as a dependency it had to install for Eclipse to be installed.
How can I install Eclipse such that it uses Java 1.7 (or 1.8) rather than require java-1.5.0-gcj?
The eclipse version we have on our yum repo is eclipse-cdt-sdk.x86_64 1:7.0.1-4.el6.
There's also an eclipse-pde.x86_64 1:3.6.1-6.13.el6 (not sure which would be the "official" eclipse version #)
Phil.e

User avatar
TrevorH
Forum Moderator
Posts: 23213
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Installing eclipse for a specific version of Java

Post by TrevorH » 2018/05/01 15:09:37

If it requires gcj then 1.5 is the only choice, all subsequent versions don't have it.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

phil.e
Posts: 31
Joined: 2018/02/13 20:28:14

Re: Installing eclipse for a specific version of Java

Post by phil.e » 2018/05/01 18:42:40

Ok, thanks for the info.
I think I'm probably just going to update them to a more current version - eclipse 3.6 is pretty old anyway.

Post Reply