WL driver, problem with compilation

Issues related to hardware problems
kviatek
Posts: 15
Joined: 2015/12/19 12:15:29

WL driver, problem with compilation

Postby kviatek » 2018/05/07 15:30:21

Hi,

I lost some hours on fighting with CentOS and I don't want to waste more time.
I'm following this: https://elrepo.org/tiki/wl-kmod
and I'm stuck on point 5.

I get:

Code: Select all

rpmbuild --rebuild --define 'packager MY_USER_NAME' /home/MY_USER_NAME/Pobrane/wl-kmod-6_30_223_271-4.el7.elrepo.nosrc.rpm
Instalowanie /home/MY_USER_NAME/Pobrane/wl-kmod-6_30_223_271-4.el7.elrepo.nosrc.rpm
ostrzeżenie: użytkownik tindall nie istnieje - używanie roota
ostrzeżenie: grupa tindall nie istnieje - używanie roota
błąd: rozpakowanie archiwum się nie powiodło na pliku /home/MY_USER_NAME/rpmbuild/SOURCES/README_6.30.223.271.txt;5af07065: cpio: open
błąd: /home/MY_USER_NAME/Pobrane/wl-kmod-6_30_223_271-4.el7.elrepo.nosrc.rpm nie może zostać zainstalowany


It means warning:
user tindall doesn't exist - using root
error: /home/MY_USER_NAME/Pobrane/wl-kmod-6_30_223_271-4.el7.elrepo.nosrc.rpm cannot be installed.

What I'm doing wrong?

User avatar
TrevorH
Forum Moderator
Posts: 22590
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: WL driver, problem with compilation

Postby TrevorH » 2018/05/07 16:41:38

Does /home/MY_USER_NAME/rpmbuild/SOURCES/README_6.30.223.271.txt exist? Has it been marked immutable? Does the directory exist?
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

kviatek
Posts: 15
Joined: 2015/12/19 12:15:29

Re: WL driver, problem with compilation

Postby kviatek » 2018/05/07 17:42:53

The file exists but is uncompressed. I see this .txt file in Ark.
2Should I first extract files?
But than I cannot use the command: rpmbuild --rebuild --define 'packager <your-name>' /<path-to-nosrc.rpm>/wl-kmod*nosrc.rpm
I must do it on '.rpm' file.
I have no idea what's the process.

bonedome
Posts: 36
Joined: 2017/04/22 08:11:04

Re: WL driver, problem with compilation

Postby bonedome » 2018/05/10 20:30:20

Hello
I have the same problem.
reading the https://elrepo.org/tiki/wl-kmod page it says
Supported EL 7 Point Release Ranges: (1) 7.0, (2) 7.1, (3) 7.2, (4) 7.3, (5) 7.4
there was a similar problem between 7.3 and 7.4, I guess we'll have to wait for the guys at elrepo to do their magic again, if you check the fedora version it has a few more patches for the later kernel it uses, so I'm guessing some of those patches are required for the latest 7.5 kernel and I suspect the CentOS package numbering system doesn't make finding out which patches are required any easier.
You can either use the old kernel (at boot) or use the built in kernel module with

Code: Select all

# modprobe brcmsmac
It's not as good but it works.
If the guys at elrepo are reading this I can post error messages if required.

User avatar
WhatsHisName
Posts: 1541
Joined: 2005/12/19 20:21:43
Location: /earth/usa/nj

Re: WL driver, problem with compilation

Postby WhatsHisName » 2018/05/11 05:28:52

Try wl-kmod-6_30_223_271-5.el7.elrepo.nosrc.rpm (note the -5) and see if it builds/works under EL 7.5.

It is in the regular elrepo srpm folder.

If it fails, then I suggest filing a bug report at http://elrepo.org/bugs/main_page.php.

bonedome
Posts: 36
Joined: 2017/04/22 08:11:04

Re: WL driver, problem with compilation

Postby bonedome » 2018/05/12 07:59:58

Good spot there WhatsHisName
I can confirm it works, thanks to the guys at elrepo for the fix