[SOLVED] One of the configured repositories failed (Unknown)

Issues related to applications and software problems
User avatar
Forum Moderator
Posts: 2944
Joined: 2010/12/01 19:25:52
Location: Helsinki, Finland

Re: yum error "One of the configured repositories failed (Unknown)""

Post by avij » 2018/05/11 14:42:45

TimL wrote:Some mirrors still have issues.
what worked for me was commenting the "metalink", and un-commenting the "baseurl" in /etc/yum.repos.d/epel.repo
Yes, sure. My general suggestion is still valid, though -- unless you have an immediate need to get EPEL packages, I would suggest using --disablerepo=epel until your local mirror gets the fixed repodata. If you do have an immediate need for EPEL packages and yum clean all does not help, you will need to adjust your config to point to some specific mirror that has the fixed content, like by adding baseurl=http://ftp.funet.fi/pub/mirrors/fedora. ... /$basearch to epel.repo. Most mirrors should be updated by now, though.

Posts: 2
Joined: 2018/05/11 13:59:39

Re: [SOLVED] One of the configured repositories failed (Unknown)

Post by TimL » 2018/05/11 14:59:06

Sure yum could list the repo, and sure it could try a different mirror if one is broken, but I think such features are best left to whenever dnf trickles down from fedora to redhat then centos.

What should be done, is someone should notify the mirrors that are still broken, and maybe fix/prevent whatever the root issue was.

User avatar
Forum Moderator
Posts: 25395
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: [SOLVED] One of the configured repositories failed (Unknown)

Post by TrevorH » 2018/05/11 16:19:48

Sure but those are mostly issues for the EPEL maintainers. EPEL is not a CentOS project, it's Redhat.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

Posts: 21
Joined: 2016/05/27 19:31:55

Re: [SOLVED] One of the configured repositories failed (Unknown)

Post by dalepres » 2018/05/11 16:28:31

Thanks, Ajiv. That's the approach I'll take next time.

Post Reply