HP Probook 450 G4 - ethernet interface

Issues related to hardware problems
Post Reply
Posts: 1
Joined: 2018/05/16 05:08:19

HP Probook 450 G4 - ethernet interface

Post by imac101 » 2018/05/16 05:19:57

I have a HP Probook 450 G4 which I converted from win-10 to centos 7
All went well other than the built in ethernet interface Realtek 8169 driver was installed on initial build.

Driver installed and registers the interface however the interface is unusable, it registers when it has a valid ethernet connection but is unable to obtain an IP address via DHCP.

Have tried the following
1. Set a static IP - no luck
2. used ethtools to verify link status, tried adjusting duplex, speed and auto negotiation to no avail.
3. used tcpdump to confirm any connectivity and tcpdump confirms packets being received and sent on the interface, including ARP's and DHCP requests with a corresponding return packet.

What am I missing...

Any help would be appreciated as the only way I can utilize the laptop is via a usb/ethernet dongle or wireless (sorry just annoying).

Post Reply