yum update "Error: Package: libvirt-daemon"

General support questions
Post Reply
diogo.47736
Posts: 3
Joined: 2018/05/17 13:32:56

yum update "Error: Package: libvirt-daemon"

Post by diogo.47736 » 2018/05/17 13:41:50

Hi,

I have a problem when UPDATE Centos 7.4. I running "yum update", but is generated errors:

Code: Select all

# yum update

...

--> Finished Dependency Resolution
Error: Package: libvirt-daemon-xen-3.2.1-402.el7.x86_64 (@centos-virt-xen)
           Requires: libvirt-daemon-driver-network = 3.2.1-402.el7
           Removing: libvirt-daemon-driver-network-3.2.1-402.el7.x86_64 (@centos-virt-xen)
               libvirt-daemon-driver-network = 3.2.1-402.el7
           Updated By: libvirt-daemon-driver-network-3.9.0-14.el7_5.2.x86_64 (updates)
               libvirt-daemon-driver-network = 3.9.0-14.el7_5.2
           Available: libvirt-daemon-driver-network-3.9.0-14.el7.x86_64 (base)
               libvirt-daemon-driver-network = 3.9.0-14.el7
Error: Package: libvirt-daemon-xen-3.2.1-402.el7.x86_64 (@centos-virt-xen)
           Requires: libvirt-daemon-driver-storage = 3.2.1-402.el7
           Removing: libvirt-daemon-driver-storage-3.2.1-402.el7.x86_64 (@centos-virt-xen)
               libvirt-daemon-driver-storage = 3.2.1-402.el7
           Updated By: libvirt-daemon-driver-storage-3.9.0-14.el7_5.2.x86_64 (updates)
               libvirt-daemon-driver-storage = 3.9.0-14.el7_5.2
           Available: libvirt-daemon-driver-storage-3.9.0-14.el7.x86_64 (base)
               libvirt-daemon-driver-storage = 3.9.0-14.el7
Error: Package: libvirt-daemon-xen-3.2.1-402.el7.x86_64 (@centos-virt-xen)
           Requires: libvirt-daemon-driver-secret = 3.2.1-402.el7
           Removing: libvirt-daemon-driver-secret-3.2.1-402.el7.x86_64 (@centos-virt-xen)
               libvirt-daemon-driver-secret = 3.2.1-402.el7
           Updated By: libvirt-daemon-driver-secret-3.9.0-14.el7_5.2.x86_64 (updates)
               libvirt-daemon-driver-secret = 3.9.0-14.el7_5.2
           Available: libvirt-daemon-driver-secret-3.9.0-14.el7.x86_64 (base)
               libvirt-daemon-driver-secret = 3.9.0-14.el7
Error: Package: srvadmin-storage-9.1.0-2757.12163.el7.x86_64 (dell-system-update_dependent)
           Requires: libsmbios.so.2()(64bit)
           Removing: libsmbios-2.3.1-2372.10488.el7.x86_64 (@dell-system-update_dependent)
               libsmbios.so.2()(64bit)
           Updated By: libsmbios-2.3.3-6.el7.x86_64 (base)
               Not found
           Available: libsmbios-2.3.1-2757.12163.el7.x86_64 (dell-system-update_dependent)
               libsmbios.so.2()(64bit)
           Available: libsmbios-2.3.3-2.el7.x86_64 (epel)
               libsmbios.so.2()(64bit)
Error: Package: libvirt-daemon-xen-3.2.1-402.el7.x86_64 (@centos-virt-xen)
           Requires: libvirt-daemon-driver-nodedev = 3.2.1-402.el7
           Removing: libvirt-daemon-driver-nodedev-3.2.1-402.el7.x86_64 (@centos-virt-xen)
               libvirt-daemon-driver-nodedev = 3.2.1-402.el7
           Updated By: libvirt-daemon-driver-nodedev-3.9.0-14.el7_5.2.x86_64 (updates)
               libvirt-daemon-driver-nodedev = 3.9.0-14.el7_5.2
           Available: libvirt-daemon-driver-nodedev-3.9.0-14.el7.x86_64 (base)
               libvirt-daemon-driver-nodedev = 3.9.0-14.el7
Error: Package: libvirt-daemon-xen-3.2.1-402.el7.x86_64 (@centos-virt-xen)
           Requires: libvirt-daemon-driver-nwfilter = 3.2.1-402.el7
           Removing: libvirt-daemon-driver-nwfilter-3.2.1-402.el7.x86_64 (@centos-virt-xen)
               libvirt-daemon-driver-nwfilter = 3.2.1-402.el7
           Updated By: libvirt-daemon-driver-nwfilter-3.9.0-14.el7_5.2.x86_64 (updates)
               libvirt-daemon-driver-nwfilter = 3.9.0-14.el7_5.2
           Available: libvirt-daemon-driver-nwfilter-3.9.0-14.el7.x86_64 (base)
               libvirt-daemon-driver-nwfilter = 3.9.0-14.el7
Error: Package: libvirt-daemon-driver-libxl-3.2.1-402.el7.x86_64 (@centos-virt-xen)
           Requires: libvirt-daemon = 3.2.1-402.el7
           Removing: libvirt-daemon-3.2.1-402.el7.x86_64 (@centos-virt-xen)
               libvirt-daemon = 3.2.1-402.el7
           Updated By: libvirt-daemon-3.9.0-14.el7_5.2.x86_64 (updates)
               libvirt-daemon = 3.9.0-14.el7_5.2
           Available: libvirt-daemon-3.9.0-14.el7.x86_64 (base)
               libvirt-daemon = 3.9.0-14.el7
Error: Package: libvirt-daemon-xen-3.2.1-402.el7.x86_64 (@centos-virt-xen)
           Requires: libvirt-daemon-driver-interface = 3.2.1-402.el7
           Removing: libvirt-daemon-driver-interface-3.2.1-402.el7.x86_64 (@centos-virt-xen)
               libvirt-daemon-driver-interface = 3.2.1-402.el7
           Updated By: libvirt-daemon-driver-interface-3.9.0-14.el7_5.2.x86_64 (updates)
               libvirt-daemon-driver-interface = 3.9.0-14.el7_5.2
           Available: libvirt-daemon-driver-interface-3.9.0-14.el7.x86_64 (base)
               libvirt-daemon-driver-interface = 3.9.0-14.el7
Error: Package: libvirt-daemon-driver-xen-3.2.1-402.el7.x86_64 (@centos-virt-xen)
           Requires: libvirt-daemon = 3.2.1-402.el7
           Removing: libvirt-daemon-3.2.1-402.el7.x86_64 (@centos-virt-xen)
               libvirt-daemon = 3.2.1-402.el7
           Updated By: libvirt-daemon-3.9.0-14.el7_5.2.x86_64 (updates)
               libvirt-daemon = 3.9.0-14.el7_5.2
           Available: libvirt-daemon-3.9.0-14.el7.x86_64 (base)
               libvirt-daemon = 3.9.0-14.el7
Error: Package: libvirt-daemon-xen-3.2.1-402.el7.x86_64 (@centos-virt-xen)
           Requires: libvirt-daemon = 3.2.1-402.el7
           Removing: libvirt-daemon-3.2.1-402.el7.x86_64 (@centos-virt-xen)
               libvirt-daemon = 3.2.1-402.el7
           Updated By: libvirt-daemon-3.9.0-14.el7_5.2.x86_64 (updates)
               libvirt-daemon = 3.9.0-14.el7_5.2
           Available: libvirt-daemon-3.9.0-14.el7.x86_64 (base)
               libvirt-daemon = 3.9.0-14.el7
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Anyone know the solve this?

Thanks,
Diogo

User avatar
TrevorH
Forum Moderator
Posts: 23213
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: yum update "Error: Package: libvirt-daemon"

Post by TrevorH » 2018/05/17 13:57:38

You're using the Virt SIG libvirt-xen packages and 7.5 rebased libvirt to a newer release so those are now seen as older than the distro ones. The Virt SIG need to rebuild their packages and bump the version number again so they are seen as newer than the distro ones.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

diogo.47736
Posts: 3
Joined: 2018/05/17 13:32:56

Re: yum update "Error: Package: libvirt-daemon"

Post by diogo.47736 » 2018/05/21 18:45:43

TrevorH wrote:You're using the Virt SIG libvirt-xen packages and 7.5 rebased libvirt to a newer release so those are now seen as older than the distro ones. The Virt SIG need to rebuild their packages and bump the version number again so they are seen as newer than the distro ones.
@TrevorH, thanks for reply.

How to do this?


[ ]s
Diogo

User avatar
TrevorH
Forum Moderator
Posts: 23213
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: yum update "Error: Package: libvirt-daemon"

Post by TrevorH » 2018/05/21 19:56:55

Write to the centos-devel mailing list and ask. No-one from the Xen SIG hangs out on the forums or on IRC so mail is the best (and only AFAIK) way to contact them.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

diogo.47736
Posts: 3
Joined: 2018/05/17 13:32:56

Re: yum update "Error: Package: libvirt-daemon"

Post by diogo.47736 » 2018/05/22 13:19:18

TrevorH wrote:Write to the centos-devel mailing list and ask. No-one from the Xen SIG hangs out on the forums or on IRC so mail is the best (and only AFAIK) way to contact them.
Thanks

Post Reply