Repo question - new packages don't show up when running "yum update"

General support questions
phil.e
Posts: 28
Joined: 2018/02/13 20:28:14

Repo question - new packages don't show up when running "yum update"

Postby phil.e » 2018/05/17 15:16:56

I have a CentOS 7 server running as an offline yum repository for CentOS 6.9 clients.
I use rsync to sync with another server upstream as my source server.
It looked like no new updates were coming in for awhile, so I checked my server against the upstream server, and mine had downloaded newer updates from the upstream server, but they don't appear available on the clients when I run yum update.
When I run rsync, I sync to the "Packages" folder but don't include the "repodata" folder.
Should that repodata folder be included in the "rsync"?
The folder structure for the CentOS6.9 updates is "./CentOS6-Updates/updates/x86_64/Packages
When I ran "createrepo" I ran it on the "CentOS6-Updates" folder, so my "repodata folder is under that folder.
My upstream has their repodata folder under the ./updates/x86_64 folder so I assume he ran "createrepo" on the "x86_64" folder.

Phil.e

User avatar
TrevorH
Forum Moderator
Posts: 22590
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Repo question - new packages don't show up when running "yum update"

Postby TrevorH » 2018/05/17 15:20:40

Should that repodata folder be included in the "rsync"?


Yes.

You might want to read the wiki page about setting up a local mirror - please see https://wiki.centos.org/HowTos/CreateLocalMirror
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

phil.e
Posts: 28
Joined: 2018/02/13 20:28:14

Re: Repo question - new packages don't show up when running "yum update"

Postby phil.e » 2018/05/17 15:27:11

Thanks for the quick reply.
So, should I remove the existing repodata folder, and run "createrepo" again on the x86_64 folder on my server?

User avatar
TrevorH
Forum Moderator
Posts: 22590
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Repo question - new packages don't show up when running "yum update"

Postby TrevorH » 2018/05/17 15:41:05

Ideally, if you are not modifying anything in the repo, you just rsync it and then it syncs the repodata as well and you don't need to run createrepo at all.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke