[SOLVED] TigerVNC Server problem

Issues related to applications and software problems
Post Reply
anya
Posts: 3
Joined: 2013/09/04 14:39:11

[SOLVED] TigerVNC Server problem

Post by anya » 2013/09/04 14:43:50

Hello everyone,

I'm trying to startup vnc server on my PC but everytime I get warning:

WARNING: The first attempt to start Xvnc failed, possibly because the font
catalog is not properly configured. Attempting to determine an appropriate
font path for this system and restart Xvnc using that font path ...
Could not start Xvnc.

/usr/bin/Xvnc: symbol lookup error: /usr/bin/Xvnc: undefined symbol: pixman_composite_trapezoids


I have installed:

rpm -qa pixman\*
pixman-0.18.4-1.el6_0.1.i686
pixman-0.18.4-1.el6_0.1.x86_64
pixman-devel-0.18.4-1.el6_0.1.x86_64

rpm -qa tigervnc-server\*
tigervnc-server-1.1.0-5.el6_4.1.x86_64

Can anyone help me, I tried everything from forums ....nothing helped me :S

Cheers

gerald_clark
Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

[SOLVED] TigerVNC Server problem

Post by gerald_clark » 2013/09/04 14:47:32

Do you have X running on that box?
Please read http://wiki.centos.org/HowTos/VNC-Server

anya
Posts: 3
Joined: 2013/09/04 14:39:11

Re: TigerVNC Server problem

Post by anya » 2013/09/04 15:07:10

X running? I read this but it is not the same, for example I do not have xstartup directory at all:

bash: /root/.vnc/xstartup: No such file or directory

gerald_clark
Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Re: TigerVNC Server problem

Post by gerald_clark » 2013/09/04 16:07:27

If you don't have X installed and running on your server, how do you expect to forward its display using vnc?

simon_matthews
Posts: 315
Joined: 2012/09/15 21:06:54

Re: TigerVNC Server problem

Post by simon_matthews » 2013/09/04 22:13:37

Start with [code]yum update[/code]
You appear to have the latest version of tigervnc, but an old version of pixman.

Also, you are not thinking of running vncserver as root are you?

anya
Posts: 3
Joined: 2013/09/04 14:39:11

Re: [SOLVED] TigerVNC Server problem

Post by anya » 2013/09/05 06:49:27

Solved with yum groupinstall "X Window System" ...Thank you. :-)

Post Reply