centOS 7 hung at "Starting Plymouth switch root service"

General support questions
User avatar
jlehtone
Posts: 1989
Joined: 2007/12/11 08:17:33
Location: Finland

Re: centOS 7 hung at "Starting Plymouth switch root service"

Post by jlehtone » 2018/09/12 08:29:46

Try adding option noauto on them.

hema.arun
Posts: 14
Joined: 2017/02/06 11:56:26

Re: centOS 7 hung at "Starting Plymouth switch root service"

Post by hema.arun » 2018/09/16 10:03:54

jlehtone wrote:
2018/09/12 08:29:46
Try adding option noauto on them.
Adding no auto will prevent it from mounting at the time of reboot or when executing command "mount -avv"

User avatar
jlehtone
Posts: 1989
Joined: 2007/12/11 08:17:33
Location: Finland

Re: centOS 7 hung at "Starting Plymouth switch root service"

Post by jlehtone » 2018/09/16 14:54:40

Indeed. No mounting -> no hang on boot.

You have the x-systemd.automount. Does that not create a systemd unit that automounts the filesystem whenever anything attempts to access it?

hema.arun
Posts: 14
Joined: 2017/02/06 11:56:26

Re: centOS 7 hung at "Starting Plymouth switch root service"

Post by hema.arun » 2018/09/19 04:24:02

jlehtone wrote:
2018/09/16 14:54:40
Indeed. No mounting -> no hang on boot.

You have the x-systemd.automount. Does that not create a systemd unit that automounts the filesystem whenever anything attempts to access it?
This mounts only when someone access the folder from command line. Developers work from Dreamweaver and then it is not mounted automatically with x-systemd.automount. Hence I am mounting it at the time of the boot.

User avatar
jlehtone
Posts: 1989
Joined: 2007/12/11 08:17:33
Location: Finland

Re: centOS 7 hung at "Starting Plymouth switch root service"

Post by jlehtone » 2018/09/19 16:31:49

Sorry, I don't have GUI (is it Nautilus?). One forgets what one never sees. :oops:

Plan B: autofs.service
Similar "delay to actual need" as with the systemd automounter, definitely unmounts unused shares (which is nice), and can be set to show a "ghost" of mount for the GUI-impaired.
(BROWSE_MODE="yes" in /etc/sysconfig/autofs)

hema.arun
Posts: 14
Joined: 2017/02/06 11:56:26

Re: centOS 7 hung at "Starting Plymouth switch root service"

Post by hema.arun » 2018/09/25 06:23:26

jlehtone wrote:
2018/09/19 16:31:49
Sorry, I don't have GUI (is it Nautilus?). One forgets what one never sees. :oops:

Plan B: autofs.service
Similar "delay to actual need" as with the systemd automounter, definitely unmounts unused shares (which is nice), and can be set to show a "ghost" of mount for the GUI-impaired.
(BROWSE_MODE="yes" in /etc/sysconfig/autofs)
can be this used for CIFS share as well? Mine is not NFS, but CIFS

In between, I found removing the "x-systemd.automount" option from fstab file mounts the share at boot time without any hung issues.
I am surprised, what is its role in delaying Plymouth. Any leads?

Post Reply