Getting dependency error when we tried to patch the centos server

Issues related to applications and software problems
kitchaaa_r
Posts: 18
Joined: 2018/08/20 18:09:55

Re: Getting dependency error when we tried to patch the centos server

Post by kitchaaa_r » 2018/09/03 08:54:12

Please let us know which URL we have to use for base

kitchaaa_r
Posts: 18
Joined: 2018/08/20 18:09:55

Re: Getting dependency error when we tried to patch the centos server

Post by kitchaaa_r » 2018/09/04 15:14:09

Hi Team,

Any updates would be much appreciated.Thanks

kitchaaa_r
Posts: 18
Joined: 2018/08/20 18:09:55

Re: Getting dependency error when we tried to patch the centos server

Post by kitchaaa_r » 2018/09/05 13:26:44

Hi Team,

Could you please someone let us know to solve the issue.which would be much appreciated. Thanks

stevemowbray
Posts: 388
Joined: 2012/06/26 14:20:47

Re: Getting dependency error when we tried to patch the centos server

Post by stevemowbray » 2018/09/05 14:39:25

Take the URL your're using for updates and replace "updates" with "os" to get the base URL.

kitchaaa_r
Posts: 18
Joined: 2018/08/20 18:09:55

Re: Getting dependency error when we tried to patch the centos server

Post by kitchaaa_r » 2018/09/05 14:51:17

Thanks lot for the update Steve.

so i am going to update my daily snyc script like below for the base URL
#### Channel label: centos6-x86_64-base ####
Repo URL: http://centos.mirrors.tds.net/centos/6/os/x86_64/

#### Channel label: centos6-x86_64-updates ####
Repo URL: http://centos.mirrors.tds.net/pub/linux ... es/x86_64/

User avatar
TrevorH
Forum Moderator
Posts: 23458
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Getting dependency error when we tried to patch the centos server

Post by TrevorH » 2018/09/05 15:06:50

Again.. don't use /6/ use the full version number like /6.10/ and make sure you flip the symlink yourself when/if there is a new version.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

kitchaaa_r
Posts: 18
Joined: 2018/08/20 18:09:55

Re: Getting dependency error when we tried to patch the centos server

Post by kitchaaa_r » 2018/09/05 15:35:43

Hi Steve,

Currently our system installed with latest kernel but the centos release version is still showing as 6.9.

kindly let me know is there any impact if i make the change in URL for base (http://centos.mirrors.tds.net/centos/6/os/x86_64/)

# uname -r
2.6.32-754.3.5.el6.x86_64
cat /etc/redhat-release
CentOS release 6.9 (Final)

stevemowbray
Posts: 388
Joined: 2012/06/26 14:20:47

Re: Getting dependency error when we tried to patch the centos server

Post by stevemowbray » 2018/09/05 16:29:14

You seem to be asking the same questions over and over again and ignoring advice.

Are you asking why the release version hasn't updated? If so, it's because either you still haven't got the repos correct or you haven't run "yum update" after you did get them correct.

User avatar
TrevorH
Forum Moderator
Posts: 23458
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Getting dependency error when we tried to patch the centos server

Post by TrevorH » 2018/09/05 17:30:19

And since they are satellite hosted repos, they are yours to control and to populate. All we can do is tell you that you need to entirely replace both base and updates every time there is a new point release (which may never happen for CentOS 6 as 6.10 may be the last). If you had a 6.9 repo then you cannot just copy the 6.10 repo over the top of it. You need to follow the instructions in the wiki entry to combine the old updates into the old base and then rsync on top of both. Or, easier, just sync the new 6.10 repo to a 6.10 directory and use a symlink to flip between one and the other.

All we can say for sure is that your copy of the repo is incorrect.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

kitchaaa_r
Posts: 18
Joined: 2018/08/20 18:09:55

Re: Getting dependency error when we tried to patch the centos server

Post by kitchaaa_r » 2018/09/05 18:07:01

Hi Team,

I have modified the URL's for base and updates in the script on satellite server
then ran the sync script and getting below errors.however packages were sync which are more than 500 as per the logs


channel="centos6-x86_64-base"
url="http://centos.mirrors.tds.net/centos/6.10/os/x86_64/"


channel="centos6-x86_64-updates"
url="http://centos.mirrors.tds.net/pub/linux ... es/x86_64/"


# ./sync-channels-centos6.sh

ERROR: (23, 'ERROR: duplicate key value violates unique constraint "rhn_cnp_cid_nid_uq"', 'Could not update database entry.')
Traceback (most recent call last):
File "/usr/bin/spacewalk-repo-sync", line 186, in <module>
sys.exit(abs(main() or 0))
File "/usr/bin/spacewalk-repo-sync", line 179, in main
sync.sync()
File "/usr/lib/python2.6/site-packages/spacewalk/satellite_tools/reposync.py", line 209, in sync
[self.channel_label], [], "server.app.yumreposync")
File "/usr/lib/python2.6/site-packages/spacewalk/server/taskomatic.py", line 65, in add_to_repodata_queue_for_channel_package_subscription
add_to_repodata_queue(channel, caller, reason[:128])
File "/usr/lib/python2.6/site-packages/spacewalk/server/taskomatic.py", line 51, in add_to_repodata_queue
queue.add(entry)
File "/usr/lib/python2.6/site-packages/spacewalk/server/taskomatic.py", line 43, in add
bypass_filters=self._boolean_as_char(entry.bypass_filters))
File "/usr/lib/python2.6/site-packages/spacewalk/server/rhnSQL/sql_base.py", line 147, in execute
return self._execute_wrapper(self._execute, *p, **kw)
File "/usr/lib/python2.6/site-packages/spacewalk/server/rhnSQL/driver_postgresql.py", line 292, in _execute_wrapper
raise sql_base.SQLSchemaError(error_code, e.pgerror, e)
spacewalk.server.rhnSQL.sql_base.SQLSchemaError: (99999, 'ERROR: current transaction is aborted, commands ignored until end of transaction block', '', InternalError('current transaction is aborted, commands ignored until end of transaction block\n',))
ERROR: Cannot retrieve repository metadata (repomd.xml) for repository: centos6-x86_64-spacewalkclient. Please verify its path and try again
[root@mncosat01 satellite]#
[root@mncosat01 satellite]#


Also i have noticed in the script that the below URL not working for spacewalkclient

#### Channel label: centos6-x86_64-spacewalkclient ####
Repo URL: http://yum.spacewalkproject.org/latest- ... /6/x86_64/

Post Reply