~40 sec boot time on fast SSD

General support questions
yaomtc
Posts: 15
Joined: 2017/04/22 00:07:03

~40 sec boot time on fast SSD

Post by yaomtc » 2018/09/07 21:07:29

It takes about 40 seconds to boot to the login, half of which comes before the CentOS loading bar, and includes things such as "Warning: AMD Processor - this hardware has not undergone upstream testing" (suggests to consult FAQ on wiki which doesn't say anything relevant I could find) and "fast TBC calibration failed", among other things. Not sure how to get the text it outputs here, it only appears on screen for a very short time, I had to take a picture. How can I troubleshoot?

CPU is Ryzen Threadripper 1900X.

EDIT: and the mobo is an ASRock Fatal1ty X399.
Last edited by yaomtc on 2018/09/15 00:18:40, edited 1 time in total.

hunter86_bg
Posts: 1422
Joined: 2015/02/17 15:14:33
Location: Bulgaria
Contact:

Re: ~40 sec boot time on fast SSD

Post by hunter86_bg » 2018/09/08 09:40:41

You can create a graphic whic you can analyze in a browser .
Just run

Code: Select all

systemd-analyze plot > ~/Downloads/plot.svg
And then open the file with a browser.
Every row indicates a service and it's duration of startup.

Also you can run

Code: Select all

systemd-analyze blame ; echo; systemd-analyze critical-chain

yaomtc
Posts: 15
Joined: 2017/04/22 00:07:03

Re: ~40 sec boot time on fast SSD

Post by yaomtc » 2018/09/14 22:28:26

Thanks hunter86_bg, that helps. Kernel takes less than a second, while initrd takes 3 seconds, doesn't seem that significant... oh, NetworkManager-wait-online.service takes 6.1s. That's a bit much. But even including EVERYTHING on that list, it's total less than 14 seconds... so while there's room for some improvement, there's definitely a different culprit here.

EDIT: Captured a video. The longest time is spent on a blank screen with a blinking cursor, but here it is anyway. https://www.youtube.com/watch?v=aa8VMu-dN2Q

hunter86_bg
Posts: 1422
Joined: 2015/02/17 15:14:33
Location: Bulgaria
Contact:

Re: ~40 sec boot time on fast SSD

Post by hunter86_bg » 2018/09/15 07:00:53

Have you tried the kernels (i think it was called kernel-ml) from elrepo?

User avatar
TrevorH
Forum Moderator
Posts: 23870
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: ~40 sec boot time on fast SSD

Post by TrevorH » 2018/09/15 09:21:13

The longest time is spent on a blank screen with a blinking cursor
Did you remove rhgb quiet from the kernel command line so that you can actually see what's going on?
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

yaomtc
Posts: 15
Joined: 2017/04/22 00:07:03

Re: ~40 sec boot time on fast SSD

Post by yaomtc » 2018/09/15 20:16:37

TrevorH wrote:
2018/09/15 09:21:13
The longest time is spent on a blank screen with a blinking cursor
Did you remove rhgb quiet from the kernel command line so that you can actually see what's going on?
Thanks, forgot about that. Now I have. Still a long period with a blinking cursor, though, and no warnings immediately after that as far as I can tell.

https://youtu.be/ZJwfkT7oYek

User avatar
TrevorH
Forum Moderator
Posts: 23870
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: ~40 sec boot time on fast SSD

Post by TrevorH » 2018/09/15 23:25:40

Try appending edd=off to the kernel command line. If that works you could also try edd=skipmbr and see if that works too. If off does not work then I would not expect skipmbr to either.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

yaomtc
Posts: 15
Joined: 2017/04/22 00:07:03

Re: ~40 sec boot time on fast SSD

Post by yaomtc » 2018/09/16 21:05:08

That didn't seem to work, had the black screen with the cursor for about 17 seconds after reboot. Oddly though I still saw the loading bar, shouldn't that not be showing up since I removed the "rhgb" option? I did run grub2-mkconfig...

EDIT: just now I hit E at the boot screen, and there they were again, rhgb and quiet. So I deleted them again, this time typing in "edd=off" in their place. While grub2-mkconfig might not what I need to be using (maybe it's EFI? I'll have to figure that out), it did give me about 17 seconds of blank-with-cursor again.

User avatar
TrevorH
Forum Moderator
Posts: 23870
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: ~40 sec boot time on fast SSD

Post by TrevorH » 2018/09/16 21:39:17

grub2-mkconfig is completely unnecessary on CentOS. It is worth updating both /etc/default/grub and /boot/grub2/grub.cfg (or its UEFI equivalent) just for completeness sake but nothing will ever run grub2-mkconfig except a human. New kernel installs update grub.cfg by calling /sbin/new-kernel-pkg which in turns calls grubby which copies the previous grub entry and amends it to become the new one. All automatic.

If edd=off did not work then I'm afraid I'm about out of ideas.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

hunter86_bg
Posts: 1422
Joined: 2015/02/17 15:14:33
Location: Bulgaria
Contact:

Re: ~40 sec boot time on fast SSD

Post by hunter86_bg » 2018/09/17 12:10:00

By the way can you provide the

Code: Select all

cat /proc/cmdline
.
I used to have a similar issue due to 'resume=' stanza.

Post Reply