Replacing Debian with CentOS

Issues related to applications and software problems
User avatar
Posts: 2172
Joined: 2007/12/11 08:17:33
Location: Finland

Re: Replacing Debian with CentOS

Post by jlehtone » 2018/09/12 08:26:28

Rymsantana wrote:
2018/09/12 01:58:35
my computer was 32bit Windows
Pedantically, a 32bit version of Windows was installed on the computer. That does not tell what the hardware does support.

I presume that majority of Windows XP installations were 32bit. The 64bit had (initially) driver issues and there were not many 64-bit applications. There were not many 64bit applications either, because "everybody" had 32-bit Windows.

You could tell the hardware of your computer. At least the CPU and GPU models.

Attempt to install a 64bit OS on 32bit hardware stops at the very beginning: hardware cannot execute the 64bit binaries.
Rymsantana wrote:Installation works at first and then it goes into a black screen and nothing happens.
It is hard to see what "works" and "at first" mean, but I would guess this:
The installer boots in "text mode" and then shifts into "graphical mode". The first "works" practically everywhere.
The graphical mode involves the GPU much more and installer's guess on the graphic settings can be incorrect.
Hence the black.

There is usually an opportunity to give options for installer during the text mode phase to work around such issues.
I, sadly, tend to play it by ear, and thus have no proper incantations at hand.

Posts: 7
Joined: 2018/09/10 19:55:05

Re: Replacing Debian with CentOS

Post by Rymsantana » 2018/09/12 19:15:59

I had installed the centOS i386 version on it and downloaded the x86-64 last night and installed it. I did a second OS on my pc and I didn't like that. So I tried to reinstall the x86-64 again to try and wipe it out and didn't work.
This morning I re-installed the Debian server i386 on it and then tried to install CentOS 7 x86-64 and it would do the same, go into a black screen. So I tried again and when it asked for options again at the beginning, I pressed tab to modify the configuration options and even though I know nothing about prompts I noticed it says: "vmlinuz initrd=initrd.img inst.stage2=hd :LABEL=CentOS\x207\x20x86_64 quiet_".
What I tried was I removed the "quiet_" at the very end as I know what a quiet installation is and then it started working. but it then displayed a message saying that:"This kernel requires an x86_64 CPU, but only detected and i686 CPU. This processor is unsuported in CentOS 7". So I guess I'm going to have to go back to 32bit option.

Posts: 7
Joined: 2018/09/10 19:55:05

Re: Replacing Debian with CentOS

Post by Rymsantana » 2018/09/12 19:23:56

owl102 wrote:
2018/09/11 18:29:10
Please note that there is no EPEL available for i686, and most other 3rd party repositories do not support i686 architecture either.

So you are basically limited to the packages available in the CentOS base repository.
You are right. I did notice that this morning. Unfortunately I have a i686 CPU. So I have no choice for the time being. Maybe I can get a better machine later. But this is experimental so I can learn Linux and move away from Windows. :D

Post Reply