I can't update

General support questions
Post Reply
skuyt
Posts: 2
Joined: 2018/09/16 12:48:17

I can't update

Post by skuyt » 2018/09/16 13:04:11

Hello Everyone, I had read a lot of problems like this, but I couldn't fix. Someone can understand what is happened here?
I tried to disable. enable, restore and still the same problem.

Code: Select all

---> Package ffmpeg-libs.x86_64 0:2.8.15-1.el7.nux will be an update
--> Processing Dependency: libx264.so.142()(64bit) for package: ffmpeg-libs-2.8.15-1.el7.nux.x86_64
---> Package ftgl.x86_64 0:2.1.3-0.8.rc5.el7 will be installed
---> Package libGLEW.x86_64 0:1.10.0-5.el7 will be installed
---> Package vlc-core.x86_64 1:2.2.5.1-2.el7.nux will be an update
--> Processing Dependency: libx264.so.142()(64bit) for package: 1:vlc-core-2.2.5.1-2.el7.nux.x86_64
--> Processing Dependency: libliveMedia.so.17()(64bit) for package: 1:vlc-core-2.2.5.1-2.el7.nux.x86_64
--> Processing Dependency: libgroupsock.so.1()(64bit) for package: 1:vlc-core-2.2.5.1-2.el7.nux.x86_64
--> Processing Dependency: libUsageEnvironment.so.1()(64bit) for package: 1:vlc-core-2.2.5.1-2.el7.nux.x86_64
--> Processing Dependency: libBasicUsageEnvironment.so.0()(64bit) for package: 1:vlc-core-2.2.5.1-2.el7.nux.x86_64
--> Finished Dependency Resolution
Error: Package: 1:vlc-core-2.2.5.1-2.el7.nux.x86_64 (nux-dextop)
           Requires: libliveMedia.so.17()(64bit)
           Available: live555-2013.11.26-1.el7.nux.x86_64 (nux-dextop)
               libliveMedia.so.17()(64bit)
           Installed: live555-2016.07.19-3.el7.x86_64 (@rpmfusion-free-updates)
              ~libliveMedia.so.52()(64bit)
Error: Package: ffmpeg-libs-2.8.15-1.el7.nux.x86_64 (nux-dextop)
           Requires: libx264.so.142()(64bit)
           Available: x264-libs-0.142-4.20140423gite260ea5.el7.nux.x86_64 (nux-dextop)
               libx264.so.142()(64bit)
           Available: x264-libs-0.142-7.20140728gitaf8e768.el7.nux.x86_64 (nux-dextop)
               libx264.so.142()(64bit)
           Available: x264-libs-0.142-11.20141221git6a301b6.el7.nux.x86_64 (nux-dextop)
               libx264.so.142()(64bit)
           Installed: x264-libs-0.148-11.20160614gita5e06b9.el7.x86_64 (@rpmfusion-free-updates)
              ~libx264.so.148()(64bit)
Error: Package: 1:vlc-core-2.2.5.1-2.el7.nux.x86_64 (nux-dextop)
           Requires: libBasicUsageEnvironment.so.0()(64bit)
           Available: live555-2013.11.26-1.el7.nux.x86_64 (nux-dextop)
               libBasicUsageEnvironment.so.0()(64bit)
           Installed: live555-2016.07.19-3.el7.x86_64 (@rpmfusion-free-updates)
              ~libBasicUsageEnvironment.so.1()(64bit)
Error: Package: 1:vlc-core-2.2.5.1-2.el7.nux.x86_64 (nux-dextop)
           Requires: libx264.so.142()(64bit)
           Available: x264-libs-0.142-4.20140423gite260ea5.el7.nux.x86_64 (nux-dextop)
               libx264.so.142()(64bit)
           Available: x264-libs-0.142-7.20140728gitaf8e768.el7.nux.x86_64 (nux-dextop)
               libx264.so.142()(64bit)
           Available: x264-libs-0.142-11.20141221git6a301b6.el7.nux.x86_64 (nux-dextop)
               libx264.so.142()(64bit)
           Installed: x264-libs-0.148-11.20160614gita5e06b9.el7.x86_64 (@rpmfusion-free-updates)
              ~libx264.so.148()(64bit)
Error: Package: 1:vlc-core-2.2.5.1-2.el7.nux.x86_64 (nux-dextop)
           Requires: libUsageEnvironment.so.1()(64bit)
           Available: live555-2013.11.26-1.el7.nux.x86_64 (nux-dextop)
               libUsageEnvironment.so.1()(64bit)
           Installed: live555-2016.07.19-3.el7.x86_64 (@rpmfusion-free-updates)
              ~libUsageEnvironment.so.3()(64bit)
Error: Package: 1:vlc-core-2.2.5.1-2.el7.nux.x86_64 (nux-dextop)
           Requires: libgroupsock.so.1()(64bit)
           Available: live555-2013.11.26-1.el7.nux.x86_64 (nux-dextop)
               libgroupsock.so.1()(64bit)
           Installed: live555-2016.07.19-3.el7.x86_64 (@rpmfusion-free-updates)
              ~libgroupsock.so.8()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
 

User avatar
TrevorH
Forum Moderator
Posts: 23458
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: I can't update

Post by TrevorH » 2018/09/16 14:13:46

You're trying to mix and match rpmfusion and nux-dextop and they each supply some of the same packages. You really need to pick one of them and stick with that one. Installing the keychecker package from EPEL will let you list the things you have currently installed from both of them so you can work out the best one to keep. If you need both then perhaps you need to better prioritise them or perhaps you can limit the packages from one of them by using includepkgs= in the .repo file for that one.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

skuyt
Posts: 2
Joined: 2018/09/16 12:48:17

Re: I can't update

Post by skuyt » 2018/09/18 02:05:23

Hi TrevorH,
I don't know if I did right, but i guess it's working.
I remove the packages with problem using "yum remove ffmpeg-libs"

after that I open nux-dextop repo and add the line priority=1, includepkgs=libx264, libavdevice and rpmfusion priority=5.

Let me know if I did something weird, but for now, it's working. :D
Thanks TrevorH

Post Reply