centos 7 installer doesn't find 82579LM LAN controller

Issues related to configuring your network
Post Reply
Posts: 2
Joined: 2018/10/12 22:11:59

centos 7 installer doesn't find 82579LM LAN controller

Post by huanito » 2018/10/12 23:00:41

My dell T1650 has two ethernet ports, one on the mother board and another on a card.
these are shown by lspci from another distro as
00:19.0 Ethernet controller: Intel Corporation 82579LM Gigabit Network Connection (Lewisville) (rev 04)
04:00.0 Ethernet controller: Broadcom Limited NetXtreme BCM5722 Gigabit Ethernet PCI Express

Running either of these installers:
centos-7-x86_64-DVD-1804.iso; or
the installer only finds the Broadcom port

I've searched the forums here for hits on 82579LM and the only hit was no help, and search engines also provided no respite.

After install when I boot into the new system it does not bring up the broadcom port even though the lan light flashes.
If I run nmtui and acivate the broadcom port with manual setup IP it shows in ip addr as state DOWN but with all the correct details to work

I'd provide a system info dump for y'all but to do that I'd need an internet connection on the system...or laboriously type in getinfo.sh to it then copy by hand the results :(

The 82759LM card is known good and works on 3 other distributions that I've tried on the same machine. They detect it fine but neither of the centos 7 installers can see it.
I'm guessing it's missing a driver but I'd have thought that might be on the installer....otoh maybe I need to download a driver from somewhere and add it during install. Dell doesn't appear to offer LAN drivers and only offers support for redhat enterprise anyway.

Let me know of any more info I can provide to help diagnose this issue.

User avatar
Forum Moderator
Posts: 25537
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: centos 7 installer doesn't find 82579LM LAN controller

Post by TrevorH » 2018/10/12 23:37:41

The Intel card should be supported by the CentOS kernel and is old enough to be pretty thoroughly tested. The driver is the e1000e module and it'll log to the system log as it loads so check what you see from dmesg | grep -i e1000e and see if that gives any clues. You could also try removing it and re-inserting it using modprobe -r e1000e;modprobe e1000e then check dmesg again and see if anything is different. The broadcom card is also supported by the in-kernel tg3 module so you could repeat the procedures above for that too. Might also be worth unloading tg3 and e1000e and then loading only one of them and see if the interface works then.

The PCI ids for the two devices are 8086:1502 and 14e4:165a
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply