webmin can't update

Comments, suggestions, compliments, etc
Post Reply
alexseah119
Posts: 4
Joined: 2018/11/21 03:04:15

webmin can't update

Post by alexseah119 » 2018/12/04 03:45:15

Hi all buddy,

Please help and tech to fix it ,if can. I can't update webmin 1.900-1 noarch in centos 5.11. I do yum update and show out error, i try to manually to update package also same issue! And what's rpmlib(FileDigests) & (rpmlib(PayloadIsXz)

i tried manually update and install epel-release-5-4.noarch.rpm & rpm-4.4.2.3-36.el5_11.x86_64.rpm & webmin-1.900-1.noarch.rpm

Below this error from my update:

Downloading Packages:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
rpmlib(FileDigests) is needed by webmin-1.900-1.noarch
rpmlib(PayloadIsXz) is needed by webmin-1.900-1.noarch
Complete!
(1, [u'Please report this error in http://bugs.centos.org/yum5bug'])

HenrykD
Posts: 69
Joined: 2011/01/14 06:09:52
Location: Poland

Re: webmin can't update

Post by HenrykD » 2018/12/04 06:11:50

Webmin 1.900 will be installed in newer versions of the CentOS (6 i 7).

alexseah119
Posts: 4
Joined: 2018/11/21 03:04:15

Re: webmin can't update

Post by alexseah119 » 2018/12/04 06:13:57

you mean are not support centos 5.11.
And if want you webmin 1.900-1 version in centos 5.11, can??

User avatar
TrevorH
Forum Moderator
Posts: 24052
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: webmin can't update

Post by TrevorH » 2018/12/04 09:01:20

CentOS 5.11 is not supported. It went End of Life nearly 2 years ago and has had no updates since. You need to migrate to a newer version ASAP. CentOS 5 is insecure and becoming more so with every security vulnerability that is discovered.

It would appear that the version of web that you're trying to install has dependencies on the version of rpm that is included in CentOS 6 and higher. It will not install and work on CentOS 5. However, the underlying problem is that you are running a dead operating system and need to reinstall to one that still gets support. At this point, I would skip CentOS 6 and migrate to 7 since 6 is going EOL in about 2 years too.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

HenrykD
Posts: 69
Joined: 2011/01/14 06:09:52
Location: Poland

Re: webmin can't update

Post by HenrykD » 2018/12/04 09:03:56

Last version of Webmin for install in CentOS 5 is 1.890.

User avatar
TrevorH
Forum Moderator
Posts: 24052
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: webmin can't update

Post by TrevorH » 2018/12/04 09:12:52

And the answer is still that you NEED to update your operating system. It's dangerous.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply